aboutsummaryrefslogtreecommitdiff
path: root/math/gambit
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-13 19:18:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-13 19:18:36 +0000
commitc268481174082e4ffe2a8e152b7890b4a3f7e976 (patch)
treec881c72ee080d57497c3905db5547dfec0fb6b23 /math/gambit
parente99e104a08626243ecd1f262dbd471beb28ed480 (diff)
downloadports-c268481174082e4ffe2a8e152b7890b4a3f7e976.tar.gz
ports-c268481174082e4ffe2a8e152b7890b4a3f7e976.zip
Notes
Diffstat (limited to 'math/gambit')
-rw-r--r--math/gambit/Makefile1
-rw-r--r--math/gambit/files/patch-src_libgambit_matrix.cc18
-rw-r--r--math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc29
3 files changed, 48 insertions, 0 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 4aa9f734b695..d093bfca4034 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Library of tools for doing computation in game theory
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c++11-lib
USE_GNOME= gtk20
diff --git a/math/gambit/files/patch-src_libgambit_matrix.cc b/math/gambit/files/patch-src_libgambit_matrix.cc
new file mode 100644
index 000000000000..8139197f2499
--- /dev/null
+++ b/math/gambit/files/patch-src_libgambit_matrix.cc
@@ -0,0 +1,18 @@
+--- src/libgambit/matrix.cc.orig 2014-06-06 16:33:54.000000000 +0400
++++ src/libgambit/matrix.cc 2015-04-13 21:39:08.802909000 +0300
+@@ -25,11 +25,15 @@
+
+ using namespace Gambit;
+
++namespace Gambit {
++
+ template class Matrix<double>;
+ template class Matrix<Rational>;
+ template class Matrix<Integer>;
+ template class Matrix<int>;
+
++}
++
+ template Vector<double> Gambit::operator*(const Vector<double> &,
+ const Matrix<double> &);
+ template Vector<Rational> Gambit::operator*(const Vector<Rational> &,
diff --git a/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
new file mode 100644
index 000000000000..3259dd1b445a
--- /dev/null
+++ b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
@@ -0,0 +1,29 @@
+--- src/tools/enumpoly/pelqhull.cc.orig 2014-05-27 12:07:04.000000000 +0400
++++ src/tools/enumpoly/pelqhull.cc 2015-04-13 20:35:03.596285000 +0300
+@@ -2792,7 +2792,7 @@
+
+ /* zdef_(type,name,doc,average) */
+ zzdef_(zdoc, Zdoc2, "precision statistics", -1);
+- zdef_(zinc, Znewvertex, reinterpret_cast<const char *>(NULL), -1);
++ zdef_(zinc, Znewvertex, static_cast<const char *>(NULL), -1);
+ zdef_(wadd, Wnewvertex, "ave. distance of a new vertex to a facet (not 0s)", Znewvertex);
+ zdef_(wmax, Wnewvertexmax, "max. distance of a new vertex to a facet", -1);
+ zdef_(wmax, Wvertexmax, "max. distance of an output vertex to a facet", -1);
+@@ -2831,7 +2831,7 @@
+ zzdef_(zinc, Zsetplane, "facets created altogether", -1);
+ zdef_(zinc, Ztotridges, "ridges created altogether", -1);
+ zdef_(zinc, Zpostfacets, "facets before post merge", -1);
+- zdef_(zinc, Zangle, reinterpret_cast<const char *>(NULL), -1);
++ zdef_(zinc, Zangle, static_cast<const char *>(NULL), -1);
+ zdef_(wadd, Wangle, "average angle (cosine) for all ridges", Zangle);
+ zdef_(wmax, Wanglemax, "maximum angle (cosine) of a ridge", -1);
+ zdef_(wmin, Wanglemin, "minimum angle (cosine) of a ridge", -1);
+@@ -2946,7 +2946,7 @@
+ zdef_(zinc, Zintersect, "intersections found redundant vertices", -1);
+ zdef_(zadd, Zintersecttot, " ave. number found per vertex", Zintersect);
+ zdef_(zmax, Zintersectmax, " max. found for a vertex", -1);
+- zdef_(zinc, Zvertexridge, reinterpret_cast<const char *>(NULL), -1);
++ zdef_(zinc, Zvertexridge, static_cast<const char *>(NULL), -1);
+ zdef_(zadd, Zvertexridgetot, " ave. number of ridges per tested vertex", Zvertexridge);
+ zdef_(zmax, Zvertexridgemax, " max. number of ridges per tested vertex", -1);
+