aboutsummaryrefslogtreecommitdiff
path: root/math/gap/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-01 13:08:23 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-01 13:08:23 +0000
commit854a2326a4dbcda42a9a17c197725cebacac34cf (patch)
tree468193a36330318548f103c5ae4bf95d125b6323 /math/gap/Makefile
parent2fa12ea571d4bc03026ceace56079f2b917f97ba (diff)
Notes
Diffstat (limited to 'math/gap/Makefile')
-rw-r--r--math/gap/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index ff62fa5d5bb2..c15db0d10c8f 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -18,10 +18,12 @@ DIST_SUBDIR= gap
MAINTAINER= johans@stack.nl
COMMENT= GAP is a system for computational discrete algebra
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
GAP_VERSION= gap4r4
-GAP_PKGTIME= 2005_05_04-17_55_UTC
+GAP_PKGTIME= 2005_07_20-19_29_UTC
GAP_PKGDATE= ${GAP_PKGTIME:C/-.*//:S/_//g}
GAP_WRKSRC= ${WRKSRC}/${GAP_VERSION}
GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
@@ -35,6 +37,9 @@ do-extract:
cd ${GAP_WRKSRC}/pkg; \
${TAR} xyf ${DISTDIR}/${DIST_SUBDIR}/packages-${GAP_PKGTIME}.tar.bz2 )
+post-patch:
+ @${REINPLACE_CMD} -e "s|CC=\'.(CC)\' ||g" ${GAP_WRKSRC}/Makefile.in
+
do-configure:
(cd ${GAP_WRKSRC}; ./configure)