aboutsummaryrefslogtreecommitdiff
path: root/math/gap
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-01 13:08:23 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-01 13:08:23 +0000
commit854a2326a4dbcda42a9a17c197725cebacac34cf (patch)
tree468193a36330318548f103c5ae4bf95d125b6323 /math/gap
parent2fa12ea571d4bc03026ceace56079f2b917f97ba (diff)
downloadports-854a2326a4dbcda42a9a17c197725cebacac34cf.tar.gz
ports-854a2326a4dbcda42a9a17c197725cebacac34cf.zip
Notes
Diffstat (limited to 'math/gap')
-rw-r--r--math/gap/Makefile7
-rw-r--r--math/gap/distinfo4
-rw-r--r--math/gap/files/patch-gap4r4_cnf_configure.out11
-rw-r--r--math/gap/files/patch-gap4r4_src_iostream.c32
4 files changed, 51 insertions, 3 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index ff62fa5d5bb2..c15db0d10c8f 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -18,10 +18,12 @@ DIST_SUBDIR= gap
MAINTAINER= johans@stack.nl
COMMENT= GAP is a system for computational discrete algebra
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
GAP_VERSION= gap4r4
-GAP_PKGTIME= 2005_05_04-17_55_UTC
+GAP_PKGTIME= 2005_07_20-19_29_UTC
GAP_PKGDATE= ${GAP_PKGTIME:C/-.*//:S/_//g}
GAP_WRKSRC= ${WRKSRC}/${GAP_VERSION}
GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
@@ -35,6 +37,9 @@ do-extract:
cd ${GAP_WRKSRC}/pkg; \
${TAR} xyf ${DISTDIR}/${DIST_SUBDIR}/packages-${GAP_PKGTIME}.tar.bz2 )
+post-patch:
+ @${REINPLACE_CMD} -e "s|CC=\'.(CC)\' ||g" ${GAP_WRKSRC}/Makefile.in
+
do-configure:
(cd ${GAP_WRKSRC}; ./configure)
diff --git a/math/gap/distinfo b/math/gap/distinfo
index 4661040ba8ad..e4df797dbab7 100644
--- a/math/gap/distinfo
+++ b/math/gap/distinfo
@@ -1,5 +1,5 @@
-MD5 (gap/packages-2005_05_04-17_55_UTC.tar.bz2) = 94ef53c929b15e03d6fb4280a157bd16
-SIZE (gap/packages-2005_05_04-17_55_UTC.tar.bz2) = 33982065
+MD5 (gap/packages-2005_07_20-19_29_UTC.tar.bz2) = fcb2e1603e47f8ab4926b5ee9e0c3e71
+SIZE (gap/packages-2005_07_20-19_29_UTC.tar.bz2) = 34464002
MD5 (gap/gap4r4p5.tar.bz2) = 61c7d40f950e3e2edf79ad125cc0c2ec
SIZE (gap/gap4r4p5.tar.bz2) = 43758168
MD5 (gap/xtom1r1p2.tar.bz2) = d925ff86d888a5098c5b22ed1625fd4a
diff --git a/math/gap/files/patch-gap4r4_cnf_configure.out b/math/gap/files/patch-gap4r4_cnf_configure.out
new file mode 100644
index 000000000000..ccffbd5f1e9e
--- /dev/null
+++ b/math/gap/files/patch-gap4r4_cnf_configure.out
@@ -0,0 +1,11 @@
+--- gap4r4/cnf/configure.out.orig Fri Jul 22 16:39:30 2005
++++ gap4r4/cnf/configure.out Fri Jul 22 16:39:27 2005
+@@ -3708,6 +3708,8 @@ if test "${gp_cv_cflags+set}" = set; the
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ case "$host-$CC" in
++ *-freebsd* )
++ gp_cv_cflags="";;
+ *-gcc | *-linux*-cc )
+ gp_cv_cflags="-Wall -g -O2";;
+ i686-*-egcs )
diff --git a/math/gap/files/patch-gap4r4_src_iostream.c b/math/gap/files/patch-gap4r4_src_iostream.c
new file mode 100644
index 000000000000..5791a2b44425
--- /dev/null
+++ b/math/gap/files/patch-gap4r4_src_iostream.c
@@ -0,0 +1,32 @@
+--- gap4r4/src/iostream.c.orig Thu Feb 19 08:28:32 2004
++++ gap4r4/src/iostream.c Tue Jun 14 18:41:51 2005
+@@ -340,9 +340,9 @@ static UInt GetMasterPty ( int * pty, Ch
+ return 0;
+
+ # else
+- static int devindex = 0;
+- static int letter = 0;
+- static int slave = 0;
++ int devindex = 0;
++ int letter = 0;
++ int slave = 0;
+
+ while ( SYS_PTYCHAR1[letter] )
+ {
+@@ -355,12 +355,16 @@ static UInt GetMasterPty ( int * pty, Ch
+ namepty[strlen(namepty)-1] = SYS_PTYCHAR2[devindex];
+
+ if ( (*pty = open( namepty, O_RDWR )) >= 0 )
++ {
+ if ( (slave = open( nametty, O_RDWR, 0 )) >= 0 )
+ {
+ close(slave);
+ (void) devindex++;
+ return 0;
+ }
++ else
++ close(*pty);
++ }
+ devindex++;
+ }
+ devindex = 0;