aboutsummaryrefslogtreecommitdiff
path: root/math/gdcalc
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 13:14:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-18 13:14:02 +0000
commitcdeb3e55b5e0b5490913115b9fc05184e70e2f91 (patch)
treec0e8a1389f7d85174e01d4f53b952d4e1501691c /math/gdcalc
parent168dfd58b7e1ccd2f60ffc09e3d8f53590e16869 (diff)
downloadports-cdeb3e55b5e0b5490913115b9fc05184e70e2f91.tar.gz
ports-cdeb3e55b5e0b5490913115b9fc05184e70e2f91.zip
Notes
Diffstat (limited to 'math/gdcalc')
-rw-r--r--math/gdcalc/Makefile1
-rw-r--r--math/gdcalc/files/patch-Makefile.in30
2 files changed, 30 insertions, 1 deletions
diff --git a/math/gdcalc/Makefile b/math/gdcalc/Makefile
index ec06343b5a8b..d160fa09f151 100644
--- a/math/gdcalc/Makefile
+++ b/math/gdcalc/Makefile
@@ -18,5 +18,4 @@ GNU_CONFIGURE= yes
LDFLAGS+= -lm
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/gdcalc/files/patch-Makefile.in b/math/gdcalc/files/patch-Makefile.in
new file mode 100644
index 000000000000..dbba59e5a7e0
--- /dev/null
+++ b/math/gdcalc/files/patch-Makefile.in
@@ -0,0 +1,30 @@
+--- Makefile.in.orig 2014-06-18 21:06:00.354774154 +0800
++++ Makefile.in 2014-06-18 21:08:48.970775730 +0800
+@@ -595,19 +595,19 @@ dist-hook:
+ install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+- $(mkinstalldirs) $(prefix)/share/pixmaps; \
+- $(mkinstalldirs) $(prefix)/share/icons; \
++ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/pixmaps; \
++ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/icons; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+- $(INSTALL_DATA) $$pixmap $(prefix)/share/pixmaps; \
+- $(INSTALL_DATA) $$pixmap $(prefix)/share/icons; \
++ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(prefix)/share/pixmaps; \
++ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(prefix)/share/icons; \
+ fi \
+ done \
+ fi
+- $(mkinstalldirs) $(prefix)/share/gnome/apps/Utilities
+- cp $(srcdir)/gdcalc.desktop $(prefix)/share/gnome/apps/Utilities
+- $(mkinstalldirs) $(prefix)/share/applnk/Applications
+- cp $(srcdir)/gdcalc.kdelnk $(prefix)/share/applnk/Applications
++ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/gnome/apps/Utilities
++ cp $(srcdir)/gdcalc.desktop $(DESTDIR)$(prefix)/share/gnome/apps/Utilities
++ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/applnk/Applications
++ cp $(srcdir)/gdcalc.kdelnk $(DESTDIR)$(prefix)/share/applnk/Applications
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: