aboutsummaryrefslogtreecommitdiff
path: root/math/geg
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
commit89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df (patch)
treedab293772a4c12d5e7f6c0f30c1e8ae09e1cfe4d /math/geg
parent65b63032bfb3a3f1c8ac4ee660ac83927b43c92a (diff)
downloadports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.tar.gz
ports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.zip
Notes
Diffstat (limited to 'math/geg')
-rw-r--r--math/geg/Makefile15
-rw-r--r--math/geg/files/patch-ac12
2 files changed, 22 insertions, 5 deletions
diff --git a/math/geg/Makefile b/math/geg/Makefile
index 0169dc05c2f6..717e1276952d 100644
--- a/math/geg/Makefile
+++ b/math/geg/Makefile
@@ -16,12 +16,17 @@ MAINTAINER= domi@saargate.de
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-CONFIGURE_ENV= LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+USE_X_PREFIX= yes
+USE_AUTOMAKE= yes
+AUTOMAKE= automake -a -i
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+MAN1= geg.1
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/src/geg ${PREFIX}/bin
+pre-configure:
+ @cd ${WRKSRC}; aclocal -I ${X11BASE}/share/aclocal
.include <bsd.port.mk>
diff --git a/math/geg/files/patch-ac b/math/geg/files/patch-ac
new file mode 100644
index 000000000000..8c2451c0837d
--- /dev/null
+++ b/math/geg/files/patch-ac
@@ -0,0 +1,12 @@
+--- configure.in.orig Wed Nov 24 08:01:41 1999
++++ configure.in Sat Jul 1 18:57:50 2000
+@@ -30,8 +30,7 @@
+ fi
+ fi
+
+-AC_CHECK_PROG(GTK_CFLAGS, gtk-config, `gtk-config --cflags`,,,)
+-AC_CHECK_PROG(GTK_LIBS, gtk-config, `gtk-config --libs`,,,)
++AM_PATH_GTK(1.2.0, , AC_MSG_ERROR(GTK+ is not installed or badly configured on your system...))
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -libs: