aboutsummaryrefslogtreecommitdiff
path: root/math/geogebra
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-28 08:41:38 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-28 08:41:38 +0000
commit0a02c2e8b3941dd77494ff6d32b298ea66541bc0 (patch)
treeac6df66a8a26d53745a9256295a5e6a5e3c5d0c8 /math/geogebra
parenta8c0494876ec16b1dd7430ba32b5a63197ceaea5 (diff)
downloadports-0a02c2e8b3941dd77494ff6d32b298ea66541bc0.tar.gz
ports-0a02c2e8b3941dd77494ff6d32b298ea66541bc0.zip
Notes
Diffstat (limited to 'math/geogebra')
-rw-r--r--math/geogebra/Makefile11
-rw-r--r--math/geogebra/distinfo4
-rw-r--r--math/geogebra/files/geogebra.sh.in18
-rw-r--r--math/geogebra/pkg-message4
-rw-r--r--math/geogebra/pkg-plist2
5 files changed, 29 insertions, 10 deletions
diff --git a/math/geogebra/Makefile b/math/geogebra/Makefile
index 73040db5fb5c..acefdc20a0cc 100644
--- a/math/geogebra/Makefile
+++ b/math/geogebra/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= geogebra
-PORTVERSION= 5.0.226.0
+PORTVERSION= 5.0.231.0
CATEGORIES= math java
MASTER_SITES= http://download.geogebra.org/installers/5.0/ \
http://freebsd.uzsolt.hu/src/
@@ -16,8 +16,6 @@ LICENSE_NAME= GeoGebra Non-Commercial License Agreement
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
-RUN_DEPENDS= bash:shells/bash
-
USE_LINUX?= c6
USE_LINUX_APPS= xorglibs
@@ -32,14 +30,15 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
JAVADIR= jre1.7.0_45-i686
SHEBANG_FILES= geogebra-portable geogebra/geogebra
+SUB_FILES= geogebra.desktop geogebra.sh
+SUB_LIST= JAVADIR=${DATADIR}/${JAVADIR}
+
post-patch:
@${REINPLACE_CMD} -e 's,arch,/compat/linux/bin/arch,' ${WRKSRC}/geogebra-portable
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/geogebra/geogebra ${STAGEDIR}${DATADIR}/${PORTNAME}/geogebra
- ${INSTALL_SCRIPT} ${WRKSRC}/geogebra-portable ${STAGEDIR}${DATADIR}
- ${LN} -s ${DATADIR}/geogebra-portable ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/geogebra.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/geogebra/*.jar ${STAGEDIR}${DATADIR}/${PORTNAME}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${JAVADIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/${JAVADIR}/bin/java ${STAGEDIR}${DATADIR}/${JAVADIR}/bin
diff --git a/math/geogebra/distinfo b/math/geogebra/distinfo
index 03c789504089..0e68e3c9f8fd 100644
--- a/math/geogebra/distinfo
+++ b/math/geogebra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GeoGebra-Linux-Portable-5.0.226.0.tar.bz2) = b03184633bc440a7495559d3394ab594785c321c7d5ae7c197dd7e265eb44bca
-SIZE (GeoGebra-Linux-Portable-5.0.226.0.tar.bz2) = 100730252
+SHA256 (GeoGebra-Linux-Portable-5.0.231.0.tar.bz2) = e3e1db941bd45ee3c34916bfd7943b6869393ea133f5a95a477896450b197c57
+SIZE (GeoGebra-Linux-Portable-5.0.231.0.tar.bz2) = 100748960
diff --git a/math/geogebra/files/geogebra.sh.in b/math/geogebra/files/geogebra.sh.in
new file mode 100644
index 000000000000..b1b9dcd36dd8
--- /dev/null
+++ b/math/geogebra/files/geogebra.sh.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+JAVACMD=%%JAVADIR%%/bin/java
+GG_XMS="32m"
+GG_XMX="1024m"
+GG_SETTINGS_FILE="${HOME}/.config/geogebra/geogebra.properties"
+CLASS=org.geogebra.desktop.GeoGebra3D
+
+JAVA_OPTS="-Xms${GG_XMS} -Xmx${GG_XMX} -Dawt.useSystemAAFontSettings=on"
+
+exec ${JAVACMD} ${JAVA_OPTS} \
+ -cp %%DATADIR%%/geogebra/geogebra.jar \
+ "-Xbootclasspath/a:${JFXRT}" \
+ ${CLASS} \
+ --versionCheckAllow=false --settingsFile=${GG_SETTINGS_FILE} \
+ --logLevel=WARN \
+ $*
+
diff --git a/math/geogebra/pkg-message b/math/geogebra/pkg-message
new file mode 100644
index 000000000000..2fbd3d81138a
--- /dev/null
+++ b/math/geogebra/pkg-message
@@ -0,0 +1,4 @@
+For proper work you should mount linproc filesystem into /proc or
+/compat/linux/proc.
+
+See more on linprocfs(5).
diff --git a/math/geogebra/pkg-plist b/math/geogebra/pkg-plist
index 8bc41cc3d58e..bc7856f3faf3 100644
--- a/math/geogebra/pkg-plist
+++ b/math/geogebra/pkg-plist
@@ -1,8 +1,6 @@
bin/geogebra
share/applications/geogebra.desktop
-%%DATADIR%%/geogebra-portable
%%DATADIR%%/geogebra/OpenGeoProver.jar
-%%DATADIR%%/geogebra/geogebra
%%DATADIR%%/geogebra/geogebra.jar
%%DATADIR%%/geogebra/geogebra_3d.jar
%%DATADIR%%/geogebra/geogebra_algos.jar