aboutsummaryrefslogtreecommitdiff
path: root/math/geogram
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-09 21:49:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-09 21:49:39 +0000
commit78cc0c2661e500e0518a93ffee92c469abb340c1 (patch)
treeea7a94b138224f067b3807991967420d7b3d9046 /math/geogram
parent9b3e201628ac928c9edec324a0abf960e52ffdf3 (diff)
downloadports-78cc0c2661e500e0518a93ffee92c469abb340c1.tar.gz
ports-78cc0c2661e500e0518a93ffee92c469abb340c1.zip
math/geogram: Change to shared libraries
Notes
Notes: svn path=/head/; revision=487093
Diffstat (limited to 'math/geogram')
-rw-r--r--math/geogram/Makefile6
-rw-r--r--math/geogram/files/patch-src_lib_geogram_NL_nl__private.h11
-rw-r--r--math/geogram/pkg-plist8
3 files changed, 20 insertions, 5 deletions
diff --git a/math/geogram/Makefile b/math/geogram/Makefile
index a5754b5bc839..887b0e73afec 100644
--- a/math/geogram/Makefile
+++ b/math/geogram/Makefile
@@ -2,6 +2,7 @@
PORTNAME= geogram
DISTVERSION= 1.6.9
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= https://gforge.inria.fr/frs/download.php/file/37779/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -17,14 +18,13 @@ LIB_DEPENDS= libglfw.so:graphics/glfw
USES= cmake:outsource gl localbase:ldflags
USE_XORG= x11 xcursor xi xinerama xrandr xxf86vm
USE_GL= gl glu
+USE_LDCONFIG= yes
-CMAKE_ON= GEOGRAM_USE_SYSTEM_GLFW3
+CMAKE_ON= GEOGRAM_USE_SYSTEM_GLFW3 VORPALINE_BUILD_DYNAMIC
CMAKE_ARGS= -DVORPALINE_PLATFORM:STRING=FreeBSD
LDFLAGS+= -pthread
post-stage:
@${RMDIR} ${STAGEDIR}${PREFIX}/include/geogram1/geogram_gfx/glup_viewer/colormaps
-# geogram installs static libraries. I couldn't make it build with shared libraries due to link errors. I asked Bruno.Levy@inria.fr to fix this (via e-mail).
-
.include <bsd.port.mk>
diff --git a/math/geogram/files/patch-src_lib_geogram_NL_nl__private.h b/math/geogram/files/patch-src_lib_geogram_NL_nl__private.h
new file mode 100644
index 000000000000..185c9f84e254
--- /dev/null
+++ b/math/geogram/files/patch-src_lib_geogram_NL_nl__private.h
@@ -0,0 +1,11 @@
+--- src/lib/geogram/NL/nl_private.h.orig 2018-12-09 21:38:58 UTC
++++ src/lib/geogram/NL/nl_private.h
+@@ -67,7 +67,7 @@
+ #define NL_OS_APPLE
+ #endif
+
+-#if defined(__linux__) || defined(__ANDROID__) || defined(NL_OS_APPLE)
++#if defined(__linux__) || defined(__FreeBSD__) || defined(__ANDROID__) || defined(NL_OS_APPLE)
+ /**
+ * \brief Defined if compiled on a Unix-like platform.
+ */
diff --git a/math/geogram/pkg-plist b/math/geogram/pkg-plist
index b95941a91302..9ff82b8dabdc 100644
--- a/math/geogram/pkg-plist
+++ b/math/geogram/pkg-plist
@@ -305,7 +305,11 @@ include/geogram1/geogram_gfx/third_party/imgui_fonts/roboto_medium.h
include/geogram1/geogram_gfx/third_party/imgui_lua_bindings/imgui_iterator.h
include/geogram1/geogram_gfx/third_party/quicktext/glQuickText.h
lib/cmake/modules/FindGeogram.cmake
-lib/libgeogram.a
-lib/libgeogram_gfx.a
+lib/libgeogram.so
+lib/libgeogram.so.1
+lib/libgeogram.so.1.6.9
+lib/libgeogram_gfx.so
+lib/libgeogram_gfx.so.1
+lib/libgeogram_gfx.so.1.6.9
libdata/pkgconfig/geogram1.pc
libdata/pkgconfig/geogram_gfx1.pc