aboutsummaryrefslogtreecommitdiff
path: root/math/gexpr
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-13 21:45:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-13 21:45:12 +0000
commita69120c56ad1ec496b1a3da743f2bc8df6a5af14 (patch)
tree38d9b496ffaccb51a98727e77b9b3cd49d8bfc1d /math/gexpr
parentb7cf824802f962fef606c101dfe0fc0b3fc3380a (diff)
downloadports-a69120c56ad1ec496b1a3da743f2bc8df6a5af14.tar.gz
ports-a69120c56ad1ec496b1a3da743f2bc8df6a5af14.zip
add gexpr
A shell calculator
Notes
Notes: svn path=/head/; revision=43961
Diffstat (limited to 'math/gexpr')
-rw-r--r--math/gexpr/Makefile24
-rw-r--r--math/gexpr/distinfo1
-rw-r--r--math/gexpr/files/patch-Makefile16
-rw-r--r--math/gexpr/pkg-comment1
-rw-r--r--math/gexpr/pkg-descr3
-rw-r--r--math/gexpr/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/math/gexpr/Makefile b/math/gexpr/Makefile
new file mode 100644
index 000000000000..ab0520086f63
--- /dev/null
+++ b/math/gexpr/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# New ports collection makefile for: gexpr
+# Date created: Jun 14, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gexpr
+PORTVERSION= 2.0.2
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/math/calc
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+MAN1= gexpr.1
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/math/gexpr/distinfo b/math/gexpr/distinfo
new file mode 100644
index 000000000000..8ca9c57bba1d
--- /dev/null
+++ b/math/gexpr/distinfo
@@ -0,0 +1 @@
+MD5 (gexpr-2.0.2.tar.gz) = e4cb9b62b1f363bbf788f455ef144885
diff --git a/math/gexpr/files/patch-Makefile b/math/gexpr/files/patch-Makefile
new file mode 100644
index 000000000000..54f3d5c71b87
--- /dev/null
+++ b/math/gexpr/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig Thu Jun 14 05:36:02 2001
++++ Makefile Thu Jun 14 05:39:22 2001
+@@ -1,11 +1,10 @@
+ # Makefile for gexpr
+ # Last updated: 10 February 1999
+
+-CC = gcc
+-OPTS = -s -O2 -Wall
++OPTS = ${CFLAGS} -I%%LOCALBASE%%/include
+ OBJS = eval.o read_token.o commands.o output.o errors.o gexpr.o
+ GEXPR = gexpr
+-LIBS = -lm
++LIBS = -lm -L%%LOCALBASE%%/lib -lgnugetopt
+
+ all: $(GEXPR)
+
diff --git a/math/gexpr/pkg-comment b/math/gexpr/pkg-comment
new file mode 100644
index 000000000000..23a6028cafeb
--- /dev/null
+++ b/math/gexpr/pkg-comment
@@ -0,0 +1 @@
+A shell calculator
diff --git a/math/gexpr/pkg-descr b/math/gexpr/pkg-descr
new file mode 100644
index 000000000000..3c1816295523
--- /dev/null
+++ b/math/gexpr/pkg-descr
@@ -0,0 +1,3 @@
+Gexpr is a shell calculator with floating point, standard C functions,
+relational operators, and output in base 2/8/10/16. It is a light alternative
+to bc(1). It can also be used to add floating point math to shell scripts.
diff --git a/math/gexpr/pkg-plist b/math/gexpr/pkg-plist
new file mode 100644
index 000000000000..619efe0185b5
--- /dev/null
+++ b/math/gexpr/pkg-plist
@@ -0,0 +1 @@
+bin/gexpr