aboutsummaryrefslogtreecommitdiff
path: root/math/ggobi/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2013-05-06 18:26:22 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2013-05-06 18:26:22 +0000
commit08c7dca3fa68469d399266b0a40bbca2e984ddfa (patch)
tree4bb52c4b024befde1f9099e156529f870a8e021f /math/ggobi/Makefile
parent20bba287672ea66b00a43acca1cc983639121960 (diff)
downloadports-08c7dca3fa68469d399266b0a40bbca2e984ddfa.tar.gz
ports-08c7dca3fa68469d399266b0a40bbca2e984ddfa.zip
Notes
Diffstat (limited to 'math/ggobi/Makefile')
-rw-r--r--math/ggobi/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/math/ggobi/Makefile b/math/ggobi/Makefile
index 152249d86fcb..06d90d4e285a 100644
--- a/math/ggobi/Makefile
+++ b/math/ggobi/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: ggobi
-# Date created: 31 January 2010
-# Whom: rhurlin
-#
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
# $FreeBSD$
-#
PORTNAME= ggobi
PORTVERSION= 2.1.9
@@ -33,6 +29,15 @@ post-patch:
${WRKSRC}/src/ggobi-renderer-factory.c \
${WRKSRC}/src/ggobi-renderer.c
+post-configure:
+# build gets irritated by the presence of an external graphviz version
+ @${REINPLACE_CMD} -e 's|#define HAVE_LIBGVC 1|/* #define HAVE_LIBGVC 1 */|' \
+ ${WRKSRC}/plugins/GraphLayout/config.h
+ @${REINPLACE_CMD} -e 's|LIBGVC_CFLAGS = -I${LOCALBASE}/include/graphviz|LIBGVC_CFLAGS =|' \
+ ${WRKSRC}/plugins/GraphLayout/Makefile
+ @${REINPLACE_CMD} -e 's|LIBGVC_LIBS = -L${LOCALBASE}/lib/graphviz -lgvc -lgraph -lcdt|LIBGVC_LIBS =|' \
+ ${WRKSRC}/plugins/GraphLayout/Makefile
+
post-install:
${MKDIR} ${PREFIX}/etc/xdg/ggobi
${INSTALL_DATA} ${WRKSRC}/ggobirc ${PREFIX}/etc/xdg/ggobi/ggobirc.sample