aboutsummaryrefslogtreecommitdiff
path: root/math/glgraph
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-06-07 15:26:54 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-06-07 15:26:54 +0000
commit3c5444b1a60594e22dacf360821993a84f322b3a (patch)
tree69abefaf6c72f5fc07d64026ca0d8840be0ab7af /math/glgraph
parentfb67c0e0e0e7164b53971faf10fd214b8a360fa9 (diff)
downloadports-3c5444b1a60594e22dacf360821993a84f322b3a.tar.gz
ports-3c5444b1a60594e22dacf360821993a84f322b3a.zip
- Add staging support
- Switch to PLIST_FILES, PORTDOCS from pkg-plist - Convert to new options framework - Remove leading article from COMMENT - Fix shebang in script, bump PORTREVISION
Notes
Notes: svn path=/head/; revision=356912
Diffstat (limited to 'math/glgraph')
-rw-r--r--math/glgraph/Makefile22
-rw-r--r--math/glgraph/pkg-plist3
2 files changed, 12 insertions, 13 deletions
diff --git a/math/glgraph/Makefile b/math/glgraph/Makefile
index 3bea64ccb31a..5ebb180a01cb 100644
--- a/math/glgraph/Makefile
+++ b/math/glgraph/Makefile
@@ -3,29 +3,31 @@
PORTNAME= glgraph
PORTVERSION= 0.2.6
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MASTER_SITES= http://glgraph.kaosu.ch/downl/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= An OpenGL based function grapher
+COMMENT= OpenGL based function grapher
RUN_DEPENDS= p5-OpenGL>=0:${PORTSDIR}/graphics/p5-OpenGL \
import:${PORTSDIR}/graphics/ImageMagick
-USES= perl5
-USE_BZIP2= yes
+USES= perl5 shebangfix tar:bzip2
USE_PERL5= run
+SHEBANG_FILES= ${PORTNAME}
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
+PLIST_FILES= bin/glgraph
+PORTDOCS= documentation.html
+
+OPTIONS_DEFINE= DOCS
+
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/glgraph ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/documentation.html ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/glgraph ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/math/glgraph/pkg-plist b/math/glgraph/pkg-plist
deleted file mode 100644
index 68ad67cef005..000000000000
--- a/math/glgraph/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/glgraph
-%%PORTDOCS%%%%DOCSDIR%%/documentation.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%