aboutsummaryrefslogtreecommitdiff
path: root/math/glm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-03-12 15:55:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-03-12 15:55:03 +0000
commitf98c6bc93bea9653028a51b3e0719c88651fa6ee (patch)
treec27ce61ac06e15c6b25e6e310b3c8884f652632e /math/glm
parentfb1d3219bf1a62724622628421cdcc6c03e91e68 (diff)
downloadports-f98c6bc93bea9653028a51b3e0719c88651fa6ee.tar.gz
ports-f98c6bc93bea9653028a51b3e0719c88651fa6ee.zip
Notes
Diffstat (limited to 'math/glm')
-rw-r--r--math/glm/Makefile25
-rw-r--r--math/glm/distinfo6
-rw-r--r--math/glm/files/glm.pc.in7
-rw-r--r--math/glm/files/patch-CMakeLists.txt11
-rw-r--r--math/glm/files/patch-glm_ext_quaternion__common.inl11
-rw-r--r--math/glm/files/patch-glm_simd_platform.h222
-rw-r--r--math/glm/files/patch-test_core_core__setup__message.cpp133
-rw-r--r--math/glm/pkg-plist208
8 files changed, 225 insertions, 398 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index ca1e6292aab2..2495ceea9ce8 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.8.5
-PORTREVISION= 4
+PORTVERSION= 0.9.9.8
PORTEPOCH= 1
CATEGORIES= math graphics
@@ -11,16 +10,32 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ mathematics library for software based on the OpenGL GLSL
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/copying.txt
USES= cmake compiler:c++11-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= g-truc
-
NO_ARCH= yes
-OPTIONS_DEFINE= TEST
+SUB_FILES= glm.pc
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= TEST DOCS
TEST_CMAKE_BOOL= GLM_TEST_ENABLE
TEST_TEST_TARGET= test
+post-patch:
+ @${REINPLACE_CMD} -e '/printf/ s|EndTime - StartTime|static_cast<long>(&)|' \
+ ${WRKSRC}/test/core/core_func_matrix.cpp
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "glm" ${STAGEDIR}${PREFIX}/include \
+ "-not -name CMakeLists.txt"
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/cmake/glm
+ ${INSTALL_DATA} ${WRKSRC}/cmake/glm/*.cmake ${STAGEDIR}${PREFIX}/lib/cmake/glm
+ ${INSTALL_DATA} ${WRKDIR}/glm.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+
+do-install-DOCS-on:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "doc *.md" ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/math/glm/distinfo b/math/glm/distinfo
index 850ff5c0732e..63cca9cfb238 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512334474
-SHA256 (g-truc-glm-0.9.8.5_GH0.tar.gz) = 80cf9958f06e5504f8df45ea14fde87411270102930be31c0a16c0da430fc920
-SIZE (g-truc-glm-0.9.8.5_GH0.tar.gz) = 3756809
+TIMESTAMP = 1615332075
+SHA256 (g-truc-glm-0.9.9.8_GH0.tar.gz) = 7d508ab72cb5d43227a3711420f06ff99b0a0cb63ee2f93631b162bfe1fe9592
+SIZE (g-truc-glm-0.9.9.8_GH0.tar.gz) = 4368032
diff --git a/math/glm/files/glm.pc.in b/math/glm/files/glm.pc.in
new file mode 100644
index 000000000000..dccab04acd83
--- /dev/null
+++ b/math/glm/files/glm.pc.in
@@ -0,0 +1,7 @@
+prefix=%%PREFIX%%
+includedir=${prefix}/include
+
+Name: GLM
+Description: OpenGL Mathematics
+Version: 0.9.8
+Cflags: -I${includedir}
diff --git a/math/glm/files/patch-CMakeLists.txt b/math/glm/files/patch-CMakeLists.txt
deleted file mode 100644
index f1a050902796..000000000000
--- a/math/glm/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2017-06-04 05:59:53 UTC
-+++ CMakeLists.txt
-@@ -226,7 +226,7 @@ configure_file(
- # install pkg-config file
- install(
- FILES "${CMAKE_CURRENT_BINARY_DIR}/glm.pc"
-- DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig"
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/../libdata/pkgconfig"
- )
-
- export(PACKAGE glm)
diff --git a/math/glm/files/patch-glm_ext_quaternion__common.inl b/math/glm/files/patch-glm_ext_quaternion__common.inl
new file mode 100644
index 000000000000..6a489b479f5d
--- /dev/null
+++ b/math/glm/files/patch-glm_ext_quaternion__common.inl
@@ -0,0 +1,11 @@
+--- glm/ext/quaternion_common.inl.orig 2020-04-13 17:41:16 UTC
++++ glm/ext/quaternion_common.inl
+@@ -104,7 +104,7 @@ namespace glm
+ {
+ // Graphics Gems III, page 96
+ T angle = acos(cosTheta);
+- T phi = angle + k * glm::pi<T>();
++ T phi = angle + static_cast<T>(k) * glm::pi<T>();
+ return (sin(angle - a * phi)* x + sin(a * phi) * z) / sin(angle);
+ }
+ }
diff --git a/math/glm/files/patch-glm_simd_platform.h b/math/glm/files/patch-glm_simd_platform.h
deleted file mode 100644
index 02040deb1a4e..000000000000
--- a/math/glm/files/patch-glm_simd_platform.h
+++ /dev/null
@@ -1,222 +0,0 @@
---- glm/simd/platform.h.orig 2018-08-09 13:49:02 UTC
-+++ glm/simd/platform.h
-@@ -77,58 +77,37 @@
-
- // Intel
- #define GLM_COMPILER_INTEL 0x00100000
--#define GLM_COMPILER_INTEL12 0x00100010
--#define GLM_COMPILER_INTEL12_1 0x00100020
--#define GLM_COMPILER_INTEL13 0x00100030
- #define GLM_COMPILER_INTEL14 0x00100040
- #define GLM_COMPILER_INTEL15 0x00100050
- #define GLM_COMPILER_INTEL16 0x00100060
-+#define GLM_COMPILER_INTEL17 0x00100070
-
- // Visual C++ defines
- #define GLM_COMPILER_VC 0x01000000
--#define GLM_COMPILER_VC10 0x01000090
--#define GLM_COMPILER_VC11 0x010000A0
- #define GLM_COMPILER_VC12 0x010000B0
- #define GLM_COMPILER_VC14 0x010000C0
- #define GLM_COMPILER_VC15 0x010000D0
-+#define GLM_COMPILER_VC16 0x010000E0
-
- // GCC defines
- #define GLM_COMPILER_GCC 0x02000000
--#define GLM_COMPILER_GCC44 0x020000B0
--#define GLM_COMPILER_GCC45 0x020000C0
- #define GLM_COMPILER_GCC46 0x020000D0
- #define GLM_COMPILER_GCC47 0x020000E0
- #define GLM_COMPILER_GCC48 0x020000F0
- #define GLM_COMPILER_GCC49 0x02000100
--#define GLM_COMPILER_GCC50 0x02000200
--#define GLM_COMPILER_GCC51 0x02000300
--#define GLM_COMPILER_GCC52 0x02000400
--#define GLM_COMPILER_GCC53 0x02000500
--#define GLM_COMPILER_GCC54 0x02000600
--#define GLM_COMPILER_GCC60 0x02000700
--#define GLM_COMPILER_GCC61 0x02000800
--#define GLM_COMPILER_GCC62 0x02000900
--#define GLM_COMPILER_GCC70 0x02000A00
--#define GLM_COMPILER_GCC71 0x02000B00
--#define GLM_COMPILER_GCC72 0x02000C00
--#define GLM_COMPILER_GCC80 0x02000D00
-+#define GLM_COMPILER_GCC5 0x02000200
-+#define GLM_COMPILER_GCC6 0x02000300
-+#define GLM_COMPILER_GCC7 0x02000400
-+#define GLM_COMPILER_GCC8 0x02000500
-
- // CUDA
- #define GLM_COMPILER_CUDA 0x10000000
--#define GLM_COMPILER_CUDA40 0x10000040
--#define GLM_COMPILER_CUDA41 0x10000050
--#define GLM_COMPILER_CUDA42 0x10000060
--#define GLM_COMPILER_CUDA50 0x10000070
--#define GLM_COMPILER_CUDA60 0x10000080
--#define GLM_COMPILER_CUDA65 0x10000090
- #define GLM_COMPILER_CUDA70 0x100000A0
- #define GLM_COMPILER_CUDA75 0x100000B0
- #define GLM_COMPILER_CUDA80 0x100000C0
-
- // Clang
- #define GLM_COMPILER_CLANG 0x20000000
--#define GLM_COMPILER_CLANG32 0x20000030
--#define GLM_COMPILER_CLANG33 0x20000040
- #define GLM_COMPILER_CLANG34 0x20000050
- #define GLM_COMPILER_CLANG35 0x20000060
- #define GLM_COMPILER_CLANG36 0x20000070
-@@ -148,20 +127,16 @@
- # define GLM_COMPILER GLM_COMPILER_UNKNOWN
-
- #elif defined(__INTEL_COMPILER)
--# if __INTEL_COMPILER == 1200
--# define GLM_COMPILER GLM_COMPILER_INTEL12
--# elif __INTEL_COMPILER == 1210
--# define GLM_COMPILER GLM_COMPILER_INTEL12_1
--# elif __INTEL_COMPILER == 1300
--# define GLM_COMPILER GLM_COMPILER_INTEL13
-+# if (__clang_major__ < 1400)
-+# error "GLM requires ICC 2013 SP1 or newer"
- # elif __INTEL_COMPILER == 1400
- # define GLM_COMPILER GLM_COMPILER_INTEL14
- # elif __INTEL_COMPILER == 1500
- # define GLM_COMPILER GLM_COMPILER_INTEL15
--# elif __INTEL_COMPILER >= 1600
-+# elif __INTEL_COMPILER == 1600
- # define GLM_COMPILER GLM_COMPILER_INTEL16
--# else
--# define GLM_COMPILER GLM_COMPILER_INTEL
-+# elif __INTEL_COMPILER >= 1700
-+# define GLM_COMPILER GLM_COMPILER_INTEL17
- # endif
-
- // CUDA
-@@ -169,37 +144,27 @@
- # if !defined(CUDA_VERSION) && !defined(GLM_FORCE_CUDA)
- # include <cuda.h> // make sure version is defined since nvcc does not define it itself!
- # endif
--# if CUDA_VERSION < 3000
--# error "GLM requires CUDA 3.0 or higher"
-+# if CUDA_VERSION < 7000
-+# error "GLM requires CUDA 7.0 or higher"
- # else
- # define GLM_COMPILER GLM_COMPILER_CUDA
- # endif
-
- // Clang
- #elif defined(__clang__)
--# if defined(__apple_build_version__)
--# if __clang_major__ == 5 && __clang_minor__ == 0
--# define GLM_COMPILER GLM_COMPILER_CLANG33
--# elif __clang_major__ == 5 && __clang_minor__ == 1
--# define GLM_COMPILER GLM_COMPILER_CLANG34
-+# if GLM_PLATFORM & GLM_PLATFORM_APPLE
-+# if (__clang_major__ < 6)
-+# error "GLM requires Clang 3.4 / Apple Clang 6.0 or higher"
- # elif __clang_major__ == 6 && __clang_minor__ == 0
- # define GLM_COMPILER GLM_COMPILER_CLANG35
- # elif __clang_major__ == 6 && __clang_minor__ >= 1
- # define GLM_COMPILER GLM_COMPILER_CLANG36
- # elif __clang_major__ >= 7
- # define GLM_COMPILER GLM_COMPILER_CLANG37
--# else
--# define GLM_COMPILER GLM_COMPILER_CLANG
- # endif
- # else
--# if __clang_major__ == 3 && __clang_minor__ == 0
--# define GLM_COMPILER GLM_COMPILER_CLANG30
--# elif __clang_major__ == 3 && __clang_minor__ == 1
--# define GLM_COMPILER GLM_COMPILER_CLANG31
--# elif __clang_major__ == 3 && __clang_minor__ == 2
--# define GLM_COMPILER GLM_COMPILER_CLANG32
--# elif __clang_major__ == 3 && __clang_minor__ == 3
--# define GLM_COMPILER GLM_COMPILER_CLANG33
-+# if ((__clang_major__ == 3) && (__clang_minor__ < 4)) || (__clang_major__ < 3)
-+# error "GLM requires Clang 3.4 or higher"
- # elif __clang_major__ == 3 && __clang_minor__ == 4
- # define GLM_COMPILER GLM_COMPILER_CLANG34
- # elif __clang_major__ == 3 && __clang_minor__ == 5
-@@ -220,39 +185,25 @@
- # define GLM_COMPILER GLM_COMPILER_CLANG42
- # elif __clang_major__ >= 4
- # define GLM_COMPILER GLM_COMPILER_CLANG42
--# else
--# define GLM_COMPILER GLM_COMPILER_CLANG
- # endif
- # endif
-
- // Visual C++
- #elif defined(_MSC_VER)
--# if _MSC_VER < 1600
--# error "GLM requires Visual C++ 10 - 2010 or higher"
--# elif _MSC_VER == 1600
--# define GLM_COMPILER GLM_COMPILER_VC11
--# elif _MSC_VER == 1700
--# define GLM_COMPILER GLM_COMPILER_VC11
-+# if _MSC_VER < 1800
-+# error "GLM requires Visual C++ 12 - 2013 or higher"
- # elif _MSC_VER == 1800
- # define GLM_COMPILER GLM_COMPILER_VC12
- # elif _MSC_VER == 1900
- # define GLM_COMPILER GLM_COMPILER_VC14
- # elif _MSC_VER >= 1910
- # define GLM_COMPILER GLM_COMPILER_VC15
--# else//_MSC_VER
--# define GLM_COMPILER GLM_COMPILER_VC
- # endif//_MSC_VER
-
- // G++
- #elif defined(__GNUC__) || defined(__MINGW32__)
--# if (__GNUC__ == 4) && (__GNUC_MINOR__ == 2)
--# define GLM_COMPILER (GLM_COMPILER_GCC42)
--# elif (__GNUC__ == 4) && (__GNUC_MINOR__ == 3)
--# define GLM_COMPILER (GLM_COMPILER_GCC43)
--# elif (__GNUC__ == 4) && (__GNUC_MINOR__ == 4)
--# define GLM_COMPILER (GLM_COMPILER_GCC44)
--# elif (__GNUC__ == 4) && (__GNUC_MINOR__ == 5)
--# define GLM_COMPILER (GLM_COMPILER_GCC45)
-+# if ((__GNUC__ == 4) && (__GNUC_MINOR__ < 6)) || (__GNUC__ < 4)
-+# error "GLM requires GCC 4.7 or higher"
- # elif (__GNUC__ == 4) && (__GNUC_MINOR__ == 6)
- # define GLM_COMPILER (GLM_COMPILER_GCC46)
- # elif (__GNUC__ == 4) && (__GNUC_MINOR__ == 7)
-@@ -261,32 +212,14 @@
- # define GLM_COMPILER (GLM_COMPILER_GCC48)
- # elif (__GNUC__ == 4) && (__GNUC_MINOR__ >= 9)
- # define GLM_COMPILER (GLM_COMPILER_GCC49)
--# elif (__GNUC__ == 5) && (__GNUC_MINOR__ == 0)
--# define GLM_COMPILER (GLM_COMPILER_GCC50)
--# elif (__GNUC__ == 5) && (__GNUC_MINOR__ == 1)
--# define GLM_COMPILER (GLM_COMPILER_GCC51)
--# elif (__GNUC__ == 5) && (__GNUC_MINOR__ == 2)
--# define GLM_COMPILER (GLM_COMPILER_GCC52)
--# elif (__GNUC__ == 5) && (__GNUC_MINOR__ == 3)
--# define GLM_COMPILER (GLM_COMPILER_GCC53)
--# elif (__GNUC__ == 5) && (__GNUC_MINOR__ >= 4)
--# define GLM_COMPILER (GLM_COMPILER_GCC54)
--# elif (__GNUC__ == 6) && (__GNUC_MINOR__ == 0)
--# define GLM_COMPILER (GLM_COMPILER_GCC60)
--# elif (__GNUC__ == 6) && (__GNUC_MINOR__ == 1)
--# define GLM_COMPILER (GLM_COMPILER_GCC61)
--# elif (__GNUC__ == 6) && (__GNUC_MINOR__ >= 2)
--# define GLM_COMPILER (GLM_COMPILER_GCC62)
--# elif (__GNUC__ == 7) && (__GNUC_MINOR__ == 0)
--# define GLM_COMPILER (GLM_COMPILER_GCC70)
--# elif (__GNUC__ == 7) && (__GNUC_MINOR__ == 1)
--# define GLM_COMPILER (GLM_COMPILER_GCC71)
--# elif (__GNUC__ == 7) && (__GNUC_MINOR__ == 2)
--# define GLM_COMPILER (GLM_COMPILER_GCC72)
-+# elif (__GNUC__ == 5)
-+# define GLM_COMPILER (GLM_COMPILER_GCC5)
-+# elif (__GNUC__ == 6)
-+# define GLM_COMPILER (GLM_COMPILER_GCC6)
-+# elif (__GNUC__ == 7)
-+# define GLM_COMPILER (GLM_COMPILER_GCC7)
- # elif (__GNUC__ >= 8)
--# define GLM_COMPILER (GLM_COMPILER_GCC80)
--# else
--# define GLM_COMPILER (GLM_COMPILER_GCC)
-+# define GLM_COMPILER (GLM_COMPILER_GCC8)
- # endif
-
- #else
diff --git a/math/glm/files/patch-test_core_core__setup__message.cpp b/math/glm/files/patch-test_core_core__setup__message.cpp
deleted file mode 100644
index 6bec66cc63f3..000000000000
--- a/math/glm/files/patch-test_core_core__setup__message.cpp
+++ /dev/null
@@ -1,133 +0,0 @@
---- test/core/core_setup_message.cpp.orig 2018-08-09 13:49:13 UTC
-+++ test/core/core_setup_message.cpp
-@@ -10,12 +10,6 @@ int test_compiler()
- {
- switch(GLM_COMPILER)
- {
-- case GLM_COMPILER_VC10:
-- std::printf("Visual C++ 10 - 2010\n");
-- break;
-- case GLM_COMPILER_VC11:
-- std::printf("Visual C++ 11 - 2012\n");
-- break;
- case GLM_COMPILER_VC12:
- std::printf("Visual C++ 12 - 2013\n");
- break;
-@@ -23,7 +17,10 @@ int test_compiler()
- std::printf("Visual C++ 14 - 2015\n");
- break;
- case GLM_COMPILER_VC15:
-- std::printf("Visual C++ 15 - 201X\n");
-+ std::printf("Visual C++ 15 - 2017\n");
-+ break;
-+ case GLM_COMPILER_VC16:
-+ std::printf("Visual C++ 16 - 20XX\n");
- break;
- default:
- std::printf("Visual C++ version not detected\n");
-@@ -35,12 +32,6 @@ int test_compiler()
- {
- switch(GLM_COMPILER)
- {
-- case GLM_COMPILER_GCC44:
-- std::printf("GCC 4.4\n");
-- break;
-- case GLM_COMPILER_GCC45:
-- std::printf("GCC 4.5\n");
-- break;
- case GLM_COMPILER_GCC46:
- std::printf("GCC 4.6\n");
- break;
-@@ -53,41 +44,17 @@ int test_compiler()
- case GLM_COMPILER_GCC49:
- std::printf("GCC 4.9\n");
- break;
-- case GLM_COMPILER_GCC50:
-- std::printf("GCC 5.0\n");
-- break;
-- case GLM_COMPILER_GCC51:
-- std::printf("GCC 5.1\n");
-- break;
-- case GLM_COMPILER_GCC52:
-- std::printf("GCC 5.2\n");
-- break;
-- case GLM_COMPILER_GCC53:
-- std::printf("GCC 5.3\n");
-- break;
-- case GLM_COMPILER_GCC54:
-- std::printf("GCC 5.4\n");
-- break;
-- case GLM_COMPILER_GCC60:
-- std::printf("GCC 6.0\n");
-- break;
-- case GLM_COMPILER_GCC61:
-- std::printf("GCC 6.1\n");
-- break;
-- case GLM_COMPILER_GCC62:
-- std::printf("GCC 6.2\n");
-- break;
-- case GLM_COMPILER_GCC70:
-- std::printf("GCC 7.0\n");
-+ case GLM_COMPILER_GCC5:
-+ std::printf("GCC 5\n");
- break;
-- case GLM_COMPILER_GCC71:
-- std::printf("GCC 7.1\n");
-+ case GLM_COMPILER_GCC6:
-+ std::printf("GCC 6\n");
- break;
-- case GLM_COMPILER_GCC72:
-- std::printf("GCC 7.2\n");
-+ case GLM_COMPILER_GCC7:
-+ std::printf("GCC 7\n");
- break;
-- case GLM_COMPILER_GCC80:
-- std::printf("GCC 8.0\n");
-+ case GLM_COMPILER_GCC8:
-+ std::printf("GCC 8\n");
- break;
- default:
- std::printf("GCC version not detected\n");
-@@ -103,12 +70,6 @@ int test_compiler()
- {
- switch(GLM_COMPILER)
- {
-- case GLM_COMPILER_CLANG32:
-- std::printf("Clang 3.2\n");
-- break;
-- case GLM_COMPILER_CLANG33:
-- std::printf("Clang 3.3\n");
-- break;
- case GLM_COMPILER_CLANG34:
- std::printf("Clang 3.4\n");
- break;
-@@ -145,23 +106,17 @@ int test_compiler()
- {
- switch(GLM_COMPILER)
- {
-- case GLM_COMPILER_INTEL12:
-- std::printf("ICC 12\n");
-- break;
-- case GLM_COMPILER_INTEL12_1:
-- std::printf("ICC 12.1\n");
-- break;
-- case GLM_COMPILER_INTEL13:
-- std::printf("ICC 13\n");
-- break;
- case GLM_COMPILER_INTEL14:
-- std::printf("ICC 14\n");
-+ std::printf("ICC 14 - 2013 SP1\n");
- break;
- case GLM_COMPILER_INTEL15:
-- std::printf("ICC 15\n");
-+ std::printf("ICC 15 - 2015\n");
- break;
- case GLM_COMPILER_INTEL16:
-- std::printf("ICC 16\n");
-+ std::printf("ICC 16 - 2017\n");
-+ break;
-+ case GLM_COMPILER_INTEL17:
-+ std::printf("ICC 17 - 20XX\n");
- break;
- default:
- std::printf("Intel compiler version not detected\n");
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index b7f005e31b07..b6f0eecf7cd2 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -1,4 +1,3 @@
-include/glm/CMakeLists.txt
include/glm/common.hpp
include/glm/detail/_features.hpp
include/glm/detail/_fixes.hpp
@@ -6,42 +5,30 @@ include/glm/detail/_noise.hpp
include/glm/detail/_swizzle.hpp
include/glm/detail/_swizzle_func.hpp
include/glm/detail/_vectorize.hpp
-include/glm/detail/dummy.cpp
-include/glm/detail/func_common.hpp
+include/glm/detail/compute_common.hpp
+include/glm/detail/compute_vector_relational.hpp
include/glm/detail/func_common.inl
include/glm/detail/func_common_simd.inl
-include/glm/detail/func_exponential.hpp
include/glm/detail/func_exponential.inl
include/glm/detail/func_exponential_simd.inl
-include/glm/detail/func_geometric.hpp
include/glm/detail/func_geometric.inl
include/glm/detail/func_geometric_simd.inl
-include/glm/detail/func_integer.hpp
include/glm/detail/func_integer.inl
include/glm/detail/func_integer_simd.inl
-include/glm/detail/func_matrix.hpp
include/glm/detail/func_matrix.inl
include/glm/detail/func_matrix_simd.inl
-include/glm/detail/func_packing.hpp
include/glm/detail/func_packing.inl
include/glm/detail/func_packing_simd.inl
-include/glm/detail/func_trigonometric.hpp
include/glm/detail/func_trigonometric.inl
include/glm/detail/func_trigonometric_simd.inl
-include/glm/detail/func_vector_relational.hpp
include/glm/detail/func_vector_relational.inl
include/glm/detail/func_vector_relational_simd.inl
include/glm/detail/glm.cpp
-include/glm/detail/precision.hpp
+include/glm/detail/qualifier.hpp
include/glm/detail/setup.hpp
include/glm/detail/type_float.hpp
-include/glm/detail/type_gentype.hpp
-include/glm/detail/type_gentype.inl
include/glm/detail/type_half.hpp
include/glm/detail/type_half.inl
-include/glm/detail/type_int.hpp
-include/glm/detail/type_mat.hpp
-include/glm/detail/type_mat.inl
include/glm/detail/type_mat2x2.hpp
include/glm/detail/type_mat2x2.inl
include/glm/detail/type_mat2x3.hpp
@@ -61,8 +48,9 @@ include/glm/detail/type_mat4x3.inl
include/glm/detail/type_mat4x4.hpp
include/glm/detail/type_mat4x4.inl
include/glm/detail/type_mat4x4_simd.inl
-include/glm/detail/type_vec.hpp
-include/glm/detail/type_vec.inl
+include/glm/detail/type_quat.hpp
+include/glm/detail/type_quat.inl
+include/glm/detail/type_quat_simd.inl
include/glm/detail/type_vec1.hpp
include/glm/detail/type_vec1.inl
include/glm/detail/type_vec2.hpp
@@ -74,20 +62,180 @@ include/glm/detail/type_vec4.inl
include/glm/detail/type_vec4_simd.inl
include/glm/exponential.hpp
include/glm/ext.hpp
+include/glm/ext/matrix_clip_space.hpp
+include/glm/ext/matrix_clip_space.inl
+include/glm/ext/matrix_common.hpp
+include/glm/ext/matrix_common.inl
+include/glm/ext/matrix_double2x2.hpp
+include/glm/ext/matrix_double2x2_precision.hpp
+include/glm/ext/matrix_double2x3.hpp
+include/glm/ext/matrix_double2x3_precision.hpp
+include/glm/ext/matrix_double2x4.hpp
+include/glm/ext/matrix_double2x4_precision.hpp
+include/glm/ext/matrix_double3x2.hpp
+include/glm/ext/matrix_double3x2_precision.hpp
+include/glm/ext/matrix_double3x3.hpp
+include/glm/ext/matrix_double3x3_precision.hpp
+include/glm/ext/matrix_double3x4.hpp
+include/glm/ext/matrix_double3x4_precision.hpp
+include/glm/ext/matrix_double4x2.hpp
+include/glm/ext/matrix_double4x2_precision.hpp
+include/glm/ext/matrix_double4x3.hpp
+include/glm/ext/matrix_double4x3_precision.hpp
+include/glm/ext/matrix_double4x4.hpp
+include/glm/ext/matrix_double4x4_precision.hpp
+include/glm/ext/matrix_float2x2.hpp
+include/glm/ext/matrix_float2x2_precision.hpp
+include/glm/ext/matrix_float2x3.hpp
+include/glm/ext/matrix_float2x3_precision.hpp
+include/glm/ext/matrix_float2x4.hpp
+include/glm/ext/matrix_float2x4_precision.hpp
+include/glm/ext/matrix_float3x2.hpp
+include/glm/ext/matrix_float3x2_precision.hpp
+include/glm/ext/matrix_float3x3.hpp
+include/glm/ext/matrix_float3x3_precision.hpp
+include/glm/ext/matrix_float3x4.hpp
+include/glm/ext/matrix_float3x4_precision.hpp
+include/glm/ext/matrix_float4x2.hpp
+include/glm/ext/matrix_float4x2_precision.hpp
+include/glm/ext/matrix_float4x3.hpp
+include/glm/ext/matrix_float4x3_precision.hpp
+include/glm/ext/matrix_float4x4.hpp
+include/glm/ext/matrix_float4x4_precision.hpp
+include/glm/ext/matrix_int2x2.hpp
+include/glm/ext/matrix_int2x2_sized.hpp
+include/glm/ext/matrix_int2x3.hpp
+include/glm/ext/matrix_int2x3_sized.hpp
+include/glm/ext/matrix_int2x4.hpp
+include/glm/ext/matrix_int2x4_sized.hpp
+include/glm/ext/matrix_int3x2.hpp
+include/glm/ext/matrix_int3x2_sized.hpp
+include/glm/ext/matrix_int3x3.hpp
+include/glm/ext/matrix_int3x3_sized.hpp
+include/glm/ext/matrix_int3x4.hpp
+include/glm/ext/matrix_int3x4_sized.hpp
+include/glm/ext/matrix_int4x2.hpp
+include/glm/ext/matrix_int4x2_sized.hpp
+include/glm/ext/matrix_int4x3.hpp
+include/glm/ext/matrix_int4x3_sized.hpp
+include/glm/ext/matrix_int4x4.hpp
+include/glm/ext/matrix_int4x4_sized.hpp
+include/glm/ext/matrix_projection.hpp
+include/glm/ext/matrix_projection.inl
+include/glm/ext/matrix_relational.hpp
+include/glm/ext/matrix_relational.inl
+include/glm/ext/matrix_transform.hpp
+include/glm/ext/matrix_transform.inl
+include/glm/ext/matrix_uint2x2.hpp
+include/glm/ext/matrix_uint2x2_sized.hpp
+include/glm/ext/matrix_uint2x3.hpp
+include/glm/ext/matrix_uint2x3_sized.hpp
+include/glm/ext/matrix_uint2x4.hpp
+include/glm/ext/matrix_uint2x4_sized.hpp
+include/glm/ext/matrix_uint3x2.hpp
+include/glm/ext/matrix_uint3x2_sized.hpp
+include/glm/ext/matrix_uint3x3.hpp
+include/glm/ext/matrix_uint3x3_sized.hpp
+include/glm/ext/matrix_uint3x4.hpp
+include/glm/ext/matrix_uint3x4_sized.hpp
+include/glm/ext/matrix_uint4x2.hpp
+include/glm/ext/matrix_uint4x2_sized.hpp
+include/glm/ext/matrix_uint4x3.hpp
+include/glm/ext/matrix_uint4x3_sized.hpp
+include/glm/ext/matrix_uint4x4.hpp
+include/glm/ext/matrix_uint4x4_sized.hpp
+include/glm/ext/quaternion_common.hpp
+include/glm/ext/quaternion_common.inl
+include/glm/ext/quaternion_common_simd.inl
+include/glm/ext/quaternion_double.hpp
+include/glm/ext/quaternion_double_precision.hpp
+include/glm/ext/quaternion_exponential.hpp
+include/glm/ext/quaternion_exponential.inl
+include/glm/ext/quaternion_float.hpp
+include/glm/ext/quaternion_float_precision.hpp
+include/glm/ext/quaternion_geometric.hpp
+include/glm/ext/quaternion_geometric.inl
+include/glm/ext/quaternion_relational.hpp
+include/glm/ext/quaternion_relational.inl
+include/glm/ext/quaternion_transform.hpp
+include/glm/ext/quaternion_transform.inl
+include/glm/ext/quaternion_trigonometric.hpp
+include/glm/ext/quaternion_trigonometric.inl
+include/glm/ext/scalar_common.hpp
+include/glm/ext/scalar_common.inl
+include/glm/ext/scalar_constants.hpp
+include/glm/ext/scalar_constants.inl
+include/glm/ext/scalar_int_sized.hpp
+include/glm/ext/scalar_integer.hpp
+include/glm/ext/scalar_integer.inl
+include/glm/ext/scalar_packing.hpp
+include/glm/ext/scalar_packing.inl
+include/glm/ext/scalar_relational.hpp
+include/glm/ext/scalar_relational.inl
+include/glm/ext/scalar_uint_sized.hpp
+include/glm/ext/scalar_ulp.hpp
+include/glm/ext/scalar_ulp.inl
+include/glm/ext/vector_bool1.hpp
+include/glm/ext/vector_bool1_precision.hpp
+include/glm/ext/vector_bool2.hpp
+include/glm/ext/vector_bool2_precision.hpp
+include/glm/ext/vector_bool3.hpp
+include/glm/ext/vector_bool3_precision.hpp
+include/glm/ext/vector_bool4.hpp
+include/glm/ext/vector_bool4_precision.hpp
+include/glm/ext/vector_common.hpp
+include/glm/ext/vector_common.inl
+include/glm/ext/vector_double1.hpp
+include/glm/ext/vector_double1_precision.hpp
+include/glm/ext/vector_double2.hpp
+include/glm/ext/vector_double2_precision.hpp
+include/glm/ext/vector_double3.hpp
+include/glm/ext/vector_double3_precision.hpp
+include/glm/ext/vector_double4.hpp
+include/glm/ext/vector_double4_precision.hpp
+include/glm/ext/vector_float1.hpp
+include/glm/ext/vector_float1_precision.hpp
+include/glm/ext/vector_float2.hpp
+include/glm/ext/vector_float2_precision.hpp
+include/glm/ext/vector_float3.hpp
+include/glm/ext/vector_float3_precision.hpp
+include/glm/ext/vector_float4.hpp
+include/glm/ext/vector_float4_precision.hpp
+include/glm/ext/vector_int1.hpp
+include/glm/ext/vector_int1_sized.hpp
+include/glm/ext/vector_int2.hpp
+include/glm/ext/vector_int2_sized.hpp
+include/glm/ext/vector_int3.hpp
+include/glm/ext/vector_int3_sized.hpp
+include/glm/ext/vector_int4.hpp
+include/glm/ext/vector_int4_sized.hpp
+include/glm/ext/vector_integer.hpp
+include/glm/ext/vector_integer.inl
+include/glm/ext/vector_packing.hpp
+include/glm/ext/vector_packing.inl
+include/glm/ext/vector_relational.hpp
+include/glm/ext/vector_relational.inl
+include/glm/ext/vector_uint1.hpp
+include/glm/ext/vector_uint1_sized.hpp
+include/glm/ext/vector_uint2.hpp
+include/glm/ext/vector_uint2_sized.hpp
+include/glm/ext/vector_uint3.hpp
+include/glm/ext/vector_uint3_sized.hpp
+include/glm/ext/vector_uint4.hpp
+include/glm/ext/vector_uint4_sized.hpp
+include/glm/ext/vector_ulp.hpp
+include/glm/ext/vector_ulp.inl
include/glm/fwd.hpp
include/glm/geometric.hpp
include/glm/glm.hpp
include/glm/gtc/bitfield.hpp
include/glm/gtc/bitfield.inl
-include/glm/gtc/color_encoding.inl
include/glm/gtc/color_space.hpp
include/glm/gtc/color_space.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
-include/glm/gtc/functions.hpp
-include/glm/gtc/functions.inl
include/glm/gtc/integer.hpp
include/glm/gtc/integer.inl
include/glm/gtc/matrix_access.hpp
@@ -118,13 +266,14 @@ include/glm/gtc/type_ptr.inl
include/glm/gtc/ulp.hpp
include/glm/gtc/ulp.inl
include/glm/gtc/vec1.hpp
-include/glm/gtc/vec1.inl
include/glm/gtx/associated_min_max.hpp
include/glm/gtx/associated_min_max.inl
include/glm/gtx/bit.hpp
include/glm/gtx/bit.inl
include/glm/gtx/closest_point.hpp
include/glm/gtx/closest_point.inl
+include/glm/gtx/color_encoding.hpp
+include/glm/gtx/color_encoding.inl
include/glm/gtx/color_space.hpp
include/glm/gtx/color_space.inl
include/glm/gtx/color_space_YCoCg.hpp
@@ -137,12 +286,16 @@ include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
include/glm/gtx/dual_quaternion.hpp
include/glm/gtx/dual_quaternion.inl
+include/glm/gtx/easing.hpp
+include/glm/gtx/easing.inl
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
include/glm/gtx/extend.inl
include/glm/gtx/extended_min_max.hpp
include/glm/gtx/extended_min_max.inl
+include/glm/gtx/exterior_product.hpp
+include/glm/gtx/exterior_product.inl
include/glm/gtx/fast_exponential.hpp
include/glm/gtx/fast_exponential.inl
include/glm/gtx/fast_square_root.hpp
@@ -150,6 +303,8 @@ include/glm/gtx/fast_square_root.inl
include/glm/gtx/fast_trigonometry.hpp
include/glm/gtx/fast_trigonometry.inl
include/glm/gtx/float_notmalize.inl
+include/glm/gtx/functions.hpp
+include/glm/gtx/functions.inl
include/glm/gtx/gradient_paint.hpp
include/glm/gtx/gradient_paint.inl
include/glm/gtx/handed_coordinate_space.hpp
@@ -168,6 +323,8 @@ include/glm/gtx/matrix_cross_product.hpp
include/glm/gtx/matrix_cross_product.inl
include/glm/gtx/matrix_decompose.hpp
include/glm/gtx/matrix_decompose.inl
+include/glm/gtx/matrix_factorisation.hpp
+include/glm/gtx/matrix_factorisation.inl
include/glm/gtx/matrix_interpolation.hpp
include/glm/gtx/matrix_interpolation.inl
include/glm/gtx/matrix_major_storage.hpp
@@ -216,6 +373,8 @@ include/glm/gtx/std_based_type.hpp
include/glm/gtx/std_based_type.inl
include/glm/gtx/string_cast.hpp
include/glm/gtx/string_cast.inl
+include/glm/gtx/texture.hpp
+include/glm/gtx/texture.inl
include/glm/gtx/transform.hpp
include/glm/gtx/transform.inl
include/glm/gtx/transform2.hpp
@@ -224,6 +383,7 @@ include/glm/gtx/type_aligned.hpp
include/glm/gtx/type_aligned.inl
include/glm/gtx/type_trait.hpp
include/glm/gtx/type_trait.inl
+include/glm/gtx/vec_swizzle.hpp
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp
@@ -247,6 +407,7 @@ include/glm/simd/exponential.h
include/glm/simd/geometric.h
include/glm/simd/integer.h
include/glm/simd/matrix.h
+include/glm/simd/neon.h
include/glm/simd/packing.h
include/glm/simd/platform.h
include/glm/simd/trigonometric.h
@@ -256,7 +417,6 @@ include/glm/vec2.hpp
include/glm/vec3.hpp
include/glm/vec4.hpp
include/glm/vector_relational.hpp
+lib/cmake/glm/glmConfig-version.cmake
lib/cmake/glm/glmConfig.cmake
-lib/cmake/glm/glmConfigVersion.cmake
-lib/cmake/glm/glmTargets.cmake
libdata/pkgconfig/glm.pc