aboutsummaryrefslogtreecommitdiff
path: root/math/glove
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-10 03:40:32 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-10 03:40:32 +0000
commit516fa9816ec6955bb23fb474ff0579287558fe13 (patch)
treea6f92f42c2fd4a87c291c0b29114fb14b2f8a3c7 /math/glove
parentd7377ebf7258e9ae5d53165a9e1fd3860233db3f (diff)
downloadports-516fa9816ec6955bb23fb474ff0579287558fe13.tar.gz
ports-516fa9816ec6955bb23fb474ff0579287558fe13.zip
Notes
Diffstat (limited to 'math/glove')
-rw-r--r--math/glove/Makefile105
-rw-r--r--math/glove/distinfo1
-rw-r--r--math/glove/files/patch-aa28
-rw-r--r--math/glove/files/patch-ab11
-rw-r--r--math/glove/files/patch-ac11
-rw-r--r--math/glove/files/patch-ad43
-rw-r--r--math/glove/pkg-comment1
-rw-r--r--math/glove/pkg-descr8
-rw-r--r--math/glove/pkg-plist4
9 files changed, 212 insertions, 0 deletions
diff --git a/math/glove/Makefile b/math/glove/Makefile
new file mode 100644
index 000000000000..f0e62ab6d114
--- /dev/null
+++ b/math/glove/Makefile
@@ -0,0 +1,105 @@
+# New ports collection makefile for: Glove
+# Date created: 14 June 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= glove
+PORTVERSION= 1.0.1
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/glove/source/
+DISTNAME= Glove_source-${PORTVERSION}
+
+MAINTAINER= lioux@linf.unb.br
+
+BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
+ makemake:${JXPORT}
+LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
+ j2dplot-0_6_5.0:${PORTSDIR}/x11-toolkits/libj2dplot \
+ jparser-1_1_8.1:${PORTSDIR}/x11-toolkits/libjparser
+
+WRKSRC= ${WRKDIR}/JX-1.5.3
+
+USE_XLIB= yes
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
+ JX_LIB_ROOT="${X11BASE}/lib"
+PLIST_SUB= PORTNAME="${PORTNAME}"
+
+# Make environment
+PORTINCLUDES= -I${X11BASE}/include/jx \
+ -I${X11BASE}/include/jcore \
+ -I${X11BASE}/include/j2dplot \
+ -I${X11BASE}/include/jparser
+
+# Installs dir with proper permissions
+INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
+# program files
+PROGRAMFILES= glove/glove
+# documents
+DOCFILES= LICENSE README.binary
+DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME}
+# additional configuration and header files
+EXTRALIB_PREFIX= ${X11BASE}/lib/jx
+EXTRALIBFILES_MAKE_WRKSRC= include/make
+# main jx distribution files needed for building
+COPY_JXDIRS= include
+COPY_JXFILES= Makefile
+# main jx distribution port wrksrc
+JXPORT= ${PORTSDIR}/x11-toolkits/jx
+JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
+JX_MAKE_CONSTANTS= j2dplot_constants jparser_constants
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 300000
+ALL_TARGET= freebsd3.x
+.else
+ALL_TARGET= freebsd2.x
+.endif
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+.endif # !defined(NOPORTDOCS)
+
+post-extract:
+.for i in ${COPY_JXDIRS}
+ @${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+.for i in ${COPY_JXFILES}
+ @${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+
+post-patch:
+ @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
+
+pre-build:
+.for i in ${JX_MAKE_CONSTANTS}
+ @${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
+.endfor
+
+post-build:
+ @cd ${WRKSRC}/programs/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS}
+
+do-install:
+.if !defined(NOPORTDOCS)
+# Install all documentation
+ @${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
+.for i in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME}/${i} ${DOCDIR_PREFIX}
+.endfor
+.endif # !defined(NOPORTDOCS)
+# Install all programs
+.for i in ${PROGRAMFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/math/glove/distinfo b/math/glove/distinfo
new file mode 100644
index 000000000000..39084fe245e6
--- /dev/null
+++ b/math/glove/distinfo
@@ -0,0 +1 @@
+MD5 (Glove_source-1.0.1.tar.gz) = a1fda27724402d7a1556c491fdcd052f
diff --git a/math/glove/files/patch-aa b/math/glove/files/patch-aa
new file mode 100644
index 000000000000..18be5d2d2db3
--- /dev/null
+++ b/math/glove/files/patch-aa
@@ -0,0 +1,28 @@
+--- Makefile.orig Sat Sep 11 17:44:38 1999
++++ Makefile Wed Jun 14 01:07:15 2000
+@@ -262,25 +262,11 @@
+ freebsd2.x: prep
+ @ln -s sys/FreeBSD-2.x_g++ \
+ include/make/jx_config
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
+- @ln -s config-freebsd.h \
+- ACE/ACE_wrappers/ace/config.h
+- @ln -s platform_freebsd.GNU \
+- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
+- @${INSTALL_CMD}
+
+ .PHONY : freebsd3.x
+ freebsd3.x: prep
+ @ln -s sys/FreeBSD-3.x_g++ \
+ include/make/jx_config
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
+- @ln -s config-freebsd-pthread.h \
+- ACE/ACE_wrappers/ace/config.h
+- @ln -s platform_freebsd_pthread.GNU \
+- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
+- @${INSTALL_CMD}
+
+ #
+ # SunOS 4.x
diff --git a/math/glove/files/patch-ab b/math/glove/files/patch-ab
new file mode 100644
index 000000000000..08f994d2573c
--- /dev/null
+++ b/math/glove/files/patch-ab
@@ -0,0 +1,11 @@
+--- include/make/sys/FreeBSD-2.x_g++.orig Wed Jun 14 01:44:51 2000
++++ include/make/sys/FreeBSD-2.x_g++ Wed Jun 14 01:45:00 2000
+@@ -35,7 +35,7 @@
+ # Comment this out if ACE or other code gives you warnings that
+ # you can't avoid.
+
+-J_DIE_ON_WARNING := -Werror
++#J_DIE_ON_WARNING := -Werror
+
+ # Uncomment this if istrstream is broken. One way to check is to run
+ # testjcore/testJFileArray.
diff --git a/math/glove/files/patch-ac b/math/glove/files/patch-ac
new file mode 100644
index 000000000000..464c4221d3af
--- /dev/null
+++ b/math/glove/files/patch-ac
@@ -0,0 +1,11 @@
+--- include/make/sys/FreeBSD-3.x_g++.orig Wed Jun 14 01:44:51 2000
++++ include/make/sys/FreeBSD-3.x_g++ Wed Jun 14 01:45:00 2000
+@@ -35,7 +35,7 @@
+ # Comment this out if ACE or other code gives you warnings that
+ # you can't avoid.
+
+-J_DIE_ON_WARNING := -Werror
++#J_DIE_ON_WARNING := -Werror
+
+ # Uncomment this if istrstream is broken. One way to check is to run
+ # testjcore/testJFileArray.
diff --git a/math/glove/files/patch-ad b/math/glove/files/patch-ad
new file mode 100644
index 000000000000..22ab10dde702
--- /dev/null
+++ b/math/glove/files/patch-ad
@@ -0,0 +1,43 @@
+--- programs/glove/Make.header.orig Fri Sep 24 15:41:45 1999
++++ programs/glove/Make.header Wed Jun 14 22:55:54 2000
+@@ -17,14 +17,15 @@
+
+ # Directories to search for header files
+
+-SEARCHDIRS := -I- \
++SEARCHDIRS = -I- \
+ -I${CODEDIR} \
+ -I${PLOTDIR} \
+ -I${JCOREDIR} \
+ -I${JXDIR} \
+ -I${JPARSEDIR} \
+ -I${J2DPLOTDIR} \
+- -I${ACE_ROOT}
++ -I${ACE_ROOT} \
++ ${J_X11_INCLUDE_DIR}
+
+ # other constants
+
+@@ -41,13 +42,6 @@
+
+ # library dependencies
+
+-ifdef J_BUILD_SHARED_LIB
+- LIB_DEPS := ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.so \
+- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.so
+-else
+- LIB_DEPS := ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.a \
+- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.a
+-endif
+
+ # make variables
+
+@@ -64,7 +58,7 @@
+ #####
+
+ .PHONY : default
+-default: libs glove
++default: glove
+
+ .PHONY : Makefiles
+ Makefiles:
diff --git a/math/glove/pkg-comment b/math/glove/pkg-comment
new file mode 100644
index 000000000000..6b50466c2d42
--- /dev/null
+++ b/math/glove/pkg-comment
@@ -0,0 +1 @@
+Data acquisition, manipulation, and analysis program for X
diff --git a/math/glove/pkg-descr b/math/glove/pkg-descr
new file mode 100644
index 000000000000..99d65132d67a
--- /dev/null
+++ b/math/glove/pkg-descr
@@ -0,0 +1,8 @@
+Glove
+
+Glove was developed for use in Caltech physics labs to provide an
+interface to data acquisition systems, sophisticated (and correct)
+statistical analysis, a flexible plotting tool, and the ability to
+easily and intuitively manipulate the data.
+
+WWW: http://www.newplanetsoftware.com/glove/
diff --git a/math/glove/pkg-plist b/math/glove/pkg-plist
new file mode 100644
index 000000000000..1c125f649de4
--- /dev/null
+++ b/math/glove/pkg-plist
@@ -0,0 +1,4 @@
+bin/glove
+%%PORTDOCS:%%share/doc/%%PORTNAME%%/LICENSE
+%%PORTDOCS:%%share/doc/%%PORTNAME%%/README.binary
+%%PORTDOCS:%%@dirrm share/doc/%%PORTNAME%%