aboutsummaryrefslogtreecommitdiff
path: root/math/gmm++
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-06 10:48:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-06 10:48:23 +0000
commit84c1313bccdfe4e47a193fa57714554a246ad54e (patch)
tree6e33cd5d926bf69cc0bfb5e5a41522b007426e31 /math/gmm++
parent7f45b414183634039462c6005d9d508a9878edf5 (diff)
downloadports-84c1313bccdfe4e47a193fa57714554a246ad54e.tar.gz
ports-84c1313bccdfe4e47a193fa57714554a246ad54e.zip
Notes
Diffstat (limited to 'math/gmm++')
-rw-r--r--math/gmm++/Makefile19
-rw-r--r--math/gmm++/distinfo3
-rw-r--r--math/gmm++/pkg-descr12
-rw-r--r--math/gmm++/pkg-plist55
4 files changed, 89 insertions, 0 deletions
diff --git a/math/gmm++/Makefile b/math/gmm++/Makefile
new file mode 100644
index 000000000000..8a3b0454f021
--- /dev/null
+++ b/math/gmm++/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: gmm++
+# Date created: 2008-07-23
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm++
+PORTVERSION= 3.0.4
+CATEGORIES= math
+MASTER_SITES= http://download.gna.org/getfem/stable/
+DISTNAME= ${PORTNAME:S/+//g}-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= A generic matrix template library
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/gmm++/distinfo b/math/gmm++/distinfo
new file mode 100644
index 000000000000..0da7976e2e47
--- /dev/null
+++ b/math/gmm++/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmm-3.0.4.tar.gz) = 677b6f08012235f956e9d83fb855b96e
+SHA256 (gmm-3.0.4.tar.gz) = 6ecae1d1bcf513c9cdedb6ae5979b9af8af90d5961383fbfa3a78ad938b96d46
+SIZE (gmm-3.0.4.tar.gz) = 463087
diff --git a/math/gmm++/pkg-descr b/math/gmm++/pkg-descr
new file mode 100644
index 000000000000..1b74ee0f381e
--- /dev/null
+++ b/math/gmm++/pkg-descr
@@ -0,0 +1,12 @@
+Gmm++ is a generic C++ template library for sparse, dense and skyline
+matrices. It is built as a set of generic algorithms (mult, add,
+copy, sub-matrices, dense and sparse solvers ...) for any interfaced
+vector type or matrix type. It can be view as a glue library allowing
+cooperation between several vector and matrix types. However, basic
+sparse, dense and skyline matrix/vector types are built in Gmm++,
+hence it can be used as a standalone linear algebra library.
+Interfacing a vector or matrix type means writing "traits" objects
+called "linalg_traits", which describe their properties. The library
+offers predefined dense, sparse and skyline matrix types.
+
+WWW: http://home.gna.org/getfem/
diff --git a/math/gmm++/pkg-plist b/math/gmm++/pkg-plist
new file mode 100644
index 000000000000..bade4c56fc7a
--- /dev/null
+++ b/math/gmm++/pkg-plist
@@ -0,0 +1,55 @@
+include/gmm/gmm.h
+include/gmm/gmm_MUMPS_interface.h
+include/gmm/gmm_algobase.h
+include/gmm/gmm_blas.h
+include/gmm/gmm_blas_interface.h
+include/gmm/gmm_condition_number.h
+include/gmm/gmm_conjugated.h
+include/gmm/gmm_def.h
+include/gmm/gmm_dense_Householder.h
+include/gmm/gmm_dense_lu.h
+include/gmm/gmm_dense_qr.h
+include/gmm/gmm_dense_sylvester.h
+include/gmm/gmm_domain_decomp.h
+include/gmm/gmm_except.h
+include/gmm/gmm_inoutput.h
+include/gmm/gmm_interface.h
+include/gmm/gmm_interface_bgeot.h
+include/gmm/gmm_iter.h
+include/gmm/gmm_iter_solvers.h
+include/gmm/gmm_kernel.h
+include/gmm/gmm_lapack_interface.h
+include/gmm/gmm_least_squares_cg.h
+include/gmm/gmm_matrix.h
+include/gmm/gmm_modified_gram_schmidt.h
+include/gmm/gmm_opt.h
+include/gmm/gmm_precond.h
+include/gmm/gmm_precond_diagonal.h
+include/gmm/gmm_precond_ildlt.h
+include/gmm/gmm_precond_ildltt.h
+include/gmm/gmm_precond_ilu.h
+include/gmm/gmm_precond_ilut.h
+include/gmm/gmm_precond_ilutp.h
+include/gmm/gmm_precond_mr_approx_inverse.h
+include/gmm/gmm_real_part.h
+include/gmm/gmm_ref.h
+include/gmm/gmm_scaled.h
+include/gmm/gmm_solver_Newton.h
+include/gmm/gmm_solver_Schwarz_additive.h
+include/gmm/gmm_solver_bfgs.h
+include/gmm/gmm_solver_bicgstab.h
+include/gmm/gmm_solver_cg.h
+include/gmm/gmm_solver_constrained_cg.h
+include/gmm/gmm_solver_gmres.h
+include/gmm/gmm_solver_idgmres.h
+include/gmm/gmm_solver_qmr.h
+include/gmm/gmm_std.h
+include/gmm/gmm_sub_index.h
+include/gmm/gmm_sub_matrix.h
+include/gmm/gmm_sub_vector.h
+include/gmm/gmm_superlu_interface.h
+include/gmm/gmm_transposed.h
+include/gmm/gmm_tri_solve.h
+include/gmm/gmm_vector.h
+include/gmm/gmm_vector_to_matrix.h
+@dirrm include/gmm