aboutsummaryrefslogtreecommitdiff
path: root/math/gmp/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-20 18:44:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-20 18:44:31 +0000
commit9f9684e7ea1eeb4ed23e18983914b55c510dce0d (patch)
treecc8107998698fb842a7f322539691e527961d4c7 /math/gmp/Makefile
parent9ab73ecc25a9959491a929a667ec7f61ff09f0f3 (diff)
Notes
Diffstat (limited to 'math/gmp/Makefile')
-rw-r--r--math/gmp/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index ea4ea84b2aa1..5c1fc19d8765 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libgmp
PORTVERSION= 4.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gmp
@@ -16,9 +16,14 @@ DISTNAME= gmp-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-cxx
INSTALLS_SHLIB= yes
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|--tag=CC||g'
+
.include <bsd.port.mk>