aboutsummaryrefslogtreecommitdiff
path: root/math/gnubc
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2010-02-03 12:47:33 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2010-02-03 12:47:33 +0000
commit39342e3318ab2bb19cff315e5655ce6c3daee8ae (patch)
treea2d3477a3a7e1627ba9366429da74128db3bfce2 /math/gnubc
parent33e59342ef767580f38ddf314d0ebfe51c874628 (diff)
downloadports-39342e3318ab2bb19cff315e5655ce6c3daee8ae.tar.gz
ports-39342e3318ab2bb19cff315e5655ce6c3daee8ae.zip
bc is an arbitrary precision numeric processing language. Syntax is similar
to C but differs in many substantial areas. It supports interactive execution of statements. The bc utility is included in the POSIX 1003.1-2008 standard. WWW: http://www.gnu.org/software/bc/
Notes
Notes: svn path=/head/; revision=249168
Diffstat (limited to 'math/gnubc')
-rw-r--r--math/gnubc/Makefile38
-rw-r--r--math/gnubc/distinfo3
-rw-r--r--math/gnubc/pkg-descr5
3 files changed, 46 insertions, 0 deletions
diff --git a/math/gnubc/Makefile b/math/gnubc/Makefile
new file mode 100644
index 000000000000..9efd7f3b39af
--- /dev/null
+++ b/math/gnubc/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: bc
+# Date created: 21 Januar 2010
+# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bc
+PORTVERSION= 1.06
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= gnu
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= The GNU bc/dc calculator
+
+GNU_CONFIGURE= yes
+MAN1= bc.1 \
+ dc.1
+INFO= bc \
+ dc
+PLIST_FILES= bin/bc \
+ bin/dc
+PORTEXAMPLES= ckbook.b \
+ pi.b \
+ primes.b \
+ twins.b
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/Examples/${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/gnubc/distinfo b/math/gnubc/distinfo
new file mode 100644
index 000000000000..f7594e6e6158
--- /dev/null
+++ b/math/gnubc/distinfo
@@ -0,0 +1,3 @@
+MD5 (bc-1.06.tar.gz) = d44b5dddebd8a7a7309aea6c36fda117
+SHA256 (bc-1.06.tar.gz) = 4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33
+SIZE (bc-1.06.tar.gz) = 278926
diff --git a/math/gnubc/pkg-descr b/math/gnubc/pkg-descr
new file mode 100644
index 000000000000..12f6fafd3b69
--- /dev/null
+++ b/math/gnubc/pkg-descr
@@ -0,0 +1,5 @@
+bc is an arbitrary precision numeric processing language. Syntax is similar
+to C but differs in many substantial areas. It supports interactive execution
+of statements. The bc utility is included in the POSIX 1003.1-2008 standard.
+
+WWW: http://www.gnu.org/software/bc/