aboutsummaryrefslogtreecommitdiff
path: root/math/gnumeric/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-06-27 12:06:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-06-27 12:06:29 +0000
commitf24b8f40822bd913c8ed5f9730314da4678a5466 (patch)
tree682413738314b03e8dbb3ef91346373eae247e08 /math/gnumeric/Makefile
parentd480303dc476141444e6d9a04d3777fc1b7e58ee (diff)
downloadports-f24b8f40822bd913c8ed5f9730314da4678a5466.tar.gz
ports-f24b8f40822bd913c8ed5f9730314da4678a5466.zip
Notes
Diffstat (limited to 'math/gnumeric/Makefile')
-rw-r--r--math/gnumeric/Makefile38
1 files changed, 14 insertions, 24 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 16309f855a66..2b1c315c7b78 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -1,50 +1,44 @@
# Created by: Yukihiro Nakai <Nakai@technologist.com>
# $FreeBSD$
-# $MCom: ports-stable/math/gnumeric/Makefile,v 1.5 2010/06/29 11:24:22 kwm Exp $
-# When updating, remember to update pkg-plist of gchemutils.
+# $MCom: ports/trunk/math/gnumeric/Makefile 18444 2013-05-11 12:51:26Z kwm $
PORTNAME= gnumeric
-PORTVERSION= 1.10.17
-PORTREVISION= 2
+PORTVERSION= 1.12.3
CATEGORIES= math gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= The GNOME 2 spreadsheet
+COMMENT= GNOME spreadsheet program
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= goffice-0.8:${PORTSDIR}/devel/goffice \
+LIB_DEPENDS= goffice-0.10:${PORTSDIR}/devel/goffice010 \
psiconv:${PORTSDIR}/converters/psiconv
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USE_XZ= yes
+USES= desktop-file-utils gettext pathfix shared-mime-info
USE_GMAKE= yes
-USES= pathfix gettext
-USE_GNOME= gnomeprefix intlhack gnomehier pygtk2 \
- desktopfileutils libgsf
-USE_PYTHON= yes
+USE_GNOME= gnomehier gnomeprefix intlhack libgsf pygobject3
+USE_PYTHON= -2.7
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-USE_CSTD= gnu89
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gnome=no --disable-silent-rules
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
- python_prog=${PYTHON_VERSION}
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
GLIB_SCHEMAS= org.gnome.gnumeric.dialogs.gschema.xml \
org.gnome.gnumeric.gschema.xml \
org.gnome.gnumeric.plugin.gschema.xml
-MAN1= gnumeric.1 ssconvert.1 ssindex.1 ssgrep.1
+MAN1= gnumeric.1 ssconvert.1 ssdiff.1 ssindex.1 ssgrep.1
-PLIST_SUB= VERSION=${PORTVERSION} GOFFICE=0.8.17
+PLIST_SUB= VERSION=${PORTVERSION} GOFFICE=0.10 SHORT_VER=1.12
OPTIONS_DEFINE= PERL
OPTIONS_DEFAULT=PERL
@@ -70,16 +64,12 @@ PLIST_SUB+= GNOMEDB="@comment "
#.endif
post-patch:
- @${RM} -f ${WRKSRC}/GNOME_Gnumeric.server.in
- @${REINPLACE_CMD} -e 's|gda-3.0 >= 3.1.1|gda-3.0 >= 3.0.1|g' \
- -e 's|gnomedb-3.0 >= 3.0.1|gnomedb-3.0 >= 3.0.0|g' \
- -e 's|gnumeric_with_gconf=true|gnumeric_with_gconf=false|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^GETTEXT_PACKAGE=gnumeric-$${VERSION}|GETTEXT_PACKAGE=gnumeric|g' \
+ ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKSRC}/gnumeric.desktop ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/gnumeric.mime ${PREFIX}/share/mime-info
- @-update-desktop-database
.for dir in share lib
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${dir}/gnumeric
.endfor