aboutsummaryrefslogtreecommitdiff
path: root/math/gnumeric
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-09-20 20:38:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-09-20 20:38:31 +0000
commit03d4563c99a3b9b3cc0b0671b0407508583ca6d3 (patch)
tree83d3939cb470e4cb59145e55a332d3ab72e575e1 /math/gnumeric
parent14a4d02444a055407824e2389c5436a3e30f7422 (diff)
downloadports-03d4563c99a3b9b3cc0b0671b0407508583ca6d3.tar.gz
ports-03d4563c99a3b9b3cc0b0671b0407508583ca6d3.zip
Notes
Diffstat (limited to 'math/gnumeric')
-rw-r--r--math/gnumeric/Makefile4
-rw-r--r--math/gnumeric/files/patch-plugins::html::html.c10
-rw-r--r--math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c27
3 files changed, 37 insertions, 4 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index b25aaad8696a..001fcfcdd739 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -38,10 +38,6 @@ PLIST_SUB= VERSION=${PORTVERSION}-bonobo
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-install:
.for dir in share/gnome lib
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${dir}/gnumeric
diff --git a/math/gnumeric/files/patch-plugins::html::html.c b/math/gnumeric/files/patch-plugins::html::html.c
new file mode 100644
index 000000000000..22d9a59975a0
--- /dev/null
+++ b/math/gnumeric/files/patch-plugins::html::html.c
@@ -0,0 +1,10 @@
+--- plugins/html/html.c.orig Sun Sep 19 16:34:22 2004
++++ plugins/html/html.c Sun Sep 19 16:34:43 2004
+@@ -410,6 +410,7 @@
+ "</HEAD>\n<BODY>\n", fp);
+ break;
+ default:
++ break;
+ }
+
+ sheets = workbook_sheets (wb);
diff --git a/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c b/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c
new file mode 100644
index 000000000000..a14b75c2f0c5
--- /dev/null
+++ b/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c
@@ -0,0 +1,27 @@
+--- plugins/psiconv/psiconv-read.c.orig Sun Sep 19 16:43:32 2004
++++ plugins/psiconv/psiconv-read.c Sun Sep 19 16:44:35 2004
+@@ -301,7 +301,7 @@
+ /* case psiconv_formula_mark_opend: */
+ default:
+ /* kind = -1; */
+- /* break; */
++ break;
+ }
+
+ if (kind == -1) {
+@@ -336,6 +336,7 @@
+ v = value_new_cellrange(cr1,cr2,1,1);
+ break;
+ default:
++ break;
+ }
+ if (!v)
+ return NULL;
+@@ -407,6 +408,7 @@
+ return NULL;
+ return parse_subexpr(psi_form1);
+ default:
++ break;
+ }
+ }
+