aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-12-14 12:03:38 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-12-14 12:03:38 +0000
commit3922098b6f474aa8f596576f188fafe1a31533a3 (patch)
treee90fae974826b10e5fe48d448f178275930978d8 /math/gnuplot/Makefile
parent9cb1f86730cb9856a5995edcdaff1dad98d8500e (diff)
downloadports-3922098b6f474aa8f596576f188fafe1a31533a3.tar.gz
ports-3922098b6f474aa8f596576f188fafe1a31533a3.zip
Notes
Diffstat (limited to 'math/gnuplot/Makefile')
-rw-r--r--math/gnuplot/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index ce410783e67f..d94d31ce6a73 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -2,32 +2,39 @@
PORTNAME= gnuplot
PORTVERSION= 4.6.6
+PORTREVISION= 1
CATEGORIES= math graphics
MASTER_SITES= SF
MAINTAINER= glewis@FreeBSD.org
COMMENT= Command-line driven graphing utility
-USES= iconv
+USES= iconv lua
+USE_TEX= kpathsea
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+CONFIGURE_ENV= LUA_VER="${LUA_VER}"
CONFIGURE_ARGS+=--with-lasergnu \
--with-readline=gnu \
+ --with-kpsexpand \
--without-linux-vga \
--without-lisp-files \
--without-tutorial \
- --with-bitmap-terminals
+ --with-bitmap-terminals \
+ --with-latex \
+ ac_cv_prog_PLAINTEX=${LOCALBASE}/bin/tex \
+ ac_cv_prog_LATEX=${LOCALBASE}/bin/latex \
+ ac_cv_prog_PDFLATEX=${LOCALBASE}/bin/pdflatex
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF PLOT TEX THINSPLINES WX X11
+OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF PLOT THINSPLINES WX X11
GRIDBOX_DESC= Use the gridbox optimization for hidden3d
PLOT_DESC= Enable plot support
-TEX_DESC= Search kpsexpand at run-time
THINSPLINES_DESC= Enable thin plate splines for grids in dgrid3d
WX_DESC= wxWidgets (formerly wxWindows) support
-OPTIONS_DEFAULT=CAIRO GD PLOT TEX WX X11
+OPTIONS_DEFAULT=CAIRO GD PLOT WX X11
OPTIONS_SUB= yes
CAIRO_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
@@ -49,11 +56,6 @@ PLOT_LIB_DEPENDS= libplot.so:${PORTSDIR}/graphics/plotutils
PLOT_CONFIGURE_ON= --with-plot=${LOCALBASE}
PLOT_CONFIGURE_OFF= --without-plot
-TEX_USE= TEX=base,texmf,latex,dvipsk
-TEX_CONFIGURE_ON= --with-kpsexpand \
- --with-texdir=${LOCALBASE}/share/texmf/tex/latex/gnuplot
-TEX_CONFIGURE_OFF= --without-kpexpand
-
THINSPLINES_CONFIGURE_ENABLE= thin-splines
X11_USE= XORG=x11
@@ -71,13 +73,10 @@ CONFIGURE_ARGS+= --disable-wxwidgets
.endif
post-patch:
-.if ! ${PORT_OPTIONS:MTEX}
@${REINPLACE_CMD} -e \
'/^install:/s/install-am//' ${WRKSRC}/share/LaTeX/Makefile.in
-.endif
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in
- @${FIND} "${WRKSRC}" -name '*.orig' -delete
.if ${PORT_OPTIONS:MDOCS}
post-build: