aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-06-25 16:33:57 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-06-25 16:33:57 +0000
commit8a9a4fef12775b08a4189aff3e59a3f747786a07 (patch)
tree6f404af35e087e61f92707536d2b54ff82a9951a /math/gnuplot
parent3e8ba509c6ca10e1d66bdc7d49cbce315e343452 (diff)
downloadports-8a9a4fef12775b08a4189aff3e59a3f747786a07.tar.gz
ports-8a9a4fef12775b08a4189aff3e59a3f747786a07.zip
Notes
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/gnuplot/files/patch-term-pdf.trm13
2 files changed, 14 insertions, 1 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 90f07010b0bc..b43439a0292c 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -58,7 +58,7 @@ CONFIGURE_ARGS+= --without-png
.endif
.if defined(WITH_PDF)
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
+LIB_DEPENDS+= pdf.7:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-pdf
diff --git a/math/gnuplot/files/patch-term-pdf.trm b/math/gnuplot/files/patch-term-pdf.trm
new file mode 100644
index 000000000000..fe2bd870c475
--- /dev/null
+++ b/math/gnuplot/files/patch-term-pdf.trm
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- term/pdf.trm.orig Fri Jun 25 10:15:46 2004
++++ term/pdf.trm Fri Jun 25 10:16:01 2004
+@@ -343,7 +343,7 @@
+ myPDF = PDF_new();
+
+ /*open new PDF file */
+- if (PDF_open_fp(myPDF, gpoutfile) == -1)
++ if (PDF_open_file(myPDF, gpoutfile) == -1)
+ int_error(NO_CARET, "Error:cannot open PDF file .\n");
+
+ #ifdef PDF_DONT_COMPRESS