aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2012-11-22 04:02:13 +0000
committerGreg Lewis <glewis@FreeBSD.org>2012-11-22 04:02:13 +0000
commitb7061fab00c403265510e8d16b75ded3d29fc000 (patch)
treea6ba73894b6ae03b55dd93bd77688643dca94e42 /math/gnuplot
parent8672f52910c95f8b23573d24e3b2549eb827fa06 (diff)
downloadports-b7061fab00c403265510e8d16b75ded3d29fc000.tar.gz
ports-b7061fab00c403265510e8d16b75ded3d29fc000.zip
Notes
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile79
1 files changed, 41 insertions, 38 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 8cff95dad0a1..f4b6f3d416fb 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -22,15 +22,18 @@ CONFIGURE_ARGS+=--with-lasergnu \
--with-bitmap-terminals
MAKE_JOBS_SAFE= yes
-OPTIONS= X11 "Enable X11 support" on \
- GD "Enable GD support" on \
- GRIDBOX "Use the gridbox optimization for hidden3d" off \
- PDF "Enable PDF support" on \
- PLOT "Enable plot support" on \
- TETEX "Search kpsexpand at run-time" on \
- THINSPLINES "Enable thin plate splines for grids in dgrid3d" off \
- WX "Enable WX support" on \
- CAIRO "Enable CAIRO support" on
+OPTIONS_DEFINE= CAIRO GD GRIDBOX PDF PLOT TETEX THINSPLINES WX X11
+CAIRO_DESC= Enable CAIRO support
+GD_DESC= Enable GD support
+GRIDBOX_DESC= Use the gridbox optimization for hidden3d
+PDF_DESC= Enable PDF support
+PLOT_DESC= Enable plot support
+TETEX_DESC= Search kpsexpand at run-time
+THINSPLINES_DESC= Enable thin plate splines for grids in dgrid3d
+WX_DESC= Enable WX support
+X11_DESC= Enable X11 support
+
+OPTIONS_DEFAULT=CAIRO GD PDF PLOT TETEX WX X11
USE_GCC= any
@@ -38,68 +41,68 @@ MAN1= gnuplot.1 lasergnu.1
.include <bsd.port.options.mk>
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --without-x
-PLIST_SUB+= X11="@comment "
+.if ${PORT_OPTIONS:MCAIRO}
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+USE_GNOME+= pango
.else
-USE_XORG= x11
-PLIST_SUB+= X11=""
+CONFIGURE_ARGS+= --without-cairo
.endif
-.if defined(WITHOUT_GD)
-CONFIGURE_ARGS+= --without-gd
-.else
+.if ${PORT_OPTIONS:MGD}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS+= --with-gd=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-gd
.endif
-.if !defined(WITHOUT_GRIDBOX)
+.if ! ${PORT_OPTIONS:MGRIDBOX}
CONFIGURE_ARGS+= --disable-h3d-quadtree --enable-h3d-gridbox
.endif
-.if defined(WITHOUT_PDF)
-CONFIGURE_ARGS+= --without-pdf
-.else
+.if ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-pdf
.endif
-.if defined(WITHOUT_PLOT)
-CONFIGURE_ARGS+= --without-plot
-.else
+.if ${PORT_OPTIONS:MPLOT}
USE_XORG+= xaw xmu xt xext
LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-plot
.endif
-.if defined(WITHOUT_TETEX)
-PLIST_SUB+= TETEX="@comment "
-.else
+.if ${PORT_OPTIONS:MTETEX}
BUILD_DEPENDS+= kpsexpand:${PORTSDIR}/print/teTeX-base
RUN_DEPENDS+= kpsexpand:${PORTSDIR}/print/teTeX-base
CONFIGURE_ARGS+= --with-kpsexpand \
--with-texdir=${LOCALBASE}/share/texmf/tex/latex/gnuplot
PLIST_SUB+= TETEX=""
+.else
+PLIST_SUB+= TETEX="@comment "
.endif
-.if defined(WITHOUT_THINSPLINES)
-CONFIGURE_ARGS+= --disable-thin-splines
-.else
+.if ${PORT_OPTIONS:MTHINSPLINES}
CONFIGURE_ARGS+= --enable-thin-splines
+.else
+CONFIGURE_ARGS+= --disable-thin-splines
.endif
-.if defined(WITHOUT_WX)
-CONFIGURE_ARGS+= --disable-wxwidgets
-.else
+.if ${PORT_OPTIONS:MWX}
USE_WX= 2.5-2.8
WX_CONF_ARGS= absolute
+.else
+CONFIGURE_ARGS+= --disable-wxwidgets
.endif
-.if defined(WITHOUT_CAIRO)
-CONFIGURE_ARGS+= --without-cairo
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= x11
+PLIST_SUB+= X11=""
.else
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-USE_GNOME+= pango
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB+= X11="@comment "
.endif
.if !defined(NOPORTDOCS)
@@ -110,7 +113,7 @@ PORTEXAMPLES= *
.endif
post-patch:
-.if defined(WITHOUT_TETEX)
+.if ! ${PORT_OPTIONS:MTETEX}
@${REINPLACE_CMD} -e \
'/^install:/s/install-am//' ${WRKSRC}/share/LaTeX/Makefile.in
.endif