aboutsummaryrefslogtreecommitdiff
path: root/math/goblin/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-03 12:06:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-03 12:06:20 +0000
commitadc23fc75e664fe10b0d62ab1bed3ac88479ee1a (patch)
treedee5b5cb660ad39e46810c0f7000764012e5d104 /math/goblin/Makefile
parent655285c6b3bdfc8016687e081e6729196a74decf (diff)
downloadports-adc23fc75e664fe10b0d62ab1bed3ac88479ee1a.tar.gz
ports-adc23fc75e664fe10b0d62ab1bed3ac88479ee1a.zip
Notes
Diffstat (limited to 'math/goblin/Makefile')
-rw-r--r--math/goblin/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
new file mode 100644
index 000000000000..fa8d24deb732
--- /dev/null
+++ b/math/goblin/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: goblin
+# Date created: Mar 3, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= goblin
+PORTVERSION= 2.4a3
+CATEGORIES= misc
+MASTER_SITES= http://www.math.uni-augsburg.de/opt/goblin.docs/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
+ tk83:${PORTSDIR}/x11-toolkits/tk83
+
+CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 \
+ -I${X11BASE}/include
+LIBS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g ; \
+ s,g\+\+,${CXX},g ; \
+ s,%%CXXFLAGS%%,${CXXFLAGS},g ; s,%%LIBS%%,${LIBS},g ; \
+ s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/include/globals.h
+
+.include <bsd.port.mk>