diff options
author | Ying-Chieh Liao <ijliao@FreeBSD.org> | 2003-05-12 07:45:50 +0000 |
---|---|---|
committer | Ying-Chieh Liao <ijliao@FreeBSD.org> | 2003-05-12 07:45:50 +0000 |
commit | 79c14d3b73301a13ade7443c27b3f86f46cd7ade (patch) | |
tree | 2a14c31bfebae3e506b3b307f2b6b7aaa22bd28e /math/goblin | |
parent | cea171c1aa3585ff5206db9bca75798115fa32f1 (diff) | |
download | ports-79c14d3b73301a13ade7443c27b3f86f46cd7ade.tar.gz ports-79c14d3b73301a13ade7443c27b3f86f46cd7ade.zip |
Notes
Diffstat (limited to 'math/goblin')
-rw-r--r-- | math/goblin/Makefile | 20 | ||||
-rw-r--r-- | math/goblin/distinfo | 2 | ||||
-rw-r--r-- | math/goblin/files/patch-Makefile | 34 | ||||
-rw-r--r-- | math/goblin/pkg-plist | 7 |
4 files changed, 37 insertions, 26 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile index 712c0b12f2bc..a5a2dd64cac1 100644 --- a/math/goblin/Makefile +++ b/math/goblin/Makefile @@ -7,30 +7,26 @@ # PORTNAME= goblin -PORTVERSION= 2.6.b5 +PORTVERSION= 2.6 CATEGORIES= misc MASTER_SITES= http://www.math.uni-augsburg.de/opt/goblin.docs/ -DISTNAME= ${PORTNAME}.${PORTVERSION:R}${PORTVERSION:E} +DISTNAME= ${PORTNAME}.${PORTVERSION} MAINTAINER= ports@FreeBSD.org COMMENT= A Graph Object Library for Network Programming Problems -LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \ - tk83:${PORTSDIR}/x11-toolkits/tk83 +LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83 USE_REINPLACE= yes +USE_GMAKE= yes +MAKE_ENV= LDFLAGS="${LDFLAGS}" +PLIST_SUB+= PORTVER=${PORTVERSION} CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 \ - -I${X11BASE}/include -LIBS= -L${LOCALBASE}/lib -L${X11BASE}/lib -USE_GMAKE= yes -PLIST_SUB+= PORTVER=${PORTVERSION:R} + -I${X11BASE}/include ${PTHREAD_CFLAGS} +LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS} post-patch: - @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g ; \ - s,g\+\+,${CXX},g ; \ - s,%%CXXFLAGS%%,${CXXFLAGS},g ; s,%%LIBS%%,${LIBS},g ; \ - s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile .for file in include/globals.h globals.cpp @${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/${file} .endfor diff --git a/math/goblin/distinfo b/math/goblin/distinfo index 3e2b776d59cc..e6fe4635a9cb 100644 --- a/math/goblin/distinfo +++ b/math/goblin/distinfo @@ -1 +1 @@ -MD5 (goblin.2.6b5.tar.gz) = 93888501dd9f1a8425289059aa578892 +MD5 (goblin.2.6.tar.gz) = bd59339b968e9dd383e493a3530fafc7 diff --git a/math/goblin/files/patch-Makefile b/math/goblin/files/patch-Makefile index d914691ea316..df7bc7a172b9 100644 --- a/math/goblin/files/patch-Makefile +++ b/math/goblin/files/patch-Makefile @@ -1,19 +1,19 @@ ---- Makefile.orig Mon Mar 31 19:07:24 2003 -+++ Makefile Mon Mar 31 19:08:45 2003 +--- Makefile.orig Fri May 2 03:21:48 2003 ++++ Makefile Mon May 12 15:32:38 2003 @@ -26,13 +26,13 @@ # GNU
-cpp = g++ -c -g -O5 -Wall -pedantic -Iinclude
-+cpp = g++ -c -g -O5 -Wall -pedantic -Iinclude %%CXXFLAGS%%
++cpp = $(CXX) -c $(CXXFLAGS) -pedantic -Iinclude
# To link with the static library libtcl.*.a
-link = g++ -lm
-+link = g++ -lm %%LIBS%%
++link = $(CXX) -lm $(LDFLAGS)
# To link with the shared object libtcl.*.so
# link = g++ -lm -Wl,-brtl -bbigtoc
# To link shared object
-linkShared = g++ -lm -Wl,-shared
-+linkShared = g++ -lm -Wl,-shared %%LIBS%%
++linkShared = $(CXX) -lm -Wl,-shared $(LDFLAGS)
# xlC
@@ -32,9 +32,27 @@ -goblin_include_path = /usr/include
-goblin_lib_path = /usr/lib
-goblin_bin_path = /usr/bin
-+goblin_include_path = %%PREFIX%%/include
-+goblin_lib_path = %%PREFIX%%/lib
-+goblin_bin_path = %%PREFIX%%/bin
++goblin_include_path = $(PREFIX)/include
++goblin_lib_path = $(PREFIX)/lib
++goblin_bin_path = $(PREFIX)/bin
#------------------------------------------------------------------------
+@@ -683,7 +683,7 @@ +
+ shared: $(objects) goshMain.o goshGraph.o goshLin.o message.o
+ $(linkShared) $(objects) goshMain.o goshGraph.o goshLin.o message.o \
+- -lpthread -o libgoblin.so
++ -o libgoblin.so
+
+
+
+@@ -691,7 +691,7 @@ +
+ gosh: goblin $(gosh_objects)
+ $(link) $(gosh_objects) goblin.a \
+- -lpthread -ltcl$(libtcl) -ltk$(libtk) -o gosh
++ -ltcl$(libtcl) -ltk$(libtk) -o gosh
+
+
+
diff --git a/math/goblin/pkg-plist b/math/goblin/pkg-plist index 5710d699d364..e144e2700ba3 100644 --- a/math/goblin/pkg-plist +++ b/math/goblin/pkg-plist @@ -108,7 +108,6 @@ bin/goblin.%%PORTVER%%/samples/connect6.gob bin/goblin.%%PORTVER%%/samples/connect7.gob bin/goblin.%%PORTVER%%/samples/dodeka.gob bin/goblin.%%PORTVER%%/samples/dsearch1.gob -bin/goblin.%%PORTVER%%/samples/dummy.gob bin/goblin.%%PORTVER%%/samples/europe.gob bin/goblin.%%PORTVER%%/samples/gedecomp1.gob bin/goblin.%%PORTVER%%/samples/gedecomp2.gob @@ -124,6 +123,7 @@ bin/goblin.%%PORTVER%%/samples/goblet.gob bin/goblin.%%PORTVER%%/samples/gsearch1.gob bin/goblin.%%PORTVER%%/samples/hamilton57.gob bin/goblin.%%PORTVER%%/samples/icosa.gob +bin/goblin.%%PORTVER%%/samples/lp3a.gob bin/goblin.%%PORTVER%%/samples/maxbflow1.gob bin/goblin.%%PORTVER%%/samples/maxbflow2.gob bin/goblin.%%PORTVER%%/samples/maxbflow3.gob @@ -231,14 +231,10 @@ bin/goblin.%%PORTVER%%/stepOver2.gif bin/goblin.%%PORTVER%%/stepSingle.gif bin/goblin.%%PORTVER%%/stepSingle2.gif bin/goblin.%%PORTVER%%/tableauCol.gif -bin/goblin.%%PORTVER%%/tableauCol.gif2 bin/goblin.%%PORTVER%%/tableauObj.gif -bin/goblin.%%PORTVER%%/tableauObj.gif2 bin/goblin.%%PORTVER%%/tableauPivot.gif bin/goblin.%%PORTVER%%/tableauRHS.gif -bin/goblin.%%PORTVER%%/tableauRHS.gif2 bin/goblin.%%PORTVER%%/tableauRow.gif -bin/goblin.%%PORTVER%%/tableauRow.gif2 bin/goblin.%%PORTVER%%/tclLogo.gif bin/goblin.%%PORTVER%%/title.tk bin/goblin.%%PORTVER%%/toggleBrowser.gif @@ -246,6 +242,7 @@ bin/goblin.%%PORTVER%%/toggleEditor.gif bin/goblin.%%PORTVER%%/toggleScript.gif bin/goblin.%%PORTVER%%/traceopt.tk bin/goblin.%%PORTVER%%/workspace.tk +include/goblin.%%PORTVER%%/~globals.h include/goblin.%%PORTVER%%/absbal.h include/goblin.%%PORTVER%%/absbig.h include/goblin.%%PORTVER%%/absdig.h |