aboutsummaryrefslogtreecommitdiff
path: root/math/grace
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2005-10-29 21:09:02 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2005-10-29 21:09:02 +0000
commit4541402f83997fd3dc2af2c397aa57f993034f2c (patch)
tree136fcaeb4ec5a86a6540915b3497e67caebb297b /math/grace
parent88a14b6db0519e6de6c1499218bbe0903c3be03f (diff)
downloadports-4541402f83997fd3dc2af2c397aa57f993034f2c.tar.gz
ports-4541402f83997fd3dc2af2c397aa57f993034f2c.zip
Notes
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile2
-rw-r--r--math/grace/files/patch-ag12
2 files changed, 13 insertions, 1 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index e85e3e058f0a..84b21add4096 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grace
PORTVERSION= 5.1.18
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math print
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
diff --git a/math/grace/files/patch-ag b/math/grace/files/patch-ag
new file mode 100644
index 000000000000..f8312f0b9bf7
--- /dev/null
+++ b/math/grace/files/patch-ag
@@ -0,0 +1,12 @@
+--- src/dlmodule.c.orig 3 Jul 2004 20:47:45 -0000
++++ src/dlmodule.c 27 Oct 2005 11:08:30 -0000
+@@ -89,6 +89,9 @@
+ return RETURN_FAILURE;
+ }
+
++ /* clear error indicator */
++ dlerror();
++
+ newkey.data = dlsym(handle, dl_function);
+ if ((error = (char *) dlerror()) != NULL) {
+ errmsg(error);