aboutsummaryrefslogtreecommitdiff
path: root/math/grace
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2000-12-29 16:22:02 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2000-12-29 16:22:02 +0000
commitde624ba7565400d1c57744916425a0b69148484e (patch)
tree6ad03a94cb25b0393f1bb30ff41b15aabed364a6 /math/grace
parent22d9d76d60a5cd771a61f15e3dab0c59f3925f12 (diff)
downloadports-de624ba7565400d1c57744916425a0b69148484e.tar.gz
ports-de624ba7565400d1c57744916425a0b69148484e.zip
Notes
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile30
-rw-r--r--math/grace/distinfo2
-rw-r--r--math/grace/files/patch-aa40
-rw-r--r--math/grace/files/patch-ab16
-rw-r--r--math/grace/files/patch-ac15
-rw-r--r--math/grace/files/patch-ad15
-rw-r--r--math/grace/files/patch-ae29
-rw-r--r--math/grace/pkg-plist15
8 files changed, 69 insertions, 93 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 255bf2769222..f2c3c2430e0f 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -1,15 +1,15 @@
# New ports collection makefile for: grace
# Date created: Dec 28 1998
-# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+# Whom: Lars Koeller <Lars.Köller@Uni-Bielefeld.de>
#
# $FreeBSD$
#
PORTNAME= grace
-PORTVERSION= 5.0.3g
+PORTVERSION= 5.1.2
CATEGORIES= math print
#
-# You never know when and why this caotic team moves it to ../src/old/ :-)
+# You never know when and why it is moved to ../src/old/ :-)
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
ftp://plasma-gate.weizmann.ac.il/pub/grace/src/old/ \
@@ -17,33 +17,29 @@ MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/old/ \
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/old/ \
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/
-DISTNAME= grace-5.0.3gamma
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
-BUILD_DEPENDS= ${X11BASE}/lib/libhlpclient.a:${PORTSDIR}/x11/libhelp
-LIB_DEPENDS= Xbae.7:${PORTSDIR}/x11-toolkits/xbae \
+LIB_DEPENDS= Xbae.8:${PORTSDIR}/x11-toolkits/xbae \
netcdf.1:${PORTSDIR}/math/netcdf \
fftw.2:${PORTSDIR}/math/fftw \
- pdf.2:${PORTSDIR}/print/pdflib \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png \
- t1.1:${PORTSDIR}/devel/t1lib
+ t1.1:${PORTSDIR}/devel/t1lib \
+ XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml \
+ pdf.3:${PORTSDIR}/print/pdflib3
MAN1= grace.1 xmgrace.1 gracebat.1 grconvert.1
USE_X_PREFIX= YES
-USE_XPM= yes
USE_GMAKE= YES
USE_MOTIF= YES
HAS_CONFIGURE= YES
CONFIGURE_ARGS= -prefix=${X11BASE} \
- --enable-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include:${LOCALBASE}/include/gd \
- --enable-libhelp \
- --enable-extra-ldpath=${LOCALBASE}/lib \
- --enable-grace-home=${X11BASE}/lib/X11/grace \
- --enable-config=generic
+ --with-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include \
+ --with-extra-ldpath=${LOCALBASE}/lib \
+ --enable-grace-home=${X11BASE}/lib/X11/grace
ALL_TARGET=
INSTALL_TARGET= install links
@@ -54,6 +50,10 @@ post-patch:
${RM} -f ${WRKSRC}/configure.input
post-install:
- ${LN} -s ${X11BASE}/lib/X11/grace/doc ${X11BASE}/share/doc/grace
+.if !defined(NOPORTDOCS)
+ if [ ! -e ${X11BASE}/share/doc/grace ]; then \
+ ${LN} -s ${X11BASE}/lib/X11/grace/doc ${X11BASE}/share/doc/grace; \
+ fi
+.endif
.include <bsd.port.mk>
diff --git a/math/grace/distinfo b/math/grace/distinfo
index fd8fed99d98e..5ede778d15fc 100644
--- a/math/grace/distinfo
+++ b/math/grace/distinfo
@@ -1 +1 @@
-MD5 (grace-5.0.3gamma.tar.gz) = fe200b1fe353afa3cd0cb580ef9d2106
+MD5 (grace-5.1.2.tar.gz) = 3f630258a3572d9988aa6010a8167e39
diff --git a/math/grace/files/patch-aa b/math/grace/files/patch-aa
index b8b15fb95109..0431e4afb6be 100644
--- a/math/grace/files/patch-aa
+++ b/math/grace/files/patch-aa
@@ -1,40 +1,18 @@
-*** configure.orig Sun Aug 22 12:11:35 1999
---- configure Fri Sep 10 16:22:17 1999
+*** configure.orig Mon May 22 19:54:43 2000
+--- configure Mon May 22 19:54:47 2000
***************
-*** 1096,1106 ****
-
- if test "x${GCC}" = "xyes"
- then
-- case "${host}" in
-- i?86-*-linux-*) CFLAGS="-m486 -malign-double $CFLAGS";;
-- i?86-*) CFLAGS="-m486 $CFLAGS";;
-- esac
--
- echo $ac_n "checking "for gcc strength-reduce bug"""... $ac_c" 1>&6
- echo "configure:1106: checking "for gcc strength-reduce bug"" >&5
- if eval "test \"`echo '$''{'ac_cv_c_gcc_strength_bug'+set}'`\" = set"; then
---- 1096,1101 ----
-***************
-*** 1832,1838 ****
+*** 2590,2596 ****
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
-
+
! test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL_PROGRAM}'
-
+
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
-
---- 1827,1833 ----
+
+--- 2590,2596 ----
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
-
+
! test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 555'
-
+
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
-
-***************
-*** 8939,8942 ****
- chmod +x $CONFIG_STATUS
- rm -fr confdefs* $ac_clean_files
- test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
--
---- 8934,8936 ----
diff --git a/math/grace/files/patch-ab b/math/grace/files/patch-ab
index acae2878785d..5d298e90d053 100644
--- a/math/grace/files/patch-ab
+++ b/math/grace/files/patch-ab
@@ -1,19 +1,11 @@
-*** conf/Make.conf.in.org Fri Sep 10 09:32:03 1999
---- conf/Make.conf.in Fri Sep 10 09:32:27 1999
+*** ac-tools/Make.conf.in.orig Mon May 22 19:57:32 2000
+--- ac-tools/Make.conf.in Mon May 22 19:57:36 2000
***************
-*** 93,98 ****
---- 93,99 ----
+*** 90,95 ****
+--- 90,96 ----
# BSD install
INSTALL=@INSTALL@
INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_SCRIPT=@INSTALL_SCRIPT@
INSTALL_DATA=@INSTALL_DATA@
MKINSTALLDIRS=@MKINSTALLDIRS@
-
-***************
-*** 119,122 ****
-
- # HTML help viewer command
- HELPVIEWER=@HELPVIEWER@
--
---- 120,122 ----
diff --git a/math/grace/files/patch-ac b/math/grace/files/patch-ac
index c15e4275b611..470793b4e7e9 100644
--- a/math/grace/files/patch-ac
+++ b/math/grace/files/patch-ac
@@ -1,19 +1,18 @@
-*** examples/Makefile.org Fri Sep 10 09:25:47 1999
---- examples/Makefile Fri Sep 10 09:25:57 1999
+*** examples/Makefile.orig Mon May 22 19:58:45 2000
+--- examples/Makefile Mon May 22 19:59:07 2000
***************
-*** 31,37 ****
+*** 33,39 ****
install : $(EXAMPLES) $(DOTEST)
$(MKINSTALLDIRS) $(GRACE_HOME)/examples
for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
! $(INSTALL_PROGRAM) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
-
+
links : dummy
-
---- 31,37 ----
+
+--- 33,39 ----
install : $(EXAMPLES) $(DOTEST)
$(MKINSTALLDIRS) $(GRACE_HOME)/examples
for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
! $(INSTALL_SCRIPT) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
-
+
links : dummy
-
diff --git a/math/grace/files/patch-ad b/math/grace/files/patch-ad
index d1dcada7354c..029b5c9fa220 100644
--- a/math/grace/files/patch-ad
+++ b/math/grace/files/patch-ad
@@ -1,19 +1,18 @@
-*** doc/Makefile.orig Fri Aug 20 00:31:44 1999
---- doc/Makefile Fri Sep 10 11:06:06 1999
+*** doc/Makefile.orig Mon May 22 20:00:24 2000
+--- doc/Makefile Mon May 22 20:00:51 2000
***************
-*** 66,72 ****
+*** 78,84 ****
$(MKINSTALLDIRS) $(PREFIX)/man
$(MKINSTALLDIRS) $(PREFIX)/man/man1
cd $(PREFIX)/man/man1; \
! for i in $? $(MANLINKS); do $(RM) $$i; $(LN_S) $(GRACE_HOME)/doc/$$i $$i; done
-
+
tests : dummy
-
---- 66,72 ----
+
+--- 78,84 ----
$(MKINSTALLDIRS) $(PREFIX)/man
$(MKINSTALLDIRS) $(PREFIX)/man/man1
cd $(PREFIX)/man/man1; \
! for i in $? $(MANLINKS); do $(RM) $$i; $(INSTALL_DATA) $(GRACE_HOME)/doc/$$i $$i; done
-
+
tests : dummy
-
diff --git a/math/grace/files/patch-ae b/math/grace/files/patch-ae
index dd55885be908..5f5cd7f0d063 100644
--- a/math/grace/files/patch-ae
+++ b/math/grace/files/patch-ae
@@ -1,16 +1,13 @@
---- conf/generic.orig Mon Mar 29 01:02:41 1999
-+++ conf/generic Fri Sep 10 16:10:36 1999
-@@ -17,11 +17,11 @@
- ###############################
- # Misc optimization flags
- #
--OPTIMIZE="-O"
-+#OPTIMIZE="-O"
- ###############################
-
- ###############################
- # Flags used for debugging
- #
--DEBUG="-g"
-+#DEBUG="-g"
- ###############################
+*** src/pdfdrv.c.org Thu Apr 20 22:34:34 2000
+--- src/pdfdrv.c Thu Aug 3 21:23:05 2000
+***************
+*** 57,62 ****
+--- 57,64 ----
+ # include "motifinc.h"
+ #endif
+
++ #define PDF_set_fillrule(handle, rule) PDF_set_parameter(handle, "fillrule", rule)
++
+ static void pdf_error_handler(PDF *p, int type, const char* msg);
+
+ static unsigned long page_scale;
diff --git a/math/grace/pkg-plist b/math/grace/pkg-plist
index 0513c4f83c35..faad6d41565a 100644
--- a/math/grace/pkg-plist
+++ b/math/grace/pkg-plist
@@ -28,7 +28,7 @@ lib/X11/grace/doc/UsersGuide.html
lib/X11/grace/doc/grace.1
lib/X11/grace/doc/gracebat.1
lib/X11/grace/doc/grconvert.1
-lib/X11/grace/doc/mygraph.gif
+lib/X11/grace/doc/mygraph.png
lib/X11/grace/doc/nohelp.html
lib/X11/grace/doc/philosophical-gnu-sm.jpg
lib/X11/grace/doc/shiftdata.sh
@@ -38,6 +38,7 @@ lib/X11/grace/examples/arrows.agr
lib/X11/grace/examples/au.agr
lib/X11/grace/examples/axes.agr
lib/X11/grace/examples/bar.agr
+lib/X11/grace/examples/boxplot.agr
lib/X11/grace/examples/brw.dat
lib/X11/grace/examples/chartebar.agr
lib/X11/grace/examples/charts.agr
@@ -52,14 +53,16 @@ lib/X11/grace/examples/log.dat
lib/X11/grace/examples/log2.agr
lib/X11/grace/examples/logistic.agr
lib/X11/grace/examples/logistic.fit
+lib/X11/grace/examples/logit.agr
lib/X11/grace/examples/logtest.par
lib/X11/grace/examples/manygraphs.agr
lib/X11/grace/examples/mlo.dat
-lib/X11/grace/examples/moresyms.agr
lib/X11/grace/examples/motif.agr
+lib/X11/grace/examples/pie.agr
lib/X11/grace/examples/polar.agr
lib/X11/grace/examples/props.agr
lib/X11/grace/examples/regions.par
+lib/X11/grace/examples/spectrum.agr
lib/X11/grace/examples/stackedb.agr
lib/X11/grace/examples/symslines.agr
lib/X11/grace/examples/terr.agr
@@ -74,12 +77,20 @@ lib/X11/grace/examples/tinset.agr
lib/X11/grace/examples/tlog.agr
lib/X11/grace/examples/tmc.c
lib/X11/grace/examples/tstack.agr
+lib/X11/grace/examples/txttrans.agr
lib/X11/grace/examples/txyr.agr
lib/X11/grace/examples/typeset.agr
+lib/X11/grace/examples/vmap.agr
+lib/X11/grace/examples/xysize.agr
lib/X11/grace/examples/xyz.agr
lib/X11/grace/fonts/FontDataBase
lib/X11/grace/fonts/enc/IsoLatin1.enc
lib/X11/grace/fonts/enc/IsoLatin2.enc
+lib/X11/grace/fonts/enc/IsoLatin9.enc
+lib/X11/grace/fonts/enc/MacRoman.enc
+lib/X11/grace/fonts/enc/PDFDoc.enc
+lib/X11/grace/fonts/enc/PSLatin1.enc
+lib/X11/grace/fonts/enc/WinAnsi.enc
lib/X11/grace/fonts/type1/d050000l.afm
lib/X11/grace/fonts/type1/d050000l.pfb
lib/X11/grace/fonts/type1/n019003l.afm