aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-14 09:12:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-14 09:12:07 +0000
commitb240e42939bc42c14f14f92a6578107c6afc1805 (patch)
treed5895949a3f52f31bef2dad3c40b77a383791296 /math/gretl/Makefile
parenta9cf544489335f23fb1592188b85037ed02a85cb (diff)
downloadports-b240e42939bc42c14f14f92a6578107c6afc1805.tar.gz
ports-b240e42939bc42c14f14f92a6578107c6afc1805.zip
Notes
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 2523f9ffc44e..7778218a6c6f 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gretl
-PORTVERSION= 1.7.7
-PORTREVISION= 1
+PORTVERSION= 1.7.9
CATEGORIES= math finance
MASTER_SITES= SF
@@ -22,11 +21,11 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
WANT_GNOME= yes
-USE_GNOME= gnometarget gtk20 libxml2
+USE_GNOME= gtk20 libxml2
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15 autoconf:262
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DGNUPLOT_PNG" \
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnuregex ${GCCLIBDIR}"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
ALL_TARGET= # empty
@@ -47,7 +46,7 @@ BROKEN= math/lapack appears to be broken on alpha
.if ${HAVE_GNOME:Mlibgnomeui}!=""
PKGNAMESUFFIX= -gnome
-USE_GNOME+= gnomeprefix gtksourceview2 libgnomeui
+USE_GNOME+= gnomehier gtksourceview2 libgnomeui
.else
CONFIGURE_ARGS+= --without-gnome --without-gtksourceview
.endif
@@ -68,6 +67,8 @@ LAPACK= -llapack
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|set term png|set term dumb|g' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<regex.h>|<gnu/regex.h>|g' \
${WRKSRC}/gui2/gtksourceview/gtksourceregex.c