aboutsummaryrefslogtreecommitdiff
path: root/math/gri/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 17:57:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 17:57:17 +0000
commit752a55f64435a39dedafc18ee52bf306a192ebed (patch)
tree1c78b73b8d533a16a9ca96c07689b89ead590ca8 /math/gri/Makefile
parenta058da9f77188a6e902f1aa97402133d2687a5ab (diff)
downloadports-752a55f64435a39dedafc18ee52bf306a192ebed.tar.gz
ports-752a55f64435a39dedafc18ee52bf306a192ebed.zip
Notes
Diffstat (limited to 'math/gri/Makefile')
-rw-r--r--math/gri/Makefile37
1 files changed, 24 insertions, 13 deletions
diff --git a/math/gri/Makefile b/math/gri/Makefile
index 48fc1fc1586b..0215c08d537d 100644
--- a/math/gri/Makefile
+++ b/math/gri/Makefile
@@ -6,33 +6,44 @@
#
PORTNAME= gri
-PORTVERSION= 2.10.1
+PORTVERSION= 2.12.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gri
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= gri-${PORTVERSION}-arch-indep
-MAINTAINER= bdodson@scms.utmb.edu
+MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
-WRKSRC= ${WRKDIR}/gri-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_PERL5_BUILD= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= YES
-MAKE_ENV+= PREFIX=${PREFIX}
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+.if defined(NOPORTDOCS)
ALL_TARGET= gri
-MAN1= gri.1
+INSTALL_TARGET= install-bin
+.endif
+
+MAN1= gri.1 gri_merge.1 gri_unpage.1
post-extract:
- ${CP} ${WRKSRC}/doc/gri-manpage.1 ${WRKSRC}/gri.1
+ @${RM} -f ${WRKSRC}/doc/*.info* ${WRKSRC}/doc/info
+ @${MV} -f ${WRKSRC}/doc/gri-manpage.1 ${WRKSRC}/doc/gri.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/makeinfo/makeinfo --no-split/" ${WRKSRC}/doc/Makefile
post-install:
-.if defined(NOPORTDOCS)
- ${RM} -rf ${PREFIX}/share/gri/doc
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${MANPREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DATA} ${WRKSRC}/doc/gri.info ${PREFIX}/info
+ install-info ${PREFIX}/info/gri.info ${PREFIX}/info/dir
.endif
- ${CHMOD} 555 ${PREFIX}/bin/gri_merge
- ${CHMOD} 555 ${PREFIX}/bin/gri_unpage
- ${INSTALL_MAN} ${WRKSRC}/gri.1 ${PREFIX}/man/man1
- @-${RM} ${PREFIX}/share/gri/${PORTVERSION}/license.txt
.include <bsd.port.mk>