aboutsummaryrefslogtreecommitdiff
path: root/math/grpn
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-26 20:50:14 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-26 20:50:14 +0000
commite5df2495863261eadee2ae4fbf57d98984d9c93b (patch)
treec7c1f797d3d14ad9b4d783abbe924ceb9fd02cd7 /math/grpn
parent2d09300ec544d55e6d39c7b83377a699c304ac6d (diff)
downloadports-e5df2495863261eadee2ae4fbf57d98984d9c93b.tar.gz
ports-e5df2495863261eadee2ae4fbf57d98984d9c93b.zip
Notes
Diffstat (limited to 'math/grpn')
-rw-r--r--math/grpn/Makefile26
-rw-r--r--math/grpn/distinfo1
-rw-r--r--math/grpn/files/patch-aa32
-rw-r--r--math/grpn/pkg-comment1
-rw-r--r--math/grpn/pkg-descr12
-rw-r--r--math/grpn/pkg-plist1
6 files changed, 73 insertions, 0 deletions
diff --git a/math/grpn/Makefile b/math/grpn/Makefile
new file mode 100644
index 000000000000..91157cc091ef
--- /dev/null
+++ b/math/grpn/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: grpn
+# Version required: 1.1.0
+# Date created: 25 October 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= grpn-1.1.0
+CATEGORIES= math gnome
+MASTER_SITES= http://wilkins.ne.mediaone.net/grpn/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+ALL_TARGET=
+USE_X_PREFIX= yes
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+MAKE_ENV+= GTK_CONFIG=${GTK_CONFIG} \
+ X11BASE=${X11BASE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/grpn ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/math/grpn/distinfo b/math/grpn/distinfo
new file mode 100644
index 000000000000..ebad69971c28
--- /dev/null
+++ b/math/grpn/distinfo
@@ -0,0 +1 @@
+MD5 (grpn-1.1.0.tar.gz) = 64379257b174f5ad98dcc25c847b6e5d
diff --git a/math/grpn/files/patch-aa b/math/grpn/files/patch-aa
new file mode 100644
index 000000000000..443851e9a51d
--- /dev/null
+++ b/math/grpn/files/patch-aa
@@ -0,0 +1,32 @@
+--- Makefile.orig Mon May 31 21:46:31 1999
++++ Makefile Mon Oct 25 19:52:03 1999
+@@ -3,7 +3,7 @@
+ # Please read the next few lines and enter the correct values.
+
+ # What compiler should be used
+-CC = gcc
++CC?= gcc
+
+ # Where to find the gtk-config script
+ GTK_DIR =
+@@ -17,9 +17,9 @@
+ # add -DUSE_GNOME if you want to make grpn GNOME compliant.
+
+
+-CFLAGS = -g -O2 -I/usr/X11/include `$(GTK_DIR)gtk-config --cflags` -DGTK_VER_1_1
++CFLAGS+= -I${X11BASE}/include -I${PREFIX}/include `${GTK_CONFIG} --cflags` -DGTK_VER_1_1
+
+-DFLAGS = -L/usr/X11/lib
++DFLAGS = -L${X11BASE}/lib -L${PREFIX}/lib
+
+ # end of user configurable section
+
+@@ -34,7 +34,7 @@
+
+
+
+-LIBS = `$(GTK_DIR)gtk-config --libs` -lX11 -lm
++LIBS = `${GTK_CONFIG} --libs` -lX11 -lm
+
+
+ grpn: $(OBJS)
diff --git a/math/grpn/pkg-comment b/math/grpn/pkg-comment
new file mode 100644
index 000000000000..55010a94bbf3
--- /dev/null
+++ b/math/grpn/pkg-comment
@@ -0,0 +1 @@
+GTK+-based reverse polish notation (RPN) calculator
diff --git a/math/grpn/pkg-descr b/math/grpn/pkg-descr
new file mode 100644
index 000000000000..711fc8b489fe
--- /dev/null
+++ b/math/grpn/pkg-descr
@@ -0,0 +1,12 @@
+GRPN is a RPN calculator for the X Window system built using
+the GIMP Toolkit (GTK).
+
+GRPN works with real numbers, complex numbers, matrices, and
+complex matrices. Numbers can be displayed in 4 different
+radix modes, and complex numbers can be displayed in either
+Cartesian or polar form.
+
+WWW: http://wilkins.ne.mediaone.net/grpn.html
+
+- Chris D. Faulhaber
+jedgar@fxp.org
diff --git a/math/grpn/pkg-plist b/math/grpn/pkg-plist
new file mode 100644
index 000000000000..f4704d2761d2
--- /dev/null
+++ b/math/grpn/pkg-plist
@@ -0,0 +1 @@
+bin/grpn