aboutsummaryrefslogtreecommitdiff
path: root/math/guppi/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-21 12:41:59 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-21 12:41:59 +0000
commit51ed61908b1636ca7e786cc1b443442cfba3054a (patch)
tree4d4e4dbb70cfc96c5ed48b89b2da5258626bd7e0 /math/guppi/Makefile
parent9f61918a7f2ec5a8850160e7e906d0fddc16890e (diff)
downloadports-51ed61908b1636ca7e786cc1b443442cfba3054a.tar.gz
ports-51ed61908b1636ca7e786cc1b443442cfba3054a.zip
Notes
Diffstat (limited to 'math/guppi/Makefile')
-rw-r--r--math/guppi/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
new file mode 100644
index 000000000000..f07f1a29fe44
--- /dev/null
+++ b/math/guppi/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: guppi
+# Date created: 22 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guppi
+PORTVERSION= 0.35.5
+CATEGORIES= math gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/Guppi
+DISTNAME= Guppi-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
+ glade.4:${PORTSDIR}/devel/libglade \
+ guile.9:${PORTSDIR}/lang/guile \
+ oaf.0:${PORTSDIR}/devel/oaf
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+USE_PYTHON= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -pthread"
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>