aboutsummaryrefslogtreecommitdiff
path: root/math/guppi/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-10-23 13:36:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-10-23 13:36:38 +0000
commit47eb709f128a600aa1d0676ddc3df244ba1f6c55 (patch)
treefdfe86ea28fe1f21fa1042f180d4f99cf4a5f254 /math/guppi/Makefile
parent6ca69f6700606e210fd95bafd2138cbb3d40ca33 (diff)
Notes
Diffstat (limited to 'math/guppi/Makefile')
-rw-r--r--math/guppi/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 0d1f945a9472..3cbf1640e52a 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= guppi
-PORTVERSION= 0.35.5
-PORTREVISION= 3
+PORTVERSION= 0.40.0
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/Guppi
@@ -15,14 +14,16 @@ DISTNAME= Guppi-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
+RUN_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
-USE_LIBTOOL= yes
USE_PYTHON= yes
INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.0" \
LIBS="-L${LOCALBASE}/lib -pthread"
@@ -31,7 +32,7 @@ PLIST_SUB= VERSION="${PORTVERSION}"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'