aboutsummaryrefslogtreecommitdiff
path: root/math/guppi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 16:51:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 16:51:09 +0000
commitd644ec35d177c8a247897ffebde1f0813620a56f (patch)
tree6e5fee3296ebdc000c90cd5a40100aea046cad32 /math/guppi
parent1ab48ca1a142b8f88acead0cba2d105f27a09e3c (diff)
downloadports-d644ec35d177c8a247897ffebde1f0813620a56f.tar.gz
ports-d644ec35d177c8a247897ffebde1f0813620a56f.zip
Notes
Diffstat (limited to 'math/guppi')
-rw-r--r--math/guppi/Makefile24
-rw-r--r--math/guppi/files/patch-src-libguppidata_guppi-data.c11
-rw-r--r--math/guppi/files/patch-src-libguppidata_guppi-seq-scalar.c11
-rw-r--r--math/guppi/files/patch-src-libguppiplot_guppi-axis-markers.c15
-rw-r--r--math/guppi/files/patch-src-libguppispecfns_mconf.h12
-rw-r--r--math/guppi/files/patch-src-libguppiuseful_guppi-plug-in.c11
-rw-r--r--math/guppi/files/patch-src_libguppiplot_guppi-root-group-item.c16
-rw-r--r--math/guppi/pkg-plist73
8 files changed, 144 insertions, 29 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 5b172bbe9c1c..37eb431a49b8 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -13,33 +13,43 @@ MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/Guppi/0.40
DISTNAME= Guppi-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= A plotting program for GNOME
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
-USE_GETTEXT= yes
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
+USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libglade-1.0" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
GNUMERIC_IDLDIR="${WRKDIR}/gnumeric"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= VERSION="${PORTVERSION}"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
post-extract:
@${MKDIR} ${WRKDIR}/gnumeric
@${CP} ${FILESDIR}/GNOME_Gnumeric_Graph.idl ${WRKDIR}/gnumeric
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/aclocal.m4
-.if ${OSVERSION} >= 700029
-BROKEN= Incorrect objformat handling
-.endif
+post-install:
+ @${RMDIR} ${LOCALBASE}/share/gnome/help/guppi/C/images
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/guppi/files/patch-src-libguppidata_guppi-data.c b/math/guppi/files/patch-src-libguppidata_guppi-data.c
new file mode 100644
index 000000000000..24e7ca09a611
--- /dev/null
+++ b/math/guppi/files/patch-src-libguppidata_guppi-data.c
@@ -0,0 +1,11 @@
+--- src/libguppidata/guppi-data.c.orig 2007-12-13 15:31:26.000000000 +0100
++++ src/libguppidata/guppi-data.c 2007-12-13 15:32:13.000000000 +0100
+@@ -1079,8 +1079,6 @@
+ static void
+ guppi_data_class_init (GuppiDataClass *klass)
+ {
+- static void build_menu (GuppiData *, GtkMenu *, gpointer);
+-
+ GtkObjectClass *object_class = (GtkObjectClass *) klass;
+
+ parent_class = gtk_type_class (GTK_TYPE_OBJECT);
diff --git a/math/guppi/files/patch-src-libguppidata_guppi-seq-scalar.c b/math/guppi/files/patch-src-libguppidata_guppi-seq-scalar.c
new file mode 100644
index 000000000000..10a4ca78f262
--- /dev/null
+++ b/math/guppi/files/patch-src-libguppidata_guppi-seq-scalar.c
@@ -0,0 +1,11 @@
+--- src/libguppidata/guppi-seq-scalar.c.orig 2007-12-13 15:33:12.000000000 +0100
++++ src/libguppidata/guppi-seq-scalar.c 2007-12-13 15:33:37.000000000 +0100
+@@ -1775,8 +1775,6 @@
+ static void
+ guppi_seq_scalar_class_init (GuppiSeqScalarClass *klass)
+ {
+- static GtkWidget *info_display (GuppiData *);
+-
+ GtkObjectClass *object_class = (GtkObjectClass *) klass;
+ GuppiDataClass *data_class = GUPPI_DATA_CLASS (klass);
+ GuppiSeqClass *seq_class = GUPPI_SEQ_CLASS (klass);
diff --git a/math/guppi/files/patch-src-libguppiplot_guppi-axis-markers.c b/math/guppi/files/patch-src-libguppiplot_guppi-axis-markers.c
new file mode 100644
index 000000000000..7356f348178c
--- /dev/null
+++ b/math/guppi/files/patch-src-libguppiplot_guppi-axis-markers.c
@@ -0,0 +1,15 @@
+--- src/libguppiplot/guppi-axis-markers.c.orig 2007-12-13 15:37:21.000000000 +0100
++++ src/libguppiplot/guppi-axis-markers.c 2007-12-13 15:38:10.000000000 +0100
+@@ -47,10 +47,11 @@
+
+ static guint gam_signals[LAST_SIGNAL] = { 0 };
+
++static void clear (GuppiAxisMarkers *);
++
+ static void
+ guppi_axis_markers_finalize (GtkObject * obj)
+ {
+- static void clear (GuppiAxisMarkers *);
+ GuppiAxisMarkers *gal = GUPPI_AXIS_MARKERS (obj);
+
+ guppi_finalized (obj);
diff --git a/math/guppi/files/patch-src-libguppispecfns_mconf.h b/math/guppi/files/patch-src-libguppispecfns_mconf.h
new file mode 100644
index 000000000000..c55facc0692e
--- /dev/null
+++ b/math/guppi/files/patch-src-libguppispecfns_mconf.h
@@ -0,0 +1,12 @@
+--- src/libguppispecfns/mconf.h.orig 2007-12-13 15:30:12.000000000 +0100
++++ src/libguppispecfns/mconf.h 2007-12-13 15:30:24.000000000 +0100
+@@ -139,9 +139,6 @@
+
+ int mtherr (const char *fctnam, int code);
+
+-/* Variable for error reporting. See mtherr.c. */
+-extern int merror;
+-
+ END_GUPPI_DECLS
+
+ #endif /* __MCONF_H__ */
diff --git a/math/guppi/files/patch-src-libguppiuseful_guppi-plug-in.c b/math/guppi/files/patch-src-libguppiuseful_guppi-plug-in.c
new file mode 100644
index 000000000000..f3107cff21d5
--- /dev/null
+++ b/math/guppi/files/patch-src-libguppiuseful_guppi-plug-in.c
@@ -0,0 +1,11 @@
+--- src/libguppiuseful/guppi-plug-in.c.orig 2007-12-13 15:26:58.000000000 +0100
++++ src/libguppiuseful/guppi-plug-in.c 2007-12-13 15:28:52.000000000 +0100
+@@ -47,7 +47,7 @@
+
+ guppi_finalized (obj);
+
+- guppi_free0 ((gpointer)pi->load_path);
++ guppi_free0 (pi->load_path);
+
+ if (parent_class->finalize)
+ parent_class->finalize (obj);
diff --git a/math/guppi/files/patch-src_libguppiplot_guppi-root-group-item.c b/math/guppi/files/patch-src_libguppiplot_guppi-root-group-item.c
index 8d53b397c82e..570afd0c459c 100644
--- a/math/guppi/files/patch-src_libguppiplot_guppi-root-group-item.c
+++ b/math/guppi/files/patch-src_libguppiplot_guppi-root-group-item.c
@@ -1,5 +1,17 @@
---- src/libguppiplot/guppi-root-group-item.c.orig Mon Sep 6 15:01:23 2004
-+++ src/libguppiplot/guppi-root-group-item.c Mon Sep 6 15:01:35 2004
+--- src/libguppiplot/guppi-root-group-item.c.orig 2002-01-08 07:31:08.000000000 +0100
++++ src/libguppiplot/guppi-root-group-item.c 2007-12-13 15:36:33.000000000 +0100
+@@ -153,10 +153,10 @@
+ guppi_canvas_item_set_bbox_c (item, 0, 0, xsize, ysize);
+ }
+
++static void canv_size_allocate (GtkWidget *, GtkAllocation *, gpointer);
+ static void
+ changed_scale (GuppiCanvasItem *item, double scale)
+ {
+- static void canv_size_allocate (GtkWidget *, GtkAllocation *, gpointer);
+ GuppiRootGroupItem *root_item = GUPPI_ROOT_GROUP_ITEM (item);
+
+ if (GUPPI_CANVAS_ITEM_CLASS (parent_class)->changed_scale)
@@ -548,6 +548,7 @@
return motion_notify_event (root, &(ev->motion));
diff --git a/math/guppi/pkg-plist b/math/guppi/pkg-plist
index b01f3cbfb0c1..0d0680bb6e1d 100644
--- a/math/guppi/pkg-plist
+++ b/math/guppi/pkg-plist
@@ -131,48 +131,82 @@ include/gnome-1.0/libguppitank/guppi-tank-init.h
include/gnome-1.0/libguppitank/guppi-tank.h
lib/guppi/plug-ins/%%VERSION%%/plot/axis/axis.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/axis/guppi_axis.so
+lib/guppi/plug-ins/%%VERSION%%/plot/axis/guppi_axis.la
+lib/guppi/plug-ins/%%VERSION%%/plot/axis/guppi_axis.a
lib/guppi/plug-ins/%%VERSION%%/plot/background/background.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/background/guppi_background.so
+lib/guppi/plug-ins/%%VERSION%%/plot/background/guppi_background.la
+lib/guppi/plug-ins/%%VERSION%%/plot/background/guppi_background.a
lib/guppi/plug-ins/%%VERSION%%/plot/barchart/barchart-stackswap.png
lib/guppi/plug-ins/%%VERSION%%/plot/barchart/barchart.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/barchart/guppi_barchart.so
+lib/guppi/plug-ins/%%VERSION%%/plot/barchart/guppi_barchart.la
+lib/guppi/plug-ins/%%VERSION%%/plot/barchart/guppi_barchart.a
lib/guppi/plug-ins/%%VERSION%%/plot/boxplot/boxplot.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/boxplot/guppi_boxplot.so
+lib/guppi/plug-ins/%%VERSION%%/plot/boxplot/guppi_boxplot.la
+lib/guppi/plug-ins/%%VERSION%%/plot/boxplot/guppi_boxplot.a
lib/guppi/plug-ins/%%VERSION%%/plot/compass-box/compass-box.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/compass-box/guppi_compass_box.so
+lib/guppi/plug-ins/%%VERSION%%/plot/compass-box/guppi_compass_box.la
+lib/guppi/plug-ins/%%VERSION%%/plot/compass-box/guppi_compass_box.a
lib/guppi/plug-ins/%%VERSION%%/plot/frame/frame.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/frame/guppi_frame.so
+lib/guppi/plug-ins/%%VERSION%%/plot/frame/guppi_frame.la
+lib/guppi/plug-ins/%%VERSION%%/plot/frame/guppi_frame.a
lib/guppi/plug-ins/%%VERSION%%/plot/image/guppi_image.so
+lib/guppi/plug-ins/%%VERSION%%/plot/image/guppi_image.la
+lib/guppi/plug-ins/%%VERSION%%/plot/image/guppi_image.a
lib/guppi/plug-ins/%%VERSION%%/plot/image/image.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/legend/guppi_legend.so
+lib/guppi/plug-ins/%%VERSION%%/plot/legend/guppi_legend.la
+lib/guppi/plug-ins/%%VERSION%%/plot/legend/guppi_legend.a
lib/guppi/plug-ins/%%VERSION%%/plot/legend/legend.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/linechart/guppi_linechart.so
+lib/guppi/plug-ins/%%VERSION%%/plot/linechart/guppi_linechart.la
+lib/guppi/plug-ins/%%VERSION%%/plot/linechart/guppi_linechart.a
lib/guppi/plug-ins/%%VERSION%%/plot/linechart/linechart.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/linegraph/guppi_linegraph.so
+lib/guppi/plug-ins/%%VERSION%%/plot/linegraph/guppi_linegraph.la
+lib/guppi/plug-ins/%%VERSION%%/plot/linegraph/guppi_linegraph.a
lib/guppi/plug-ins/%%VERSION%%/plot/linegraph/linegraph.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi-pie-data.glade
lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi-pie-looks.glade
lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi-pie-state-config.glade
lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi_pie.so
+lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi_pie.la
+lib/guppi/plug-ins/%%VERSION%%/plot/pie/guppi_pie.a
lib/guppi/plug-ins/%%VERSION%%/plot/pie/pie-explode.png
lib/guppi/plug-ins/%%VERSION%%/plot/pie/pie-spin.png
lib/guppi/plug-ins/%%VERSION%%/plot/pie/pie.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/pricebars/guppi_pricebars.so
+lib/guppi/plug-ins/%%VERSION%%/plot/pricebars/guppi_pricebars.la
+lib/guppi/plug-ins/%%VERSION%%/plot/pricebars/guppi_pricebars.a
lib/guppi/plug-ins/%%VERSION%%/plot/pricebars/pricebars.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/scatter/guppi-scatter-state.glade
lib/guppi/plug-ins/%%VERSION%%/plot/scatter/guppi_scatter.so
+lib/guppi/plug-ins/%%VERSION%%/plot/scatter/guppi_scatter.la
+lib/guppi/plug-ins/%%VERSION%%/plot/scatter/guppi_scatter.a
lib/guppi/plug-ins/%%VERSION%%/plot/scatter/scatter-brush.png
lib/guppi/plug-ins/%%VERSION%%/plot/scatter/scatter-drag.png
lib/guppi/plug-ins/%%VERSION%%/plot/scatter/scatter.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/text/guppi-text-state.glade
lib/guppi/plug-ins/%%VERSION%%/plot/text/guppi_text.so
+lib/guppi/plug-ins/%%VERSION%%/plot/text/guppi_text.la
+lib/guppi/plug-ins/%%VERSION%%/plot/text/guppi_text.a
lib/guppi/plug-ins/%%VERSION%%/plot/text/text.plugin
lib/guppi/plug-ins/%%VERSION%%/plot/xybox/guppi_xybox.so
+lib/guppi/plug-ins/%%VERSION%%/plot/xybox/guppi_xybox.la
+lib/guppi/plug-ins/%%VERSION%%/plot/xybox/guppi_xybox.a
lib/guppi/plug-ins/%%VERSION%%/plot/xybox/xybox.plugin
lib/libguppi.so
lib/libguppi.so.16
+lib/libguppi.la
+lib/libguppi.a
lib/libguppitank.so
lib/libguppitank.so.16
+lib/libguppitank.la
+lib/libguppitank.a
share/aclocal/libguppi.m4
share/gnome/help/guppi/C/c20.html
share/gnome/help/guppi/C/docbook.css
@@ -182,25 +216,25 @@ share/gnome/help/guppi/C/topic.dat
%%DATADIR%%/glade/guppi-gnumeric-format-guru.glade
%%DATADIR%%/glade/view-properties.glade
%%DATADIR%%/scripts/guppi-gnumeric-plots.xml
-share/locale/az/LC_MESSAGES/Guppi.mo
-share/locale/da/LC_MESSAGES/Guppi.mo
-share/locale/de/LC_MESSAGES/Guppi.mo
-share/locale/el/LC_MESSAGES/Guppi.mo
-share/locale/es/LC_MESSAGES/Guppi.mo
-share/locale/fr/LC_MESSAGES/Guppi.mo
-share/locale/is/LC_MESSAGES/Guppi.mo
-share/locale/it/LC_MESSAGES/Guppi.mo
-share/locale/nl/LC_MESSAGES/Guppi.mo
-share/locale/no/LC_MESSAGES/Guppi.mo
-share/locale/pl/LC_MESSAGES/Guppi.mo
-share/locale/pt/LC_MESSAGES/Guppi.mo
-share/locale/pt_BR/LC_MESSAGES/Guppi.mo
-share/locale/ru/LC_MESSAGES/Guppi.mo
-share/locale/sk/LC_MESSAGES/Guppi.mo
-share/locale/sv/LC_MESSAGES/Guppi.mo
-share/locale/tr/LC_MESSAGES/Guppi.mo
-share/locale/uk/LC_MESSAGES/Guppi.mo
-share/locale/zh_CN/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/az/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/da/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/de/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/el/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/es/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/is/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/it/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/no/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/Guppi.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/Guppi.mo
share/oaf/GNOME_Guppi_Gnumeric.oaf
share/pixmaps/gnome-guppi.png
share/pixmaps/guppi/area.xpm
@@ -285,7 +319,6 @@ share/pixmaps/guppi/surface.xpm
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
-@dirrm share/gnome/help/guppi/C/images
@dirrm share/gnome/help/guppi/C
@dirrm share/gnome/help/guppi
@dirrm lib/guppi/plug-ins/%%VERSION%%/plot/xybox