aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /math/hs-Agda
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
downloadports-109269205e521bb1d2d87678a391e5adefff88d6.tar.gz
ports-109269205e521bb1d2d87678a391e5adefff88d6.zip
Notes
Diffstat (limited to 'math/hs-Agda')
-rw-r--r--math/hs-Agda/Makefile6
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal17
2 files changed, 14 insertions, 9 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 9de5448ab600..31b426771dd0 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -3,15 +3,13 @@
PORTNAME= Agda
PORTVERSION= 2.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Dependently typed functional programming language and proof assistant
-CABAL_SETUP= Setup.hs
-
-USE_CABAL= geniplate>=0.6.0.3 hashable>=1.2 hashtables \
+USE_CABAL= geniplate>=0.6.0.3 hashable>=1.1 hashtables \
haskeline>=0.6.3.2 haskell-src-exts>=1.9.6 mtl \
QuickCheck>=2.3 parallel syb>=0.1 unordered-containers>=0.2 \
xhtml zlib>=0.4.0.1
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index 208d469dd4d5..42b95170d46e 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,12 +1,19 @@
--- ./Agda.cabal.orig 2012-11-12 01:25:25.000000000 +0100
-+++ ./Agda.cabal 2013-03-09 17:44:08.000000000 +0100
-@@ -82,8 +82,8 @@
- process >= 1.0.1.0 && < 1.2,
++++ ./Agda.cabal 2013-05-03 23:08:18.000000000 +0200
+@@ -69,7 +69,7 @@
+
+ build-depends: base >= 4.2 && < 4.7,
+ mtl >= 2.0 && < 2.2,
+- QuickCheck >= 2.3 && < 2.6,
++ QuickCheck >= 2.3 && < 2.7,
+ haskell-src-exts >= 1.9.6 && < 1.14,
+ containers >= 0.1 && < 0.6,
+ unordered-containers == 0.2.*,
+@@ -83,7 +83,7 @@
haskeline >= 0.6.3.2 && < 0.8,
xhtml == 3000.2.*,
-- hashable >= 1.1.2.3 && < 1.2,
+ hashable >= 1.1.2.3 && < 1.2,
- hashtables == 1.0.*,
-+ hashable >= 1.1.2.3 && < 1.3,
+ hashtables == 1.1.*,
geniplate >= 0.6.0.3 && < 0.7,
parallel < 3.3,