aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-02-05 22:26:31 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-02-05 22:26:31 +0000
commitc731105b7f8e403a3db33599a7d7f1ce9257f375 (patch)
tree23d3f49a5183d8fbc5324dad9a1ae399f457b1d7 /math/hs-Agda
parent32ca3ee61e3889801319024959589312eb652bfa (diff)
downloadports-c731105b7f8e403a3db33599a7d7f1ce9257f375.tar.gz
ports-c731105b7f8e403a3db33599a7d7f1ce9257f375.zip
Notes
Diffstat (limited to 'math/hs-Agda')
-rw-r--r--math/hs-Agda/Makefile4
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal11
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs11
3 files changed, 23 insertions, 3 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 6aaa8cf9d2c7..a323aeef942a 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Agda
PORTVERSION= 2.3.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= A dependently typed functional programming language and proof assistant
CABAL_SETUP= Setup.hs
-USE_CABAL= hashable hashtables haskeline>=0.6.3.2 \
+USE_CABAL= hashable>=1.2 hashtables haskeline>=0.6.3.2 \
haskell-src-exts>=1.9.6 mtl QuickCheck>=2.3 syb>=0.1 \
xhtml zlib>=0.4.0.1
USE_ALEX= yes
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index d451dea27c94..ad9b3b70f9a2 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,5 +1,5 @@
--- ./Agda.cabal.orig 2012-03-12 11:09:34.000000000 +0100
-+++ ./Agda.cabal 2012-10-03 22:53:16.000000000 +0200
++++ ./Agda.cabal 2013-02-05 04:15:30.000000000 +0100
@@ -71,13 +71,13 @@
if flag(use-locale)
build-depends: base >= 4.2 && < 4.6
@@ -18,6 +18,15 @@
containers >= 0.1 && < 0.5,
pretty >= 1.0 && < 1.2,
directory >= 1.0 && < 1.2,
+@@ -90,7 +90,7 @@
+ process >= 1.0.1.0 && < 1.2,
+ haskeline >= 0.6.3.2 && < 0.7,
+ xhtml == 3000.2.*,
+- hashable == 1.1.*,
++ hashable == 1.2.*,
+ hashtables == 1.0.*,
+ syb >= 0.1 && < 0.4
+ build-tools: happy >= 1.15 && < 2,
@@ -334,7 +334,7 @@
if flag(use-locale)
build-depends: base >= 4.2 && < 4.6
diff --git a/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs b/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
new file mode 100644
index 000000000000..ef6fa31298eb
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
@@ -0,0 +1,11 @@
+--- ./src/full/Agda/TypeChecking/Serialise.hs.orig 2012-03-12 11:09:33.000000000 +0100
++++ ./src/full/Agda/TypeChecking/Serialise.hs 2013-02-05 04:30:03.000000000 +0100
+@@ -119,7 +119,7 @@
+ -- | With direct access to the internals of 'TypeRep' this instance
+ -- could presumably be improved.
+ instance Hashable TypeRep' where
+- hash = hash . show . unTypeRep'
++ hashWithSalt n = hashWithSalt n . show . unTypeRep'
+
+ data St = St
+ { nodeE :: !(Array Int32 Node)