aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
commit25bf018f0fa446ca38508d35b6b3474e88d758d3 (patch)
tree45b457da59382af32e809be042d2a1a7cad9e952 /math/hs-Agda
parent1c8feb1a3fd41782660f5439357efe8a9519c625 (diff)
downloadports-25bf018f0fa446ca38508d35b6b3474e88d758d3.tar.gz
ports-25bf018f0fa446ca38508d35b6b3474e88d758d3.zip
Notes
Diffstat (limited to 'math/hs-Agda')
-rw-r--r--math/hs-Agda/Makefile26
-rw-r--r--math/hs-Agda/distinfo7
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal26
-rw-r--r--math/hs-Agda/files/pkg-deinstall.in9
-rw-r--r--math/hs-Agda/files/pkg-install.in9
5 files changed, 40 insertions, 37 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index c6ac1f1ad953..7568b0e790a6 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -2,36 +2,28 @@
# $FreeBSD$
PORTNAME= Agda
-PORTVERSION= 2.4.2.3
+PORTVERSION= 2.5.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Dependently typed functional programming language and proof assistant
-USE_CABAL= base-orphans>=0.3.1 boxes>=0.1.3 cpphs data-hash>=0.2.0.0 \
- edit-distance>=0.2.1.2 equivalence>=0.2.5 \
- geniplate-mirror>=0.6.0.6 hashable>=1.1.2.3 hashtables>=1.0 \
- haskell-src-exts>=1.16.0.1 mtl>=2.1.1 parallel QuickCheck>=2.8 \
- strict>=0.3.2 text>=0.11 transformers-compat>=0.3.3.2 \
- unordered-containers>=0.2 zlib>=0.4.0.1
+USE_CABAL= EdisonCore boxes data-hash edit-distance equivalence \
+ geniplate-mirror gitrev hashable hashtables ieee754 \
+ monadplus mtl murmur-hash parallel regex-tdfa strict \
+ text unordered-containers zlib
USE_ALEX= yes
USE_HAPPY= yes
+USE_CPPHS= yes
USES= iconv:translit
EXECUTABLE= agda-mode agda
-_PRIMITIVE= Primitive.agdai
-
-INSTALL_PORTDATA= ${INSTALL_DATA} \
- ${DISTDIR}/${DIST_SUBDIR}/${_PRIMITIVE}.${PORTVERSION} \
- ${STAGEDIR}${DATADIR}/lib/prim/Agda/${_PRIMITIVE}
-
FLAGS_ENABLE= cpphs
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-
-MASTER_SITES+= LOCAL/pgj:primitive
-DISTFILES+= ${_PRIMITIVE}.${PORTVERSION}:primitive
+SUB_FILES= pkg-install pkg-deinstall
+SUB_LIST= DATADIR=${DATADIR}
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/math/hs-Agda/distinfo b/math/hs-Agda/distinfo
index 35fced2f5b13..5d6083b21fd5 100644
--- a/math/hs-Agda/distinfo
+++ b/math/hs-Agda/distinfo
@@ -1,4 +1,3 @@
-SHA256 (cabal/Agda-2.4.2.3.tar.gz) = bc6def45e32498f51863d67acfbe048c039d630c6a36761ed27e99a5f68d7b27
-SIZE (cabal/Agda-2.4.2.3.tar.gz) = 990268
-SHA256 (cabal/Primitive.agdai.2.4.2.3) = a5b2353a50256f24c87f20b7892faabc99b9bad8f9b5cc68c24343707c1accf8
-SIZE (cabal/Primitive.agdai.2.4.2.3) = 2627
+TIMESTAMP = 1500999185
+SHA256 (cabal/Agda-2.5.2.tar.gz) = d812cec3bf7f03c4b27248572475c7e060154102771a8434cc11ba89f5691439
+SIZE (cabal/Agda-2.5.2.tar.gz) = 1240885
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index f6be142036d6..a7e0d60526de 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,17 +1,11 @@
---- Agda.cabal.orig 2015-05-25 16:22:38 UTC
+--- Agda.cabal.orig 2016-12-22 12:18:52 UTC
+++ Agda.cabal
-@@ -85,12 +85,12 @@ library
- -- even though it builds with older GHCs.
- , bytestring >= 0.9.2.1 && < 0.11
- , containers >= 0.4.2.1 && < 0.6
-- , data-hash == 0.2.0.0
-+ , data-hash == 0.2.0.*
- , deepseq >= 1.3.0.0 && < 1.5
- , edit-distance >= 0.2.1.2 && < 0.3
- , equivalence >= 0.2.5 && < 0.4
- , filepath >= 1.3.0.0 && < 1.5
-- , geniplate-mirror >= 0.6.0.6 && < 0.7
-+ , geniplate-mirror >= 0.6.0.6 && < 0.8
- -- hashable 1.2.0.10 makes library-test 10x slower. The issue was
- -- fixed in hashable 1.2.1.0.
- -- https://github.com/tibbe/hashable/issues/57.
+@@ -160,7 +160,7 @@ library
+ -- some cases.
+ , hashtables >= 1.0.1.8 && < 1.2 || >= 1.2.0.2 && < 1.3
+ , haskeline >= 0.7.1.3 && < 0.8
+- , ieee754 >= 0.7.8 && < 0.8
++ , ieee754 >= 0.7.8 && < 0.9
+ , monadplus >= 1.4 && < 1.5
+ -- mtl-2.1 contains a severe bug.
+ --
diff --git a/math/hs-Agda/files/pkg-deinstall.in b/math/hs-Agda/files/pkg-deinstall.in
new file mode 100644
index 000000000000..2b2d2656ddf5
--- /dev/null
+++ b/math/hs-Agda/files/pkg-deinstall.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+PKG_DATADIR=%%DATADIR%%
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ for ai in $(find ${PKG_DATADIR}/lib/prim/Agda -name '*.agdai'); do
+ rm $ai
+ done
+fi
diff --git a/math/hs-Agda/files/pkg-install.in b/math/hs-Agda/files/pkg-install.in
new file mode 100644
index 000000000000..7e5bff441da7
--- /dev/null
+++ b/math/hs-Agda/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+PKG_DATADIR=%%DATADIR%%
+
+if [ "$2" = "POST-INSTALL" ]; then
+ for a in $(find ${PKG_DATADIR}/lib/prim/Agda -name '*.agda'); do
+ ${PKG_PREFIX}/bin/agda $a
+ done
+fi