aboutsummaryrefslogtreecommitdiff
path: root/math/hs-erf
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-04 06:41:09 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-04 06:41:09 +0000
commitd8d1f7445de5f1126d5f564b88b423e67d2b13c5 (patch)
treef70f2b814d7da7193fdbdface8cdd3a0d6854332 /math/hs-erf
parent0750ae01b02337ef482fbe234e0517cb798103af (diff)
downloadports-d8d1f7445de5f1126d5f564b88b423e67d2b13c5.tar.gz
ports-d8d1f7445de5f1126d5f564b88b423e67d2b13c5.zip
Notes
Diffstat (limited to 'math/hs-erf')
-rw-r--r--math/hs-erf/Makefile75
-rw-r--r--math/hs-erf/distinfo3
-rw-r--r--math/hs-erf/pkg-descr4
-rw-r--r--math/hs-erf/pkg-plist14
4 files changed, 96 insertions, 0 deletions
diff --git a/math/hs-erf/Makefile b/math/hs-erf/Makefile
new file mode 100644
index 000000000000..30817074a6a6
--- /dev/null
+++ b/math/hs-erf/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: hs-erf
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= erf
+PORTVERSION= 1.0.0.0
+CATEGORIES= math haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= The error function, erf, and friends for Haskell
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.10.4
+ERF_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+ERF_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ ERF_VERSION=${ERF_VERSION} \
+ ERF_LIBDIR_REL=${ERF_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${ERF_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/math/hs-erf/distinfo b/math/hs-erf/distinfo
new file mode 100644
index 000000000000..46445986af52
--- /dev/null
+++ b/math/hs-erf/distinfo
@@ -0,0 +1,3 @@
+MD5 (erf-1.0.0.0.tar.gz) = 1bdb56838565abfaa7d7ab6e2870ddaa
+SHA256 (erf-1.0.0.0.tar.gz) = d6e27965a5961e135b68c39f38137727ccd01d8c1d588c67fb996167354b6b7e
+SIZE (erf-1.0.0.0.tar.gz) = 974
diff --git a/math/hs-erf/pkg-descr b/math/hs-erf/pkg-descr
new file mode 100644
index 000000000000..b304599533d1
--- /dev/null
+++ b/math/hs-erf/pkg-descr
@@ -0,0 +1,4 @@
+A type class for the error function, erf, and related functions for Haskell.
+Instances for Float and Double.
+
+WWW: http://hackage.haskell.org/package/erf
diff --git a/math/hs-erf/pkg-plist b/math/hs-erf/pkg-plist
new file mode 100644
index 000000000000..cfae21a69489
--- /dev/null
+++ b/math/hs-erf/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Number/Erf.hi
+%%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSerf-%%ERF_VERSION%%.o
+%%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSerf-%%ERF_VERSION%%.a
+%%ERF_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Number
+@dirrm %%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%ERF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%ERF_LIBDIR_REL%%
+@exec /bin/sh %D/%%ERF_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister erf
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old