aboutsummaryrefslogtreecommitdiff
path: root/math/ipopt/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-29 07:48:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-29 07:48:18 +0000
commit3812f2a836ed2d34d657a022a534420ea009fc18 (patch)
tree99e5a472d9d52bf887fb6eea2d7269f646dcd5e5 /math/ipopt/Makefile
parent01a3c0f5078a18ad8232ef31f8e756f6c76134aa (diff)
Notes
Diffstat (limited to 'math/ipopt/Makefile')
-rw-r--r--math/ipopt/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/math/ipopt/Makefile b/math/ipopt/Makefile
index 1dd77117fe96..7c2dcef562a6 100644
--- a/math/ipopt/Makefile
+++ b/math/ipopt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Ipopt
-DISTVERSION= 3.12.12
-PORTREVISION= 2
+DISTVERSION= 3.12.13
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/Ipopt/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/OLD/:metis \
@@ -29,11 +28,16 @@ CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
--with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib"
CXXFLAGS+= -ffast-math
+DEBUG_CXXFLAGS= -fomit-frame-pointer
-OPTIONS_DEFINE= DEBUG DOCS
-PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/coin/doc/${PORTNAME}
-DEBUG_CXXFLAGS= -fomit-frame-pointer
+OPTIONS_DEFINE= DEBUG DOCS
+
+DOCS_ALL_TARGET= all doxydoc
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+
+PORTDOCS= *
post-extract:
@(${ECHO} "Extracting Metis and Mumps ThirdParty libraries ..." )
@@ -46,16 +50,7 @@ pre-patch:
@(cd ${WRKSRC}/ThirdParty/Mumps && ${PATCH} -p0 < mumps.patch && ${PATCH} -p0 < mumps_mpi.patch )
@(${MV} ${WRKSRC}/ThirdParty/Mumps/MUMPS/libseq/mpi.h ${WRKSRC}/ThirdParty/Mumps/MUMPS/libseq/mumps_mpi.h);
-pre-build: # workaround: configure fails to find the 'rand' function on 12, need to investigate. This patch unbreaks the build.
+pre-build: # workaround: configure fails to find the 'rand' function, need to investigate. This patch unbreaks the build.
@${REINPLACE_CMD} -e 's|.*HAVE_RAND.*|#define HAVE_RAND 1|' ${WRKSRC}/Ipopt/src/Common/config.h
-post-install-DOCS-off:
- @${RM} -r ${STAGEDIR}${PREFIX}/share/coin
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Ipopt/doc/documentation.pdf ${STAGEDIR}${DOCSDIR}
- ${MV} ${STAGEDIR}${PREFIX}/share/coin/doc ${STAGEDIR}${DOCSDIR}
- @${RM} -r ${STAGEDIR}${PREFIX}/share/coin
-
.include <bsd.port.mk>