aboutsummaryrefslogtreecommitdiff
path: root/math/ised
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-09-08 02:56:39 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-09-08 02:56:39 +0000
commit28955f8a3ad5b4db38ce395e7177713fcedf95b0 (patch)
tree5c4d410b5c22259108dcc158a09dffb336c0ca1c /math/ised
parentffc2dd2fe1aed3feb85db881764171ef84744e42 (diff)
downloadports-28955f8a3ad5b4db38ce395e7177713fcedf95b0.tar.gz
ports-28955f8a3ad5b4db38ce395e7177713fcedf95b0.zip
Notes
Diffstat (limited to 'math/ised')
-rw-r--r--math/ised/Makefile2
-rw-r--r--math/ised/distinfo4
-rw-r--r--math/ised/files/patch-src_base.h21
3 files changed, 24 insertions, 3 deletions
diff --git a/math/ised/Makefile b/math/ised/Makefile
index 98f092eefcc0..f9fe208f55cc 100644
--- a/math/ised/Makefile
+++ b/math/ised/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ised
-PORTVERSION= 2.3.2
+PORTVERSION= 2.4.0
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}
diff --git a/math/ised/distinfo b/math/ised/distinfo
index d51379e8465f..12b8939d1fa2 100644
--- a/math/ised/distinfo
+++ b/math/ised/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ised-2.3.2.tar.bz2) = 0e501fcf76972c1ff7eceee6cbc3bdd93c530fc83b712908b3749749b6599ebb
-SIZE (ised-2.3.2.tar.bz2) = 120015
+SHA256 (ised-2.4.0.tar.bz2) = df131beae14de1ed75b34162d2a952ee4aa4f9651b625f63d908a274ce80d67f
+SIZE (ised-2.4.0.tar.bz2) = 122560
diff --git a/math/ised/files/patch-src_base.h b/math/ised/files/patch-src_base.h
new file mode 100644
index 000000000000..42e34582ecde
--- /dev/null
+++ b/math/ised/files/patch-src_base.h
@@ -0,0 +1,21 @@
+--- src/base.h.orig 2012-09-07 22:48:50.000000000 -0400
++++ src/base.h 2012-09-07 22:50:59.000000000 -0400
+@@ -14,6 +14,7 @@
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ **/
++#include <stdint.h>
+
+ #ifndef H_BASE
+ #define H_BASE
+@@ -182,10 +183,6 @@ typedef long long itype;
+ #endif //__x86_64__
+ #endif //TRAPOVERFLOWS
+
+-#ifndef uint64_t
+-typedef unsigned long long uint64_t; //might not be right but close enough
+-#endif
+-
+ //if we are on x86_64, we can do modular multiplication without overflow
+ #ifdef __x86_64__
+ #if IVALUE==ILONG