aboutsummaryrefslogtreecommitdiff
path: root/math/jakarta-commons-math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-14 07:51:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-14 07:51:04 +0000
commit0836164848518efc027b74ea150ac2191d674056 (patch)
treea06e05d39767d1c1ff543216a288e003897edd36 /math/jakarta-commons-math
parentfa576e02c7b1b77ad74e220371af22b8454280db (diff)
downloadports-0836164848518efc027b74ea150ac2191d674056.tar.gz
ports-0836164848518efc027b74ea150ac2191d674056.zip
Notes
Diffstat (limited to 'math/jakarta-commons-math')
-rw-r--r--math/jakarta-commons-math/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index a263cef9e981..de0d232d5da5 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -7,6 +7,7 @@
PORTNAME= commons-math
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= math java
MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}
MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
@@ -17,6 +18,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Java library of self-contained mathematics and statistics components
BUILD_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVAJARDIR}/junit.jar:${PORTSDIR}/java/junit \
${JAVAJARDIR}/commons-discovery.jar:${PORTSDIR}/java/jakarta-commons-discovery
RUN_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
${JAVAJARDIR}/commons-discovery.jar:${PORTSDIR}/java/jakarta-commons-discovery
@@ -56,6 +58,12 @@ JDK_API!= (${FIND} -s ${LOCALBASE}/share/doc/jdk1.? -maxdepth 1 -name api -type
MAKE_ARGS+= -Djdk.api=${JDK_API}
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's#4.4##g' \
+ -e 's#junit-#junit#g' \
+ -e 's#/usr/share/junit#${JAVAJARDIR}#g' \
+ ${WRKSRC}/build.xml
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
@${MKDIR} ${JAVAJARDIR}