aboutsummaryrefslogtreecommitdiff
path: root/math/jakarta-commons-math
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-01-31 01:48:04 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-01-31 01:48:04 +0000
commite9c581baa8ef8764c14223f7722d96f05c1fa17d (patch)
treecb509e7baff3ca362dc077feb443791a41348d55 /math/jakarta-commons-math
parent05610f3814c4eea0cb25b8cc51beed9107aaad21 (diff)
downloadports-e9c581baa8ef8764c14223f7722d96f05c1fa17d.tar.gz
ports-e9c581baa8ef8764c14223f7722d96f05c1fa17d.zip
Notes
Diffstat (limited to 'math/jakarta-commons-math')
-rw-r--r--math/jakarta-commons-math/Makefile74
-rw-r--r--math/jakarta-commons-math/distinfo2
-rw-r--r--math/jakarta-commons-math/files/patch-build.xml14
-rw-r--r--math/jakarta-commons-math/pkg-descr5
4 files changed, 95 insertions, 0 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
new file mode 100644
index 000000000000..ee6b2aad03bd
--- /dev/null
+++ b/math/jakarta-commons-math/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: Jakarta Commons Math
+# Date created: January 30th, 2004
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-math
+PORTVERSION= 1.0
+CATEGORIES= math java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/source
+PKGNAMEPREFIX= jakarta-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Java library of self-contained mathematics and statistics components
+
+BUILD_DEPENDS= ${JAR_DEPENDS}
+RUN_DEPENDS= ${JAR_DEPENDS}
+
+JAR_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVAJARDIR}/commons-discovery.jar:${PORTSDIR}/java/jakarta-commons-discovery
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+USE_ANT= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+ALL_TARGET= jar
+MAKE_ARGS= -Dlibdir=${JAVAJARDIR} -Dnoget=yes
+COMMONS_LOGGING_API= ${LOCALBASE}/share/doc/commons-logging/api
+.if exists(${COMMONS_LOGGING_API})
+MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_LOGGING_API}
+.endif
+COMMONS_DISCOVERY_API= ${LOCALBASE}/share/doc/commons-discovery/api
+.if exists(${COMMONS_DISCOVERY_API})
+MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_DISCOVERY_API}
+.endif
+
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+OTHERDOCS= LICENSE.txt NOTICE.txt
+PORTDOCS= api ${OTHERDOCS}
+.endif
+JARFILE= ${PORTNAME}-${PORTVERSION}.jar
+DESTJARFILE= ${PORTNAME}.jar
+PLIST_FILES+= %%JAVAJARDIR%%/${DESTJARFILE}
+
+.include <bsd.port.pre.mk>
+
+JDK_API!= (${FIND} -s ${LOCALBASE}/share/doc/jdk1.? -maxdepth 1 -name api -type d 2>/dev/null || ${TRUE}) | ${TAIL} -n 1
+.if ${JDK_API} != ""
+MAKE_ARGS+= -Djdk.api=${JDK_API}
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/target/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_MSG} " [ DONE ]"
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/dist/docs \
+ && ${FIND} -s api -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} -s api -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/jakarta-commons-math/distinfo b/math/jakarta-commons-math/distinfo
new file mode 100644
index 000000000000..114cafe36952
--- /dev/null
+++ b/math/jakarta-commons-math/distinfo
@@ -0,0 +1,2 @@
+MD5 (commons-math-1.0-src.tar.gz) = 0b5d92acc9259f45676bd64b4894b5ad
+SIZE (commons-math-1.0-src.tar.gz) = 208541
diff --git a/math/jakarta-commons-math/files/patch-build.xml b/math/jakarta-commons-math/files/patch-build.xml
new file mode 100644
index 000000000000..b6afe9d04480
--- /dev/null
+++ b/math/jakarta-commons-math/files/patch-build.xml
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- build.xml.orig Mon Jan 31 02:07:27 2005
++++ build.xml Mon Jan 31 02:28:01 2005
+@@ -145,6 +145,9 @@
+ <property name="title" value="Math 1.0 API">
+ </property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.math.*">
++ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
++ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
++ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
+ <classpath>
+ <path refid="build.classpath">
+ </path>
diff --git a/math/jakarta-commons-math/pkg-descr b/math/jakarta-commons-math/pkg-descr
new file mode 100644
index 000000000000..73b50f45eba5
--- /dev/null
+++ b/math/jakarta-commons-math/pkg-descr
@@ -0,0 +1,5 @@
+Commons Math is a library of lightweight, self-contained mathematics and
+statistics components addressing the most common problems not available in the
+Java programming language or Commons Lang.
+
+WWW: http://jakarta.apache.org/commons/math/