aboutsummaryrefslogtreecommitdiff
path: root/math/jakarta-commons-math
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-06-20 09:23:05 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-06-20 09:23:05 +0000
commitf599e52798703f5dc7e518c66586aaac5af516c8 (patch)
tree655613b0e97a8bb67132ddf983c502c4c4f4efed /math/jakarta-commons-math
parentd873b22c1accd4166c6eaf65a78446398a9e14b5 (diff)
downloadports-f599e52798703f5dc7e518c66586aaac5af516c8.tar.gz
ports-f599e52798703f5dc7e518c66586aaac5af516c8.zip
Notes
Diffstat (limited to 'math/jakarta-commons-math')
-rw-r--r--math/jakarta-commons-math/Makefile15
-rw-r--r--math/jakarta-commons-math/distinfo6
-rw-r--r--math/jakarta-commons-math/files/patch-build.xml10
3 files changed, 15 insertions, 16 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index ee6b2aad03bd..c70eb8379776 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= commons-math
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= math java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/source
@@ -16,20 +16,19 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= hq@FreeBSD.org
COMMENT= Java library of self-contained mathematics and statistics components
-BUILD_DEPENDS= ${JAR_DEPENDS}
-RUN_DEPENDS= ${JAR_DEPENDS}
-
-JAR_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+BUILD_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVAJARDIR}/commons-discovery.jar:${PORTSDIR}/java/jakarta-commons-discovery
+RUN_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
${JAVAJARDIR}/commons-discovery.jar:${PORTSDIR}/java/jakarta-commons-discovery
USE_JAVA= yes
JAVA_VERSION= 1.2+
USE_ANT= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
ALL_TARGET= jar
-MAKE_ARGS= -Dlibdir=${JAVAJARDIR} -Dnoget=yes
+MAKE_ARGS= -Dlibdir=${WRKDIR} -Dnoget=true \
+ -Dcommons-logging.jar="file://${JAVAJARDIR}/commons-logging.jar" \
+ -Dcommons-discovery.jar="file://${JAVAJARDIR}/commons-discovery.jar"
COMMONS_LOGGING_API= ${LOCALBASE}/share/doc/commons-logging/api
.if exists(${COMMONS_LOGGING_API})
MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_LOGGING_API}
diff --git a/math/jakarta-commons-math/distinfo b/math/jakarta-commons-math/distinfo
index be74d7c3d5fb..fdea2674aa7b 100644
--- a/math/jakarta-commons-math/distinfo
+++ b/math/jakarta-commons-math/distinfo
@@ -1,3 +1,3 @@
-MD5 (commons-math-1.0-src.tar.gz) = 0b5d92acc9259f45676bd64b4894b5ad
-SHA256 (commons-math-1.0-src.tar.gz) = 0be07e582a11599b367576657dd0f5da39368ea25b89bb31b9ccdc3826af0f8d
-SIZE (commons-math-1.0-src.tar.gz) = 208541
+MD5 (commons-math-1.1-src.tar.gz) = 88561caad1800114f28799d0050d0673
+SHA256 (commons-math-1.1-src.tar.gz) = f6272bf57bc5d505b7132e0a0a91ff48cc39070d05cae0e2b8f8f2b62b11939c
+SIZE (commons-math-1.1-src.tar.gz) = 385679
diff --git a/math/jakarta-commons-math/files/patch-build.xml b/math/jakarta-commons-math/files/patch-build.xml
index b6afe9d04480..5327f059f3c3 100644
--- a/math/jakarta-commons-math/files/patch-build.xml
+++ b/math/jakarta-commons-math/files/patch-build.xml
@@ -1,11 +1,11 @@
$FreeBSD$
---- build.xml.orig Mon Jan 31 02:07:27 2005
-+++ build.xml Mon Jan 31 02:28:01 2005
-@@ -145,6 +145,9 @@
- <property name="title" value="Math 1.0 API">
+--- build.xml.orig Sun Dec 18 20:37:46 2005
++++ build.xml Tue Jun 20 11:16:15 2006
+@@ -179,6 +179,9 @@
+ <property name="title" value="Math 1.1 API">
</property>
- <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.math.*">
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java" packagenames="org.apache.commons.math.*">
+ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
+ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>