aboutsummaryrefslogtreecommitdiff
path: root/math/jakarta-commons-math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-10 06:54:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-10 06:54:15 +0000
commit4c602865c2937d998c2ebe77b0a20f9458c5dfc8 (patch)
tree1c0f23cc3380060c76e6bfc4e7eb1192d4f08457 /math/jakarta-commons-math
parent6432370980520a4903f1ba3971ce3c4392aedc9d (diff)
Notes
Diffstat (limited to 'math/jakarta-commons-math')
-rw-r--r--math/jakarta-commons-math/Makefile7
-rw-r--r--math/jakarta-commons-math/distinfo4
-rw-r--r--math/jakarta-commons-math/files/patch-build.xml11
3 files changed, 16 insertions, 6 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index 09ed226ba8c8..b0f457875bac 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= commons-math
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= math java
MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}
MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
PKGNAMEPREFIX= jakarta-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= Java library of self-contained mathematics and statistics components
BUILD_DEPENDS= ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
@@ -58,8 +58,7 @@ MAKE_ARGS+= -Djdk.api=${JDK_API}
.endif
post-patch:
- ${REINPLACE_CMD} -e 's#4.4##g' \
- -e 's#junit-#junit#g' \
+ ${REINPLACE_CMD} -e 's#junit-#junit#g' \
-e 's#/usr/share/junit#${JAVAJARDIR}#g' \
${WRKSRC}/build.xml
diff --git a/math/jakarta-commons-math/distinfo b/math/jakarta-commons-math/distinfo
index e9595bf54b63..df3fa218f1cd 100644
--- a/math/jakarta-commons-math/distinfo
+++ b/math/jakarta-commons-math/distinfo
@@ -1,2 +1,2 @@
-SHA256 (commons-math-2.1-src.tar.gz) = f31e098afa916a7f17bd8d8a15163d761ddb54c28d8d64f7f57ce86167f2c48b
-SIZE (commons-math-2.1-src.tar.gz) = 1099423
+SHA256 (commons-math-2.2-src.tar.gz) = a7624c3a3e2581d9905f1f1090c78c25448678bddcec2a48a4dc8a80f16ed1b8
+SIZE (commons-math-2.2-src.tar.gz) = 1321209
diff --git a/math/jakarta-commons-math/files/patch-build.xml b/math/jakarta-commons-math/files/patch-build.xml
new file mode 100644
index 000000000000..979022a68fd9
--- /dev/null
+++ b/math/jakarta-commons-math/files/patch-build.xml
@@ -0,0 +1,11 @@
+--- build.xml.orig 2012-03-26 01:38:37.000000000 +0600
++++ build.xml 2012-03-26 01:38:56.000000000 +0600
+@@ -36,7 +36,7 @@
+ <!-- Junit -->
+ <property name="junit.version" value="4.8.2"/>
+ <property name="junit.home" value="/usr/share/junit"/>
+- <property name="junit.jar" value="${junit.home}/junit-${junit.version}.jar"/>
++ <property name="junit.jar" value="${junit.home}/junit.jar"/>
+
+
+ <!-- ========== Component Declarations ==================================== -->