aboutsummaryrefslogtreecommitdiff
path: root/math/jama
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 05:40:15 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 05:40:15 +0000
commit4828c13abab0c38c714c74bc4c1851104f5f504e (patch)
treebeee8de6ceff03bef73d9df46e23bf2f9674e206 /math/jama
parent9ca64fc26a4104b7a3afa2971a8faad2e3811d0c (diff)
downloadports-4828c13abab0c38c714c74bc4c1851104f5f504e.tar.gz
ports-4828c13abab0c38c714c74bc4c1851104f5f504e.zip
Add jama 1.2.1, Java-like Matrix C++ Templates.
PR: 52850 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=82179
Diffstat (limited to 'math/jama')
-rw-r--r--math/jama/Makefile39
-rw-r--r--math/jama/distinfo2
-rw-r--r--math/jama/pkg-descr11
-rw-r--r--math/jama/pkg-plist38
4 files changed, 90 insertions, 0 deletions
diff --git a/math/jama/Makefile b/math/jama/Makefile
new file mode 100644
index 000000000000..b84e3aac410e
--- /dev/null
+++ b/math/jama/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: jama
+# Date created: May 15, 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jama
+PORTVERSION= 1.2.1
+CATEGORIES= math devel
+MASTER_SITES= http://math.nist.gov/tnt/
+DISTNAME= ${PORTNAME}121src
+.ifndef NOPORTDOCS
+DISTFILES=${DISTNAME}${EXTRACT_SUFX} jama102doc.zip
+.endif
+DIST_SUBDIR= tnt
+EXTRACT_ONLY=
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Java-like Matrix C++ Templates
+
+BUILD_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
+RUN_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/tnt
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ -d ${PREFIX}/include/tnt
+.ifndef NOPORTDOCS
+ ${MKDIR} ${PREFIX}/share/doc
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/jama102doc \
+ -d ${PREFIX}/share/doc
+ ${MV} ${PREFIX}/share/doc/doxygen ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/jama/distinfo b/math/jama/distinfo
new file mode 100644
index 000000000000..5163756db518
--- /dev/null
+++ b/math/jama/distinfo
@@ -0,0 +1,2 @@
+MD5 (tnt/jama121src.zip) = 1360a4a9557d3e0a660a9c6bbbde3cbf
+MD5 (tnt/jama102doc.zip) = ddb94fdb217fbda0275c60872c08b545
diff --git a/math/jama/pkg-descr b/math/jama/pkg-descr
new file mode 100644
index 000000000000..26f1dcbc7b84
--- /dev/null
+++ b/math/jama/pkg-descr
@@ -0,0 +1,11 @@
+JAMA/C++ Linear Algebra Package (v. 1.2.1)
+
+JAMA/C++: a translation of the Java Matrix Library, developed by the
+Mathworks and NIST, into C++
+* classical matrix linear algebra
+* QR
+* SVD
+* Cholesky
+* Eigenvalue solver
+
+Based on NIST's Template Numerical Toolkit.
diff --git a/math/jama/pkg-plist b/math/jama/pkg-plist
new file mode 100644
index 000000000000..53d4220a104b
--- /dev/null
+++ b/math/jama/pkg-plist
@@ -0,0 +1,38 @@
+include/tnt/jama_cholesky.h
+include/tnt/jama_eig.h
+include/tnt/jama_lu.h
+include/tnt/jama_qr.h
+include/tnt/jama_svd.h
+%%PORTDOCS%%share/doc/jama/html/annotated.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__Cholesky-members.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__Cholesky.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__Eigenvalue-members.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__Eigenvalue.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__LU-members.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__LU.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__QR-members.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__QR.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__SVD-members.html
+%%PORTDOCS%%share/doc/jama/html/class_JAMA__SVD.html
+%%PORTDOCS%%share/doc/jama/html/doxygen.css
+%%PORTDOCS%%share/doc/jama/html/doxygen.gif
+%%PORTDOCS%%share/doc/jama/html/files.html
+%%PORTDOCS%%share/doc/jama/html/functions.html
+%%PORTDOCS%%share/doc/jama/html/index.html
+%%PORTDOCS%%share/doc/jama/html/jama_cholesky_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_cholesky_h.html
+%%PORTDOCS%%share/doc/jama/html/jama_cholesky_old_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_cholesky_old_h.html
+%%PORTDOCS%%share/doc/jama/html/jama_eig_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_eig_h.html
+%%PORTDOCS%%share/doc/jama/html/jama_lu_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_lu_h.html
+%%PORTDOCS%%share/doc/jama/html/jama_qr_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_qr_h.html
+%%PORTDOCS%%share/doc/jama/html/jama_svd_h-source.html
+%%PORTDOCS%%share/doc/jama/html/jama_svd_h.html
+%%PORTDOCS%%share/doc/jama/html/namespace_JAMA.html
+%%PORTDOCS%%share/doc/jama/html/namespace_TNT.html
+%%PORTDOCS%%share/doc/jama/html/namespaces.html
+%%PORTDOCS%%@dirrm share/doc/jama/html/
+%%PORTDOCS%%@dirrm share/doc/jama/