aboutsummaryrefslogtreecommitdiff
path: root/math/jlatexmath/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-05-01 14:28:55 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-05-01 14:28:55 +0000
commite719a20555b0a92af25957e6f4d3e0f06ee44b6f (patch)
tree01461e7a7e0cbd151e62354e08b9acbdb8321122 /math/jlatexmath/Makefile
parente10a0828f7b71f41a76c3dc71fc9bfa3e4c127de (diff)
downloadports-e719a20555b0a92af25957e6f4d3e0f06ee44b6f.tar.gz
ports-e719a20555b0a92af25957e6f4d3e0f06ee44b6f.zip
Notes
Diffstat (limited to 'math/jlatexmath/Makefile')
-rw-r--r--math/jlatexmath/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index aaedc55d96fd..e510f365bfca 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= jlatexmath
-PORTVERSION= 0.9.7
+PORTVERSION= 1.0.3
CATEGORIES= math java
MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/
DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= makc@FreeBSD.org
COMMENT= Java API to display mathematical formulas written in LaTeX
LICENSE= GPLv2
@@ -26,23 +26,31 @@ OPTIONS_SUB= yes
FOP_DESC= textproc/fop plugin (required for math/scilab)
FOP_BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
- ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
+ ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons
+FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS}
${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
${JAVALIBDIR}/commons-io.jar:${PORTSDIR}/devel/jakarta-commons-io \
${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons
-FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS}
FOP_ALL_TARGET= fop
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e 's|/usr/share/java/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/fop.properties
${REINPLACE_CMD} -e 's|/usr/share/java/batik.jar|${LOCALBASE}/share/java/batik/batik.jar|' ${WRKSRC}/fop.properties
${REINPLACE_CMD} -e 's|/usr/share/java/|${JAVALIBDIR}/|' ${WRKSRC}/fop.properties
+pre-install:
+# Remove empty directory
+ -${RMDIR} ${WRKSRC}/examples/Macros/bin
+
do-install:
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
+.if ${PORT_OPTIONS:MFOP}
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath-fop.jar
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>