aboutsummaryrefslogtreecommitdiff
path: root/math/jlatexmath/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:24:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:24:44 +0000
commit61ccb63c4db1f6a0c4ce32e0762aed65d7ad6bc5 (patch)
tree2c73aec1d55e1ad44169d0a7a581dad37991ada6 /math/jlatexmath/Makefile
parent3ab2c72352d39235abc83d06940ed8f427f39e8a (diff)
downloadports-61ccb63c4db1f6a0c4ce32e0762aed65d7ad6bc5.tar.gz
ports-61ccb63c4db1f6a0c4ce32e0762aed65d7ad6bc5.zip
Notes
Diffstat (limited to 'math/jlatexmath/Makefile')
-rw-r--r--math/jlatexmath/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
new file mode 100644
index 000000000000..8fdc662eb723
--- /dev/null
+++ b/math/jlatexmath/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jlatexmath
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jlatexmath
+PORTVERSION= 0.8.9
+CATEGORIES= math java
+MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/ \
+ http://www.predatorlabs.net/dl/
+DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Java API to display mathematical formulas written in LaTeX
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_BUILD= yes
+JAVA_RUN= yes
+USE_ANT= yes
+
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-0.8.9.jar ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>