aboutsummaryrefslogtreecommitdiff
path: root/math/jlatexmath
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-05-01 14:28:55 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-05-01 14:28:55 +0000
commite719a20555b0a92af25957e6f4d3e0f06ee44b6f (patch)
tree01461e7a7e0cbd151e62354e08b9acbdb8321122 /math/jlatexmath
parente10a0828f7b71f41a76c3dc71fc9bfa3e4c127de (diff)
downloadports-e719a20555b0a92af25957e6f4d3e0f06ee44b6f.tar.gz
ports-e719a20555b0a92af25957e6f4d3e0f06ee44b6f.zip
Notes
Diffstat (limited to 'math/jlatexmath')
-rw-r--r--math/jlatexmath/Makefile18
-rw-r--r--math/jlatexmath/distinfo4
-rw-r--r--math/jlatexmath/pkg-plist21
3 files changed, 31 insertions, 12 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index aaedc55d96fd..e510f365bfca 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= jlatexmath
-PORTVERSION= 0.9.7
+PORTVERSION= 1.0.3
CATEGORIES= math java
MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/
DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= makc@FreeBSD.org
COMMENT= Java API to display mathematical formulas written in LaTeX
LICENSE= GPLv2
@@ -26,23 +26,31 @@ OPTIONS_SUB= yes
FOP_DESC= textproc/fop plugin (required for math/scilab)
FOP_BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
- ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
+ ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons
+FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS}
${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
${JAVALIBDIR}/commons-io.jar:${PORTSDIR}/devel/jakarta-commons-io \
${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons
-FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS}
FOP_ALL_TARGET= fop
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e 's|/usr/share/java/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/fop.properties
${REINPLACE_CMD} -e 's|/usr/share/java/batik.jar|${LOCALBASE}/share/java/batik/batik.jar|' ${WRKSRC}/fop.properties
${REINPLACE_CMD} -e 's|/usr/share/java/|${JAVALIBDIR}/|' ${WRKSRC}/fop.properties
+pre-install:
+# Remove empty directory
+ -${RMDIR} ${WRKSRC}/examples/Macros/bin
+
do-install:
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
+.if ${PORT_OPTIONS:MFOP}
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath-fop.jar
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/math/jlatexmath/distinfo b/math/jlatexmath/distinfo
index 170521076b84..57a3fe0c3f07 100644
--- a/math/jlatexmath/distinfo
+++ b/math/jlatexmath/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jlatexmath-src-all-0.9.7.zip) = f27772c54e438034ea5cd70fc53b5cef8775578b50b41597bf23e2960c98d4f6
-SIZE (jlatexmath-src-all-0.9.7.zip) = 1177126
+SHA256 (jlatexmath-src-all-1.0.3.zip) = 58b14f0f30250b7cd3d1e5cfae20a8d5f999c01e9ff5e03508cbdb8f922dd7fd
+SIZE (jlatexmath-src-all-1.0.3.zip) = 1203123
diff --git a/math/jlatexmath/pkg-plist b/math/jlatexmath/pkg-plist
index 759d60eb2423..cf128631543d 100644
--- a/math/jlatexmath/pkg-plist
+++ b/math/jlatexmath/pkg-plist
@@ -4,6 +4,8 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example4.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example5.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example6.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example7.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/ExampleSwing2.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Main.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/lion.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Convert.java
@@ -16,15 +18,24 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/build.xml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/lion.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/GIWS/LaTeXGenerator.giws.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/GIWS/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/GIWS/build.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/GIWS/src/org/scilab/forge/example/giws/LaTeXGenerator.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/FooPackage.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/Main.java
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/Package_Foo.xml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/README
+%%FOP%%%%JAVAJARDIR%%/jlatexmath-fop.jar
%%JAVAJARDIR%%/jlatexmath.jar
-%%FOP%%share/java/classes/jlatexmath-fop.jar
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Macros/bin
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Macros
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Export
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Basic
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Export
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src/org/scilab/forge/example/giws
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src/org/scilab/forge/example
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src/org/scilab/forge
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src/org/scilab
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src/org
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS/src
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/GIWS
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Macros
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/Macros/bin