aboutsummaryrefslogtreecommitdiff
path: root/math/jlatexmath
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-04-25 11:51:05 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-04-25 11:51:05 +0000
commitafc9c7c8a3820f1b0838c882ba8f035f1ac9fc15 (patch)
tree699a6f78848590ec1497ec4992226a87826ec283 /math/jlatexmath
parent40beeb3a0a3448e9801b546b198b70ad172bce4e (diff)
downloadports-afc9c7c8a3820f1b0838c882ba8f035f1ac9fc15.tar.gz
ports-afc9c7c8a3820f1b0838c882ba8f035f1ac9fc15.zip
Notes
Diffstat (limited to 'math/jlatexmath')
-rw-r--r--math/jlatexmath/Makefile46
1 files changed, 16 insertions, 30 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index 9af3afefa843..aaedc55d96fd 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -4,8 +4,7 @@
PORTNAME= jlatexmath
PORTVERSION= 0.9.7
CATEGORIES= math java
-MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/ \
- http://www.predatorlabs.net/dl/
+MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/
DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -15,7 +14,6 @@ LICENSE= GPLv2
USES= zip
USE_JAVA= yes
-JAVA_VERSION= 1.6+
JAVA_BUILD= yes
JAVA_RUN= yes
USE_ANT= yes
@@ -24,28 +22,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= FOP EXAMPLES
OPTIONS_DEFAULT= FOP
-FOP_DESC= textproc/fop plugin (required for math/scilab)
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFOP}
-BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
- ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
- ${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
- ${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
- ${JAVALIBDIR}/commons-io.jar:${PORTSDIR}/devel/jakarta-commons-io \
- ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
- ${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons
-
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-ALL_TARGET+= fop
-
-PLIST_SUB+= FOP=""
-.else
-PLIST_SUB+= FOP="@comment "
-.endif
+OPTIONS_SUB= yes
+
+FOP_DESC= textproc/fop plugin (required for math/scilab)
+FOP_BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
+ ${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
+ ${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
+ ${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
+ ${JAVALIBDIR}/commons-io.jar:${PORTSDIR}/devel/jakarta-commons-io \
+ ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVALIBDIR}/xml-apis-ext.jar:${PORTSDIR}/textproc/xml-commons
+FOP_RUN_DEPENDS:= ${FOP_BUILD_DEPENDS}
+FOP_ALL_TARGET= fop
post-patch:
${REINPLACE_CMD} -e 's|/usr/share/java/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/fop.properties
@@ -53,10 +41,8 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/share/java/|${JAVALIBDIR}/|' ${WRKSRC}/fop.properties
do-install:
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath.jar
- ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath-fop.jar
-.if ${PORT_OPTIONS:MEXAMPLES}
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath.jar
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jlatexmath-fop.jar
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>