aboutsummaryrefslogtreecommitdiff
path: root/math/jts/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2013-02-16 23:57:07 +0000
committerWen Heping <wen@FreeBSD.org>2013-02-16 23:57:07 +0000
commitf639f41d7279eb74fca04e61261daea8bdd502a4 (patch)
treed17940824c275d480bdd150a02e43e47a6499bcf /math/jts/Makefile
parent7d7b4e173f366359012c87e026da1212e5db7573 (diff)
Notes
Diffstat (limited to 'math/jts/Makefile')
-rw-r--r--math/jts/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/math/jts/Makefile b/math/jts/Makefile
index 0da8f2824e8a..1a054bbe9f88 100644
--- a/math/jts/Makefile
+++ b/math/jts/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: jts
-# Date created: 22 May 2005
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= jts
-PORTVERSION= 1.12
+PORTVERSION= 1.13
CATEGORIES= math databases
MASTER_SITES= SF/${PORTNAME}-topo-suite/${PORTNAME}/${PORTVERSION}
-MAINTAINER= wen@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= JTS Topology Suite
RUN_DEPENDS= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom \
@@ -25,12 +21,14 @@ NO_WRKSUBDIR= yes
VER= ${PORTVERSION:L}
JARFILES= JTS_Test acme jts-${VER}
+.include <bsd.port.options.mk>
+
do-install:
.for jar in ${JARFILES}
${INSTALL_DATA} ${WRKSRC}/lib/${jar}.jar \
${JAVAJARDIR}/${jar:S|-${VER}||}.jar
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
@cd ${WRKDIR}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."