aboutsummaryrefslogtreecommitdiff
path: root/math/k3dsurf
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-02-20 08:57:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-02-20 08:57:48 +0000
commit74331843f6e181339c6ae87c373c11a53e022670 (patch)
treed83891545bd86033d91b663a79b6ad3bed77f40d /math/k3dsurf
parentefe40190bb511795d782c7d4b38a6bd08e5143dd (diff)
downloadports-74331843f6e181339c6ae87c373c11a53e022670.tar.gz
ports-74331843f6e181339c6ae87c373c11a53e022670.zip
Notes
Diffstat (limited to 'math/k3dsurf')
-rw-r--r--math/k3dsurf/Makefile35
-rw-r--r--math/k3dsurf/distinfo3
-rw-r--r--math/k3dsurf/files/patch-src_k3dsurf.ui9
-rw-r--r--math/k3dsurf/files/patch-src_newwindow2.ui9
-rw-r--r--math/k3dsurf/pkg-descr15
5 files changed, 71 insertions, 0 deletions
diff --git a/math/k3dsurf/Makefile b/math/k3dsurf/Makefile
new file mode 100644
index 000000000000..783a7832b9fe
--- /dev/null
+++ b/math/k3dsurf/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: K3DSurf
+# Date created: Sun 19 feb 2006
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= k3dsurf
+PORTVERSION= 0.5.4
+CATEGORIES= math graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Visualize and manipulate Mathematical surfaces or curves
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_QT_VER= 3
+QTDIR?= ${X11BASE}
+MAKE_ENV= QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++" \
+ QTDIR="${QTDIR}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/k3dsurf
+
+pre-build:
+ cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} qmake
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/k3dsurf ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/math/k3dsurf/distinfo b/math/k3dsurf/distinfo
new file mode 100644
index 000000000000..e705c6be5186
--- /dev/null
+++ b/math/k3dsurf/distinfo
@@ -0,0 +1,3 @@
+MD5 (k3dsurf-0.5.4-src.tar.gz) = 22d115057dd5adc122f7929e1a280003
+SHA256 (k3dsurf-0.5.4-src.tar.gz) = ba31d459ac8b9ea66e590c952107d784e4eda7f62c548573e4297c0de6f3fde6
+SIZE (k3dsurf-0.5.4-src.tar.gz) = 389139
diff --git a/math/k3dsurf/files/patch-src_k3dsurf.ui b/math/k3dsurf/files/patch-src_k3dsurf.ui
new file mode 100644
index 000000000000..7edbb63e3b23
--- /dev/null
+++ b/math/k3dsurf/files/patch-src_k3dsurf.ui
@@ -0,0 +1,9 @@
+--- src/k3dsurf.ui.orig Sat Dec 10 19:33:43 2005
++++ src/k3dsurf.ui Sun Feb 19 23:28:43 2006
+@@ -16329,6 +16329,5 @@
+ </slots>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>connectwidget.h</includehint>
+ </includehints>
+ </UI>
diff --git a/math/k3dsurf/files/patch-src_newwindow2.ui b/math/k3dsurf/files/patch-src_newwindow2.ui
new file mode 100644
index 000000000000..83f9e8c3b7cb
--- /dev/null
+++ b/math/k3dsurf/files/patch-src_newwindow2.ui
@@ -0,0 +1,9 @@
+--- src/newwindow2.ui.orig Wed Jul 27 00:16:36 2005
++++ src/newwindow2.ui Sun Feb 19 23:29:30 2006
+@@ -104,6 +104,5 @@
+ </slots>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>connectwidget.h</includehint>
+ </includehints>
+ </UI>
diff --git a/math/k3dsurf/pkg-descr b/math/k3dsurf/pkg-descr
new file mode 100644
index 000000000000..e24d61a908e1
--- /dev/null
+++ b/math/k3dsurf/pkg-descr
@@ -0,0 +1,15 @@
+K3DSurf is a program to visualize and manipulate multidimensional surfaces
+by using Mathematical equations. It's also a "Modeler" for POV-Ray in the
+area of parametric surfaces.
+
+Features :
+* 3D, 4D, 5D and 6D HyperObjects visualization.
+* Full support of all functions (like C language).
+* Support of mouse event in the drawing area (Left:Rotate, Right:scale
+ and Midle:translate).
+* Animation an Morph effect.
+* Povscript and Mesh file generation(and Run if povray is installed).
+ VRML2 and OBJ files also supported.
+* More than 100 well known examples.
+
+WWW: http://k3dsurf.sourceforge.net/