aboutsummaryrefslogtreecommitdiff
path: root/math/kalgebra
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /math/kalgebra
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
downloadports-a2d3b5a4bc5047210b788a128596ec34749ffa11.tar.gz
ports-a2d3b5a4bc5047210b788a128596ec34749ffa11.zip
Notes
Diffstat (limited to 'math/kalgebra')
-rw-r--r--math/kalgebra/Makefile42
-rw-r--r--math/kalgebra/distinfo2
-rw-r--r--math/kalgebra/pkg-descr5
-rw-r--r--math/kalgebra/pkg-plist40
4 files changed, 89 insertions, 0 deletions
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
new file mode 100644
index 000000000000..d0789cda0eb2
--- /dev/null
+++ b/math/kalgebra/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: kalgebra
+# Date created: 5 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kalgebra
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= math kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE 4 graph calculator
+
+LIB_DEPENDS= keduvocdocument.5:${PORTSDIR}/misc/libkdeedu
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui opengl script scripttools xml \
+ moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+OPTIONS= READLINE "Install console interface" on
+
+.include <bsd.port.options.mk>
+
+.ifndef(WITHOUT_READLINE)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+PLIST_SUB+= READLINE=""
+.else
+CMAKE_ARGS+= -DWITH_Readline:BOOL=FALSE
+PLIST_SUB+= READLINE="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/kalgebra/distinfo b/math/kalgebra/distinfo
new file mode 100644
index 000000000000..7ab9a734c0b3
--- /dev/null
+++ b/math/kalgebra/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/kalgebra-4.7.2.tar.bz2) = 85f213eb34042bf2ec4a4c481fb48b60821aed247b438502415387c4ee5611b7
+SIZE (KDE/kalgebra-4.7.2.tar.bz2) = 232924
diff --git a/math/kalgebra/pkg-descr b/math/kalgebra/pkg-descr
new file mode 100644
index 000000000000..5aa3fa36bad7
--- /dev/null
+++ b/math/kalgebra/pkg-descr
@@ -0,0 +1,5 @@
+KAlgebra is a mathematical calculator based on content markup MathML
+language, capable to make simple MathML operations (arithmetic and
+logical) and to representate 2D and 3D graphs.
+
+WWW: http://www.kde.org/applications/education/kalgebra
diff --git a/math/kalgebra/pkg-plist b/math/kalgebra/pkg-plist
new file mode 100644
index 000000000000..4cdb1b426268
--- /dev/null
+++ b/math/kalgebra/pkg-plist
@@ -0,0 +1,40 @@
+%%READLINE%%bin/calgebra
+bin/kalgebra
+bin/kalgebramobile
+lib/kde4/plasma_applet_kalgebra.so
+lib/libanalitza.so
+lib/libanalitza.so.5
+lib/libanalitza.so.5.0.1
+lib/libanalitzagui.so
+lib/libanalitzagui.so.5
+lib/libanalitzagui.so.5.0.1
+share/applications/kde4/kalgebra.desktop
+share/applications/kde4/kalgebramobile.desktop
+share/apps/kalgebra/scripts/console/console.js
+share/apps/kalgebra/scripts/console/kalgebraconsole.desktop
+share/apps/kalgebra/scripts/plot2d/kalgebraplot2d.desktop
+share/apps/kalgebra/scripts/plot2d/plot2d.js
+share/apps/kalgebra/scripts/tables/kalgebratables.desktop
+share/apps/kalgebra/scripts/tables/tables.js
+share/apps/kalgebra/scripts/variables/kalgebravariables.desktop
+share/apps/kalgebra/scripts/variables/variables.js
+share/apps/katepart/syntax/kalgebra.xml
+share/doc/HTML/en/kalgebra/commands.docbook
+share/doc/HTML/en/kalgebra/common
+share/doc/HTML/en/kalgebra/index.cache.bz2
+share/doc/HTML/en/kalgebra/index.docbook
+share/doc/HTML/en/kalgebra/kalgebra-main-window.png
+share/icons/hicolor/128x128/apps/kalgebra.png
+share/icons/hicolor/16x16/apps/kalgebra.png
+share/icons/hicolor/32x32/apps/kalgebra.png
+share/icons/hicolor/48x48/apps/kalgebra.png
+share/icons/hicolor/64x64/apps/kalgebra.png
+share/kde4/services/kalgebraplasmoid.desktop
+share/kde4/servicetypes/kalgebrascript.desktop
+@dirrm share/doc/HTML/en/kalgebra
+@dirrm share/apps/kalgebra/scripts/variables
+@dirrm share/apps/kalgebra/scripts/tables
+@dirrm share/apps/kalgebra/scripts/plot2d
+@dirrm share/apps/kalgebra/scripts/console
+@dirrm share/apps/kalgebra/scripts
+@dirrm share/apps/kalgebra