aboutsummaryrefslogtreecommitdiff
path: root/math/kamis
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-13 03:15:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-13 03:16:19 +0000
commit3e31e1530fa3087611f35910d75ac67a0cd1f186 (patch)
tree2d7e720bd83dd97bf41c3a851ceb7b9951dadeab /math/kamis
parent315897eb2a2b0a6d65a00712f5113404b2e212c9 (diff)
downloadports-3e31e1530fa3087611f35910d75ac67a0cd1f186.tar.gz
ports-3e31e1530fa3087611f35910d75ac67a0cd1f186.zip
Diffstat (limited to 'math/kamis')
-rw-r--r--math/kamis/files/patch-wmis_CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/math/kamis/files/patch-wmis_CMakeLists.txt b/math/kamis/files/patch-wmis_CMakeLists.txt
new file mode 100644
index 000000000000..d528aa714b66
--- /dev/null
+++ b/math/kamis/files/patch-wmis_CMakeLists.txt
@@ -0,0 +1,13 @@
+- workaround for https://github.com/KarlsruheMIS/KaMIS/issues/30
+
+--- wmis/CMakeLists.txt.orig 2022-07-13 03:12:06 UTC
++++ wmis/CMakeLists.txt
+@@ -5,7 +5,7 @@ if (NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Release)
+ endif (NOT CMAKE_BUILD_TYPE)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fno-omit-frame-pointer -march=native -DNDEBUG -fPIC -O3 ")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fno-omit-frame-pointer -DNDEBUG -fPIC -O3 ")
+
+ CHECK_CXX_COMPILER_FLAG(-Wno-unused-value COMPILER_SUPPORTS_NOUNUSED)
+ if(COMPILER_SUPPORTS_NOUNUSED)