aboutsummaryrefslogtreecommitdiff
path: root/math/kash3
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-12-09 17:56:35 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-12-09 17:56:35 +0000
commit92a9f734a498995d6c42ab687f299eba3d6911eb (patch)
tree3c8c5abdca57aee857be1046a13e050c43c02f8a /math/kash3
parentaec0e09426b8c188ecaa1d5ee84d608ceb2874e4 (diff)
downloadports-92a9f734a498995d6c42ab687f299eba3d6911eb.tar.gz
ports-92a9f734a498995d6c42ab687f299eba3d6911eb.zip
Notes
Diffstat (limited to 'math/kash3')
-rw-r--r--math/kash3/Makefile27
-rw-r--r--math/kash3/distinfo9
-rw-r--r--math/kash3/pkg-plist39
3 files changed, 51 insertions, 24 deletions
diff --git a/math/kash3/Makefile b/math/kash3/Makefile
index 378a7c0b2a0d..5b24daa7a3cd 100644
--- a/math/kash3/Makefile
+++ b/math/kash3/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= kash3
-PORTVERSION= 2006.01.31
+PORTVERSION= 2008.07.31
CATEGORIES= math
MASTER_SITES= ftp://ftp.math.tu-berlin.de/pub/algebra/Kant/Kash_3/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/
-DISTNAME= ${PORTNAME:U}-${ELFTYPE}-${PORTVERSION:S|.|-|g}
+DISTFILES= ${PORTNAME:U}-${ELFTYPE}-i686-${PORTVERSION:S|.|-|g}.tar.bz2
MAINTAINER= nivit@FreeBSD.org
COMMENT= A computer algebra system for computing in algebraic number fields
@@ -20,11 +20,16 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
NO_CDROM= not for commercial distribution or use
NO_BUILD= yes
+OPTIONS= OPTLIB "Install optional functions library" on
+
+PLIST_SUB= OPTLIB=${OPTLIB}
+
USE_BZIP2= yes
USE_LINUX= yes
SUB_FILES= ${PORTNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME:U}-${ELFTYPE}-i686-${PORTVERSION:S|.|-|g}
+
FIND_DATA= -type f -mindepth 1 -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
FIND_DIRS= -type d -exec ${MKDIR} ${DATADIR}/{} \;
@@ -37,18 +42,30 @@ FIND_HERE+= html pdf
LN_OPTS= -sf
ELFTYPE= Linux
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPTLIB)
+DISTFILES+= ${PORTNAME:U}-lib-archindep-${PORTVERSION:S|.|-|g}.tar.bz2
+OPTLIB=
+.else
+OPTLIB= "@comment "
+.endif
+
do-install:
${MKDIR} ${DATADIR};
+.if defined(WITH_OPTLIB)
+ cd ${WRKDIR}/${PORTNAME:U}-lib-archindep-${PORTVERSION:S|.|-|g}; \
+ ${COPYTREE_SHARE} . ${DATADIR}
+.endif
cd ${WRKSRC}; \
${FIND} ${FIND_HERE} ${FIND_DIRS}; \
${FIND} ${FIND_HERE} ${FIND_DATA}; \
${BRANDELF} -t ${ELFTYPE} ${PORTNAME}; \
${INSTALL_PROGRAM} ${PORTNAME} ${DATADIR}/${PORTNAME};
${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${PREFIX}/bin/${PORTNAME}
-
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}; \
${MV} ${DATADIR}/html ${DATADIR}/pdf ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/kash3/distinfo b/math/kash3/distinfo
index 4e5001b39e22..b47b6408f0e7 100644
--- a/math/kash3/distinfo
+++ b/math/kash3/distinfo
@@ -1,3 +1,6 @@
-MD5 (KASH3-Linux-2006-01-31.tar.bz2) = 5ebf5555a05258668721366fa9b095f6
-SHA256 (KASH3-Linux-2006-01-31.tar.bz2) = 2e0cb5376b23363650f5633ce50a9cd11efc4affb422da53c66adac7bfe150c0
-SIZE (KASH3-Linux-2006-01-31.tar.bz2) = 17325719
+MD5 (KASH3-Linux-i686-2008-07-31.tar.bz2) = 3373d76d7a4ae9586db16bc4e1885cf8
+SHA256 (KASH3-Linux-i686-2008-07-31.tar.bz2) = c88a28b21d8b75dc5a66f54cbb5078c4f32ef1aace28fecbe664803a0f34a360
+SIZE (KASH3-Linux-i686-2008-07-31.tar.bz2) = 17334852
+MD5 (KASH3-lib-archindep-2008-07-31.tar.bz2) = 6ef418ae6f60d1fa79c71f1c44ba8b5f
+SHA256 (KASH3-lib-archindep-2008-07-31.tar.bz2) = eaaf650c20b1c5d27445380dd23f0bfedeb057b8c7c9561cce0c369081104af9
+SIZE (KASH3-lib-archindep-2008-07-31.tar.bz2) = 3367591
diff --git a/math/kash3/pkg-plist b/math/kash3/pkg-plist
index b6089ca72749..0e3cf84f37ec 100644
--- a/math/kash3/pkg-plist
+++ b/math/kash3/pkg-plist
@@ -3609,6 +3609,7 @@ bin/kash3
%%PORTDOCS%%%%DOCSDIR%%/html/reference.html
%%PORTDOCS%%%%DOCSDIR%%/pdf/gap3proglang.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/kash3intro.pdf
+%%DATADIR%%/README
%%DATADIR%%/data/Galois/conj1.dat
%%DATADIR%%/data/Galois/conj1.ind
%%DATADIR%%/data/Galois/conj10.dat
@@ -5043,6 +5044,8 @@ bin/kash3
%%DATADIR%%/gap/two/twogpd7.grp
%%DATADIR%%/gap/two/twogpd8.grp
%%DATADIR%%/kash3
+%%OPTLIB%%%%DATADIR%%/lib/ModPoly.k
+%%OPTLIB%%%%DATADIR%%/lib/MultPol.k
%%DATADIR%%/lib/XML.g
%%DATADIR%%/lib/__DOC.g
%%DATADIR%%/lib/alff.g
@@ -5052,8 +5055,11 @@ bin/kash3
%%DATADIR%%/lib/docui.g
%%DATADIR%%/lib/elldoc.g
%%DATADIR%%/lib/elliptic.g
+%%OPTLIB%%%%DATADIR%%/lib/ideals.k
%%DATADIR%%/lib/init-methods.g
%%DATADIR%%/lib/init.g
+%%OPTLIB%%%%DATADIR%%/lib/iso.k
+%%OPTLIB%%%%DATADIR%%/lib/isoinit.k
%%DATADIR%%/lib/kash.g
%%DATADIR%%/lib/list.g
%%DATADIR%%/lib/locFact.g
@@ -5063,29 +5069,30 @@ bin/kash3
%%DATADIR%%/lib/method.g
%%DATADIR%%/lib/qaos.k
%%DATADIR%%/lib/term.g
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/cgi-bin
+%%OPTLIB%%%%DATADIR%%/lib/unit_group_res.g
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/diamond
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/Zcrown
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/CeBIT/2004
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/CeBIT
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/Zcrown
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo/diamond
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/kantlogo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/cgi-bin
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/data/Galois
-@dirrm %%DATADIR%%/data/TrnGps
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/gap/two
+@dirrm %%DATADIR%%/gap/tom
+@dirrm %%DATADIR%%/gap/thr
+@dirrm %%DATADIR%%/gap/tbl
+@dirrm %%DATADIR%%/gap/sml/idlib
+@dirrm %%DATADIR%%/gap/sml
+@dirrm %%DATADIR%%/gap/lib
+@dirrm %%DATADIR%%/gap/grp
+@dirrm %%DATADIR%%/gap
@dirrm %%DATADIR%%/data/ecpp/Data/Weber
@dirrm %%DATADIR%%/data/ecpp/Data
@dirrm %%DATADIR%%/data/ecpp
+@dirrm %%DATADIR%%/data/TrnGps
+@dirrm %%DATADIR%%/data/Galois
@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%/gap/grp
-@dirrm %%DATADIR%%/gap/lib
-@dirrm %%DATADIR%%/gap/sml/idlib
-@dirrm %%DATADIR%%/gap/sml
-@dirrm %%DATADIR%%/gap/tbl
-@dirrm %%DATADIR%%/gap/thr
-@dirrm %%DATADIR%%/gap/tom
-@dirrm %%DATADIR%%/gap/two
-@dirrm %%DATADIR%%/gap
-@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%